LINUX.ORG.RU

Creative Audigy: работает только выход на колонки


0

1

Стоит Creative Audigy, работает только гнездо выхода для колонок. Встроенная аудиокарта отключена в биосе, при ее включении видно обе но используется по умолчанию встроенная и не переключить вывод звука через внешнюю. На встроенной работают все разъемы. Как заставить работать все разъемы в Creative включая подключенные к ней через кабель разъемы на передней стенке системника? И есть ли вариант выбирать в системе карту по умолчанию (не нашел такого параметра)? И есть ли вариант вывод звука настроить на внешнюю, а микрофон настроить на внутреннюю, что б работали впаре? Система Debian Squeeze x64 stable, ALSA. Драйвер установлен с оф. репов (liblo10k1-0, ld10k1). Если я не ошибаюсь для нее я в мак оси ставил драйвер emu10k2

Вывод lspci | grep audio: 07:02.0 Multimedia audio controller: Creative Labs SB Audigy (rev 03) Вывод aplay -L: null Discard all samples (playback) or generate zero samples (capture) default:CARD=Intel HDA Intel, VT1828S Analog Default Audio Device front:CARD=Intel,DEV=0 HDA Intel, VT1828S Analog Front speakers surround40:CARD=Intel,DEV=0 HDA Intel, VT1828S Analog 4.0 Surround output to Front and Rear speakers surround41:CARD=Intel,DEV=0 HDA Intel, VT1828S Analog 4.1 Surround output to Front, Rear and Subwoofer speakers surround50:CARD=Intel,DEV=0 HDA Intel, VT1828S Analog 5.0 Surround output to Front, Center and Rear speakers surround51:CARD=Intel,DEV=0 HDA Intel, VT1828S Analog 5.1 Surround output to Front, Center, Rear and Subwoofer speakers surround71:CARD=Intel,DEV=0 HDA Intel, VT1828S Analog 7.1 Surround output to Front, Center, Side, Rear and Woofer speakers iec958:CARD=Intel,DEV=0 HDA Intel, VT1828S Digital IEC958 (S/PDIF) Digital Audio Output default:CARD=Audigy Audigy 1 [Unknown], ADC Capture/Standard PCM Playback Default Audio Device front:CARD=Audigy,DEV=0 Audigy 1 [Unknown], ADC Capture/Standard PCM Playback Front speakers rear:CARD=Audigy,DEV=0 Audigy 1 [Unknown], ADC Capture/Standard PCM Playback Rear speakers center_lfe:CARD=Audigy,DEV=0 Audigy 1 [Unknown], ADC Capture/Standard PCM Playback Center and Subwoofer speakers surround40:CARD=Audigy,DEV=0 Audigy 1 [Unknown], ADC Capture/Standard PCM Playback 4.0 Surround output to Front and Rear speakers surround41:CARD=Audigy,DEV=0 Audigy 1 [Unknown], ADC Capture/Standard PCM Playback 4.1 Surround output to Front, Rear and Subwoofer speakers surround50:CARD=Audigy,DEV=0 Audigy 1 [Unknown], ADC Capture/Standard PCM Playback 5.0 Surround output to Front, Center and Rear speakers surround51:CARD=Audigy,DEV=0 Audigy 1 [Unknown], ADC Capture/Standard PCM Playback 5.1 Surround output to Front, Center, Rear and Subwoofer speakers iec958:CARD=Audigy,DEV=0 Audigy 1 [Unknown], ADC Capture/Standard PCM Playback IEC958 (S/PDIF) Digital Audio Output

★★★

Чем пользуешься? Альса, осс, есть ли пульса поверх? ДЕ какой? Если кеды, карта по дефолту ставится в systemsettings. ЗЫ как ты так «отключил в биосе», что видно обе?!

erfea ★★★★★ ()
Ответ на: комментарий от erfea

только ALSA, стоит gnome 2.30.2. Отключил в биосе просто поставив disable напротив названия встроенной карточки, видно обе звуковухи в регуляторе громкости ALSA (выбираются в выпадающем списке)

zevilz ★★★ ()
Ответ на: комментарий от zevilz

Как самый простой вариант, lspci -v, найти модуль используемый встроенной звушкой, вписать его в блеклист, ..., профит.

erfea ★★★★★ ()

lspci -v: 07:02.0 Multimedia audio controller: Creative Labs SB Audigy (rev 03)    Subsystem: Creative Labs Device 005a    Flags: bus master, medium devsel, latency 64, IRQ 17    I/O ports at e480 [size=32]    Capabilities: <access denied>    Kernel driver in use: EMU10K1_Audigy

zevilz ★★★ ()
Ответ на: комментарий от zevilz

Прочитай повнимательнее, я предложил вариант как отрубить встроенную звушку, как самый простой вариант решения задачи.

erfea ★★★★★ ()
Ответ на: комментарий от erfea

Я и в биосе ее могу отключить. Мне надо, чтобы все разъемы на внешней звуковухе работали, или хотя бы микрофон заработал. Все настройки в альсе перетыкал, сигнала от микрофона нет(((

zevilz ★★★ ()
Ответ на: комментарий от zevilz

Значит не все перетыкал, надо во первых включить миксер аппаратный, во вторых микрофонный вход (не перепутать физически гнездо для него), а так же включить непосредственно захват и захват в общий контур миксера (если желаешь слышать себя в колонках). Аудиджи геморные звушки. Тоже касается и всех выходов, нужно всё включать. УМВР, audigy 2 SZ и была еще 4 (сгорела).

erfea ★★★★★ ()
Ответ на: комментарий от erfea

Поставил alsa-oss, alsa-tools,liblo10k1-dev, libasound2-dev, qlo10k1 и libqt3-mt, включил все ползунки в миксере, все активировал, пришел попить кофе, прихожу, втыкаю наушники с микрофоном и... микрофон заработал) Другие только разъемы не проверял. Я вот только не понял из-за чего заработал микрофон, то ли из-за установленных пакетов, то ли наковырял рабочую конфигурацию миксера. Вот только бесит, то что постоянно некоторые настройки миксера постоянно сами отключаются, другие постоянно включаются при закрытии окошка, а если убавляешь на время микрофон, то чтобы его прибавить, необходимо закрыть окно миксера и включить его, а потом потянуть ползунок вверх.

zevilz ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.