LINUX.ORG.RU

У кого-нить #nouveau + #compiz ещё роняют иксы?


0

1

Ночью окончательно достали глюки блоба, решил пересесть на nouveau. Даже готов терпеть отсутствие нормального 3D и vdpau.

Собралось, поставилось, работает.

Одно «но» — при попытке запустить compiz — мгновенно падают иксы:

Backtrace:
[ 28176.789] 0: /usr/bin/X (xorg_backtrace+0x3c) [0x80de1c8]
[ 28176.789] 1: /usr/bin/X (0x8047000+0x59b2b) [0x80a0b2b]
[ 28176.789] 2: (vdso) (__kernel_rt_sigreturn+0x0) [0xffffe40c]
[ 28176.789] 3: /usr/lib/xorg/modules/libexa.so (0xb75e5000+0xacf6) [0xb75efcf6]
[ 28176.789] 4: /usr/bin/X (0x8047000+0x14e0c9) [0x81950c9]
[ 28176.789] 5: /usr/lib/xorg/modules/extensions/libglx.so (0xb7651000+0x3295c) [0xb768395c]
[ 28176.789] 6: /usr/lib/dri/swrast_dri.so (0xb7322000+0x106b0) [0xb73326b0]
[ 28176.789] 7: /usr/lib/dri/swrast_dri.so (0xb7322000+0x106ec) [0xb73326ec]
[ 28176.789] 8: /usr/lib/xorg/modules/extensions/libglx.so (0xb7651000+0x328d7) [0xb76838d7]
[ 28176.789] 9: /usr/lib/xorg/modules/extensions/libglx.so (0xb7651000+0x2f40d) [0xb768040d]
[ 28176.789] 10: /usr/lib/xorg/modules/extensions/libglx.so (0xb7651000+0x301ab) [0xb76811ab]
[ 28176.789] 11: /usr/lib/xorg/modules/extensions/libglx.so (0xb7651000+0x31faa) [0xb7682faa]
[ 28176.789] 12: /usr/bin/X (0x8047000+0x27199) [0x806e199]
[ 28176.789] 13: /usr/bin/X (0x8047000+0x1b29a) [0x806229a]
[ 28176.789] 14: /lib/libc.so.6 (__libc_start_main+0xe7) [0x42898b83]
[ 28176.789] 15: /usr/bin/X (0x8047000+0x1ae81) [0x8061e81]
[ 28176.789] Segmentation fault at address (nil)
[ 28176.789].
Fatal server error:
[ 28176.789] Caught signal 11 (Segmentation fault). Server aborting
[ 28176.789].
[ 28176.789].
Please consult the The X.Org Foundation support.
     at http://wiki.x.org
 for help..

Пересобирал libc, xorg-server — пофиг. Сперва с «версионными» media-libs/mesa-7.10.2 и x11-drivers/xf86-video-nouveau-0.0.16_pre20110323, потом — с ними же из VCS.

x11-base/xorg-server-1.9.4, Gentoo.

Есть мысли?

★★★★★

Обновление до xorg-server-1.10.1 тоже не помогло.

KRoN73 ★★★★★ ()

Работоспособность нуво сильно зависит от видеокарты. И да, не указана версия ядра. У меня на GeForce 250 GTS c 2.6.38 хорошо работают и компиз, и кде, и даже гном-шелл. А вот на GeForce 8200 эффекты нормально работают только в KDE и только с XRender.

Vovka-Korovka ★★★★★ ()
Ответ на: комментарий от Vovka-Korovka

GF 210 + 2.6.38-gentoo-r2

А вот на GeForce 8200 эффекты нормально работают


Тут до эффектов дело вообще не доходит, иксы мгновенно сегфолтятся при запуске compiz'а.

KRoN73 ★★★★★ ()
Ответ на: комментарий от Deleted

>Возможно попался неудачный срез исходников драйвера.

Так я сперва пробовал «стабилизированный» 0.0.16_pre20110323, потом — текущий из GIT. Симптомы одинаковы.

KRoN73 ★★★★★ ()
Ответ на: комментарий от KRoN73

А вот на GeForce 8200 эффекты нормально работают только в KDE и только с XRender.

Тут до эффектов дело вообще не доходит, иксы мгновенно сегфолтятся при запуске compiz'а.

Немножко неточно написал. На 8200 попытки запустить компиз заканчиваются зависанием. Правда иксы не падают, хотя пригодится из консоли убивать сессию xfce. А на ядре 2.6.39 попытки запустить гном-шелл вообще приводят к падению ядра. Так что падение иксов это еще не самое страшное :-)

Vovka-Korovka ★★★★★ ()
Ответ на: комментарий от KRoN73

а если все-таки попробовать включить KMS?

MaZy ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.