LINUX.ORG.RU

Сенсоры...


0

0

Slackware 9.1/Linux 2.6.6rc1/lm-sensors 2.8.6;
на PIV2500/i845e/MSI MS-6555E.

Проблема в том, что сенсоры работают неверно. Т.е. температура = -1; обороты вентилятора 0.

В i2c работают (т.е. отображают данные в /sys) только Intel 801 (devices) и NS LM80 (sensors). Что нужно поставить чтобы это все заработало?

sensors:
lm80-i2c-0-2f
Adapter: SMBus I801 adapter at 0c00
+5V: +6.71 V (min = +6.71 V, max = +6.71 V) ALARM
VTT: +2.55 V (min = +2.55 V, max = +2.55 V) ALARM
+3.3V: +4.43 V (min = +4.43 V, max = +4.43 V) ALARM
+Vcore: +3.76 V (min = +3.76 V, max = +3.76 V) ALARM
+12V: +16.10 V (min = +16.10 V, max = +16.10 V) ALARM
-12V: -16.11 V (min = -16.11 V, max = -16.11 V) ALARM
-5V: -6.70 V (min = -6.70 V, max = -6.70 V) ALARM
fan1: 0 RPM (min = 0 RPM, div = 8) ALARM
fan2: 0 RPM (min = 0 RPM, div = 8) ALARM
temp: -1.00C (hot: limit = -1C, hyst = -1C) ALARM
: (os: limit = -1C, hyst = -1C) ALARM
alarms: Board temperature input (LM75) ALARM

lsmod:
Module Size Used by
lm80 16768 0
i2c_i801 8076 0
i2c_sensor 3456 1 lm80

Re: Сенсоры...

у меня что-то типа этого было, правда с другим чипсетом... попробуй при вызове sensors-detect использовать разные интерфейсы. там можно через ISA-bus, или через SMBus - они предлагают разный набор модулей. с одними работает, с другими нет:(

BuGfiX ()
Ответ на: Re: Сенсоры... от BuGfiX

Re: Re: Сенсоры...

ISA-bus и SMS-bus - это лишь протоколы доставки. Показывают одинакого (хотя последний может виснуть, собака страшная, выдавая неверные параметры).

jackill ★★★★★ ()
Ответ на: Re: Re: Сенсоры... от jackill

Re: Re: Re: Сенсоры...

А как вы используете lm-sensor под 2.6.x
 поясните Plllzzz ...


galchyonok ★★ ()
Ответ на: Re: Re: Сенсоры... от jackill

Re: Re: Re: Сенсоры...

Настроил я её все-таки. Если кто-то столкнется с подобным, вот мой теперешний lsmod:

key@ice:~$ lsmod
Module Size Used by
fglrx 212964 9
w83627hf 27140 0
i2c_isa 2816 0
i2c_sensor 3456 1
i2c_dev 9088 0

Только в такой комбинации это заработало. Кстати, сенсоры показывают у меня три термодатчика - на двух температура совпадает с показаниями в BIOS, а третий (его в BIOS'e нет) показывает -48C; но я на это забил.

2galchyonok: А в чем собственно проблема? Пересобрал ядро с i2c и установил как обычно.

SteelKey ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.