LINUX.ORG.RU

Почему при отключенном AHCI...


0

0

Загружается AHCI драйвер?

AHCI отключил в БИОСе, вместо sata_nv.ko как был ahci.ko, так и остался.

00:09.0 IDE interface: nVidia Corporation MCP78S [GeForce 8200] SATA Controller (non-AHCI mode) (rev a2) (prog-if 85 [Master SecO PriO])
	Subsystem: ASUSTeK Computer Inc. Device 82f2
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx+
	Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0 (750ns min, 250ns max)
	Interrupt: pin A routed to IRQ 27
	Region 0: I/O ports at c480 [size=8]
	Region 1: I/O ports at c400 [size=4]
	Region 2: I/O ports at c080 [size=8]
	Region 3: I/O ports at c000 [size=4]
	Region 4: I/O ports at bc00 [size=16]
	Region 5: Memory at fcf7a000 (32-bit, non-prefetchable) [size=8K]
	Capabilities: [44] Power Management version 2
		Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 PME-Enable- DSel=0 DScale=0 PME-
	Capabilities: [8c] SATA HBA <?>
	Capabilities: [b0] Message Signalled Interrupts: Mask- 64bit+ Queue=0/3 Enable+
		Address: 00000000fee0200c  Data: 4199
	Capabilities: [ec] HyperTransport: MSI Mapping Enable+ Fixed+
	Kernel driver in use: ahci
	Kernel modules: ahci

А через граб можно заблеклистить модуль?


Ответ на: комментарий от KPSS

>Он через initrd грузится, а туда-сюда пересобирать не охота его.

modprobe -r ahci

Led ★★★☆☆ ()

$ lspci -k |grep -i ahci

00:09.0 IDE interface: nVidia Corporation MCP78S [GeForce 8200] SATA Controller (non-AHCI mode) (rev a2)
	Kernel driver in use: ahci
	Kernel modules: ata_generic, pata_acpi, ahci, ide-pci-generic

anon_666 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.