LINUX.ORG.RU

Вебкамера Logitech Quickcam Express Plus не работает


0

0

ядро 2.6.35-rc6

dmesg:

[  615.274628] usb 1-1.4: New USB device found, idVendor=046d, idProduct=092f
[  615.274633] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[  615.274636] usb 1-1.4: Product: Camera
[  615.274639] usb 1-1.4: Manufacturer:         
[  615.274733] usb 1-1.4: usb_probe_device
[  615.274736] usb 1-1.4: configuration #1 chosen from 1 choice
[  615.274874] usb 1-1.4: adding 1-1.4:1.0 (config #1, interface 0)
[  615.274918] spca561 1-1.4:1.0: usb_probe_interface
[  615.274920] spca561 1-1.4:1.0: usb_probe_interface - got id
[  615.274922] gspca: probing 046d:092f
[  615.282799] input: spca561 as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.4/input/input5
[  615.282852] gspca: video0 created
[  615.282865] drivers/usb/core/inode.c: creating file '004'

lsmod:

Module                  Size  Used by
gspca_spca561           9714  0 

lsusb:

Bus 002 Device 003: ID 09da:000a A4 Tech Co., Ltd Port Mouse
Bus 002 Device 002: ID 8087:0020  
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 046d:092f Logitech, Inc. QuickCam Express Plus
Bus 001 Device 002: ID 8087:0020  
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

в /dev есть video0 и v4l ekiga выдает скриншот

xawtv ничего не показывает, в консоли вывод:

This is xawtv-3.95, running on Linux/x86_64 (2.6.35-rc6)
WARNING: v4l-conf is compiled without DGA support.
/dev/video0 [v4l2]: no overlay support
v4l-conf had some trouble, trying to continue anyway
Warning: Cannot convert string "-*-ledfixed-medium-r-*--39-*-*-*-c-*-*-*" to type FontStruct
ioctl: VIDIOC_G_STD(std=0x7fc989795b6a [PAL_B1,PAL_H,PAL_D,PAL_D1,PAL_M,PAL_N,PAL_60,NTSC_M,?,SECAM_B,SECAM_H,SECAM_K,SECAM_K1,SECAM_L,ATSC_16_VSB,(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null)]): Invalid argument
ioctl: VIDIOC_S_STD(std=0x0 []): Invalid argument
no way to get: 384x288 32 bit TrueColor (LE: bgr-)

Два года назад на убунте работала на ура. Подскажите что можно сделать чтобы она заработала сейчас.

Ответ на: комментарий от anon_666

спасибо, все заработало с

LD_PRELOAD=/usr/local/lib/libv4l/v4l1compat.so ekiga

orkshaman ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.