LINUX.ORG.RU

Частично перестает работать мышь Fedora12/KDE


0

0

Есть проблема, не смогли разобраться с чем связана... излазил весь гугл, яндекс и прочая, не смог обнаружить ничего похожего. Суть: Компьютер работает 24/7... Через 1-5 дня работы, начинается проблема с мышкой, изначально выражается с ошибками позиционирования и плохой реакцией на нажатие кнопок мыши. Ошибка позиционирования - это при движении, траектория не отрабатывается, а мышь првгает по экрану, может не «видеть» активного окна, считая предыдущее окно активным, определил правым кликом, показывает выпадающее меню характерное для оного. Плохая реакция на нажатие кнопок мыши - это значит происходит реакция на клик с 5-20 раза. Длится около часа. После чего, точность позиционирования восстанавливаетсся всегда и рекция на кнопки мыши так-же,, однако работает только для панели задачь, или меню запуска программ, с последним работает только на открытие меню, остальные действия только с клавиатуры. С последней проблем нет никаких вообще. С программами мышь не работает, все делаю через клавиатуру, в сети не очень удобно работать(((! Под другим пользователем запущенным параллельно(root), все прекрасно работает. Изредка, через несколько часов, все симптомы проходят и мышь продолжает работать в штатном режиме. Иногда, кратковременно восстанавливается работоспособность, но практически сразу начинаются проблемы по новой. Никаких настроек с мышью не производил, все по умолчанию. Проблема появилась только с установкой Fedora 12, в 11-й никаких проблем не было. Первоначально F12 была установлена на чистую систему и чистый винт(ранее писал о потере данных), после того как определил что восстановление не получиться, система была по новой установлена на другой чистый винт, не подключая старый(старый IDE 40Гб слишком медленен и мал для подключения к системе с 500гиговым винтом). Проблема появилась очень быстро, примерно через неделю. Перезагрузка решает проблему примерно на 1-5 суток. Перезагружаться резона нет, работает wget, на прошлой системе работал Teleport Pro под wine, вот разобрался с wget)))... льет ресурс небольшой но с большим количеством переходов, проблема в том что сканирование уже скачанного для продолжения работы длится около 30-50 часов... т.е. до 2-х суток работы в пустую. Мышек у меня 3 шт. 2 радио и 1 проводная. Радио - Оптические Logitech USB laser 1000, Logitech PS/2, Проводная APS USB. От смены мышки - ничего не меняется!

Система Fedora 12, обновления регулярные только со стабильных репов. Иксы - KDE.

З.ы. Возможный софт на подозрении: 1. Игра OpenTTD - первый раз проявилось сразу после установки ее в систему из репов, сейвы и настройки игры перемигрировали из прошлой системы(единственное что оттуда). Скорее всего простое совпадение но все-же. 2. wine - в прошлой системе проявлялось через некоторое время после его запуска и последующего завершения, последнее проблему не убирало. В данной системе, не уверен, т.к. компьютер перезагружался всего 1 раз, а wine все-же нужен иногда. Сорри за сумбур, если необходимы пояснения или листинг чего-либо, спрашивайте, только это я не очень опытный, всего пока не знаю, лучше сразу с командой спрашивать

З.ы.ы. Я пока не совсем понимаю принципов работы, но вопрос такой имеется, файл конфигурации мыши если онулить/удалить, хотя-бы для эксперимента, может поможет? Но где оно, я к сожалению не знаю!

З.ы.ы.ы. Обратил внимание, в панели задачь, там где иконки скрытых приложений, изредка что-то «моргает», т.е. появляется и сразу исчезает, заметил только что... и кажется после этих «морганий» мышь восстанавливает свою работоспособность.... пока писал, около 5 раз произошло, последних 3 раза проверил, восстанавливала, а потом снова переставала работать!

Дополнение

Перезапуск отдельно иксов, никак не влияет на работоспособность крысы!

Stiven ()
Ответ на: комментарий от legolegs

Если не считать того что для получения ссылки там мышка нужна... Ладно, произошло следующее, отключилась клава, полностью, через несколько минут, заработал Ctrl+F1... Перешел в консоль и обнаружил около 20-30 консолей root, убил... потом обратил внимание что памяти система зохавала почти гиг. Обычно не больше 300 метров, убил plasma-desktop, запустил... Окна появились, заработала клава, мышь, но рабочее окружение кед не появилось, только ранее открытые окна.... Опять частично отключилась мышь, срабатывает только после «правого клика» и только если в рабочей области окна находится, перетаскивать окна не может:

dmesg(когда все отрубилось): http://pastebin.com/m7a33bf78

htop: http://pastebin.com/d6abe284a

Stiven ()
Ответ на: комментарий от Stiven

Повытыкай все юсб-устройства и втыкли писипополамные клаву и мышь. Ещё обрати внимание на это:

sd 6:0:0:0: [sde] Unhandled error code
sd 6:0:0:0: [sde] Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK
end_request: I/O error, dev sde, sector 2254911

sde - это флешка? Короче избавься от этого девайся, потести его на другом компе.

legolegs ★★★★★ ()
Ответ на: комментарий от legolegs

Наконец добралсо ддо компа. Мышь работает, клав работает, вчера ничего не сделал, запустил plasma-desktop, пока работают!

Повытыкай все юсб-устройства и втыкли писипополамные клаву и мышь.

Раньше не помогало, но как только начнется, опробую! USB устройства в системе только сама мышь,и лампа подстветки. Судя, по dmesg это JetFlash TS4GJFV60, но это флешка, она давным давно отключена... через umount....

Stiven ()
Ответ на: комментарий от Stiven

> она давным давно отключена... через umount

Это не помешает ей посылать сигналы какому-нибудь hald (или что там должно регулярно опрашивать порты?).

question4 ★★★★★ ()
Ответ на: комментарий от question4

А как бы ее тогда правильно отключить? Если не через umount? Проблемы продолжаются, перезагрузка не всегда помогает, хотя, перезапуск plasma-desktop, похоже, помогает всегда...

Stiven ()
Ответ на: комментарий от Stiven

> А как бы ее тогда правильно отключить?

Единственный известный мне способ — физически. Наверное, можно и как-то изменить настройки демонов, либо plasma-desktop, но в них я не разбираюсь...

question4 ★★★★★ ()
Ответ на: комментарий от Stiven

Проблема решена, похоже окончательно! Начал устанавливать web-камеру... а она ни в какую, полез в нутренности системного блока к дополнительной шине USB и узрел...

Я когда-то давным давно, уже и не помню когда, но очень давно, года 4-5 нзд минимум. Купил у товарища за бутылку пива его разбитую трубу нокия. Работала, звонки даже принимала, только не работал экран, динамики, клавиатура, была разбита батарея и корпус, прочие примочки тоже... вибратор и прием/отправка тока работали. Ну я немного повозившись, сделал из этой трубы GPRS-модуль. Тогда то этих брелоков GPRS-USB не было. Купил симку, и лазал в сеть, только вот неудобная куча проводов была, я ее скрутил аккуратненько, подключил к БП компа(батареи то не было, а новая 500р стоит(((!) и кабелем нокиевским, к внутреннему USB подвесил. В форточках, понятное дело драйвер подвешивал и все ок... Потом появился интернет и анлим... На 8-11 Fedore я на кабель так и не смог дрова запустить(*nix драйвера не существует, под wine не получилось). Ну и забыл за эту самоделку. А счас случайно заметил... отключил, и мышка волшебным образом заработала, и web-камера)! Единтсвенное что перезагрузиться пришлось для web-камеры.

З.ы. В любом случае спасибо!

Stiven ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.