LINUX.ORG.RU

проблема с сетевой картой sis900 в Mandrake 9.1


0

0

материнка - какой то FIC на чипсете sis651 (видео встроенное, аудио встроенное, сеть тоже) harddrake опознает сетвую как sis900, на сайте произв указ RLT 8201 , модуль sis900 загружается, интерфейс eth0 стартует, даже определяет воткнут ли кабель или нет, а проблема в том что пересылка данных не идет. вот что в логах:

/var/log/messages Sep 17 17:05:41 avt07 kernel: sis900.c: v1.08.06 9/24/2002 Sep 17 17:05:41 avt07 kernel: eth0: Realtek RTL8201 PHY transceiver found at address 2. Sep 17 17:05:41 avt07 kernel: eth0: Using transceiver found at address 2 as default Sep 17 17:05:41 avt07 kernel: eth0: SiS 900 PCI Fast Ethernet at 0xe800, IRQ 19, 00:40:ca:58:bf:36. Sep 17 17:05:41 avt07 kernel: eth0: Media Link Off

Sep 17 17:05:40 avt07 network: Bringing up interface eth0: succeeded Sep 17 18:19:40 avt07 /etc/hotplug/net.agent: NET unregister event not supported Sep 17 18:20:00 avt07 CROND[3518]: (root) CMD ( /usr/share/sshd-monitor/sshd-restarter) Sep 17 18:20:09 avt07 kernel: sis900.c: v1.08.06 9/24/2002 Sep 17 18:20:09 avt07 kernel: eth0: Realtek RTL8201 PHY transceiver found at address 2. Sep 17 18:20:09 avt07 kernel: eth0: Using transceiver found at address 2 as default Sep 17 18:20:09 avt07 kernel: eth0: SiS 900 PCI Fast Ethernet at 0xe800, IRQ 19, 00:40:ca:58:bf:36. Sep 17 18:20:09 avt07 /etc/hotplug/net.agent: invoke ifplugd eth0 Sep 17 18:20:09 avt07 ifplugd[3530]: Warning: Could not get interface address. Sep 17 18:20:09 avt07 ifplugd[3530]: Using interface eth0/00:40:CA:58:BF:36 with driver sis900 v1.08.06 9/24/2002 Sep 17 18:20:09 avt07 ifplugd[3530]: ETHTOOL_GLINK failed: Operation not supported Sep 17 18:20:09 avt07 ifplugd[3530]: ifplugd 0.13 successfully initialized, link beat not detected. Sep 17 18:20:11 avt07 kernel: eth0: Media Link On 100mbps full-duplex Sep 17 18:20:11 avt07 ifplugd[3530]: Link beat detected. Sep 17 18:20:11 avt07 ifplugd[3530]: Executing '/etc/ifplugd/ifplugd.action eth0 up'. Sep 17 18:20:13 avt07 ifplugd[3530]: Program executed successfully. Sep 17 18:20:17 avt07 kernel: NETDEV WATCHDOG: eth0: transmit timed out Sep 17 18:20:17 avt07 kernel: eth0: Transmit timeout, status 00000004 00000249 Sep 17 18:20:25 avt07 kernel: NETDEV WATCHDOG: eth0: transmit timed out Sep 17 18:20:25 avt07 kernel: eth0: Transmit timeout, status 00000004 00000249 Sep 17 18:20:33 avt07 kernel: NETDEV WATCHDOG: eth0: transmit timed out Sep 17 18:20:33 avt07 kernel: eth0: Transmit timeout, status 00000004 00000249 Sep 17 18:20:41 avt07 kernel: NETDEV WATCHDOG: eth0: transmit timed out Sep 17 18:20:41 avt07 kernel: eth0: Transmit timeout, status 00000004 00000249

anonymous

Re: проблема с сетевой картой sis900 в Mandrake 9.1

А ядро то хоть какое? Похоже из-за IRQ 19, видимо ACPI не работающий
у тебя, можно попробовать в параметрах загрузки ядра указать noacpi...

McMCC ★★★ ()

Re: проблема с сетевой картой sis900 в Mandrake 9.1

ядро 2.4.21-13mdk пробовал пересобирать ядро с драйвером не модулем, тот же эфект, в параметрах загрузки ядра стоит acpi=off, но ядро его включает, в винь2000 на том же прерывание и тех же адресах работает, а в линуксе только arp пакеты отсылает, кот. видны в сети, а ответы на них отбрасывает. Отключил сетвушку в биосе и вставил проверенный intel pro 100mb PCI, тот же эфект :(

anonymous ()

Re: проблема с сетевой картой sis900 в Mandrake 9.1

у меня sys651 чипсет, сетевуха sys900 заработала после того, как в БИОСе отключил плуг-енд-плей. Осталась одна проблема со звуковой картой sys7012

anonymous ()

Re: проблема с сетевой картой sis900 в Mandrake 9.1

даже не знаю в чем проблема, П&П в биосе выключен, опция для запуска ядра acpi=off, подключил нормальную сетеву карту PCI (интел) то же, модуль драйвера запускается, карта видится, а пакеты не шлет, даже арп, и в ifconfig растет количество пакетов TX overruns: ... когда включаю sis900 встроенную, то хоть arp пакеты в сеть попадают, но обратно они не приходят TX dropped увеличевается. Для проверки переткнул винт в другую машину (asus i845gl с rtl8101(8139 series))... перенастроил eth0 на другой драйвер и сеть заработала, с чем это может быть связано?

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.