LINUX.ORG.RU
решено ФорумAdmin

Внезапно отвалилась сеть: transmit timed out


0

1

Привет всем. Сегодня внезапно завалилась сеть на серваке. В /var/log/messages появились следующие сообщения:

Aug  3 11:23:11 core kernel: NETDEV WATCHDOG: eth0: transmit timed out
Aug  3 11:23:47 core last message repeated 3 times
Aug  3 11:24:59 core last message repeated 2 times
Aug  3 11:27:05 core last message repeated 2 times
Aug  3 11:28:47 core last message repeated 2 times
Aug  3 11:29:53 core kernel: NETDEV WATCHDOG: eth0: transmit timed out
Aug  3 11:30:59 core kernel: NETDEV WATCHDOG: eth0: transmit timed out
Aug  3 11:32:41 core last message repeated 2 times
Aug  3 11:33:53 core kernel: NETDEV WATCHDOG: eth0: transmit timed out
Aug  3 11:33:54 core kernel: input: AT Translated Set 2 keyboard as /class/input/input1
Aug  3 11:34:59 core kernel: NETDEV WATCHDOG: eth0: transmit timed out
Aug  3 11:35:47 core kernel: NETDEV WATCHDOG: eth0: transmit timed out
Aug  3 11:37:29 core last message repeated 2 times
Aug  3 11:39:17 core last message repeated 2 times
Aug  3 11:40:05 core kernel: NETDEV WATCHDOG: eth0: transmit timed out
Aug  3 11:40:49 core kernel: r8169: eth0: link up
Aug  3 11:42:37 core kernel: NETDEV WATCHDOG: eth0: transmit timed out
Aug  3 11:43:31 core kernel: NETDEV WATCHDOG: eth0: transmit timed out

А ethtool отдает вот что:

ethtool eth0
Settings for eth0:
        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Advertised auto-negotiation: Yes
        Speed: 1000Mb/s
        Duplex: Full
        Port: Twisted Pair
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: pumbg
        Wake-on: g
        Current message level: 0x00000033 (51)
        Link detected: yes
Хотя сеть 100Мb/s o_O. Плюс ко всему прочему он никак не реагирует на пропажу линка. Помогает только ребут. Мож кто сталкивался, не подскажите в чем дело?

Система RHEL 5.2Beta (Бету не ругать, она служит уже очень долгое время. И это первый раз такое)
Ядро 2.6.18-84
Сеть RTL8111/8168B PCI Express Gigabit

1) настает жопа сетевухе 2) кривой провод(да, да, я видел и такое - вроде все работает, но как-то хреново и фиг отловишь проблему) 3) настает жопа порту Catalyst 4) кривой драйвер

Это так сказать, брутфорс всех возможных причин. Может я еще что забыл, но эти 4 вспомнились сразу

Pinkbyte ★★★★★ ()

У RHEL 5.0 r8169 c 8168 плохо работал. Попробовать в другой порт свича, не значит, что порт битый, скорее просто договориться не могут. В опциях жестко прописать 100 полный дуплекс. Это если драйвер обновлять неохота. Линк то он видит, только считает что можно 1000.

Ну для начала, как советовали раньше, провод другой, ну или перебить джеки.

lvi ★★★★ ()
Ответ на: комментарий от Pinkbyte

На счет сетевухи, я тож так подумал сначала. Попробую как нить поменять сеть - если повторится.

tex paragraphs зло +1

zloywolk ()
Ответ на: комментарий от lvi

Каталист с Ж. Только там два порта с Ж))) магистральные. Остальные сотки. В одну из таких сотен и воткнут серв.

zloywolk ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.