LINUX.ORG.RU

kernel+ide_setup - проблема :-((


0

0

Люди, помогите решить проблему. Заключается вот в чем - когда собираю ядро сам, то оно при загрузке не принимает опцию hdd=ide-scsi, хотя ошибок не пишет и сам ide-scsi подгружает, только есессно без привязки к сидюку. Если гружусь в стандартном ядре - то все нормально. Пробовал на 2.4.18-27, 2.4.20-8, 2.4.20-18.9 (от РХцев) и 2.4.21 (с кернел.орг). dmesg выглядит примерно так (кусок): .... zone(1): 28656 pages. zone(2): 0 pages. Kernel command line: ro root=/dev/hda1 hdd=ide-scsi Initializing CPU#0 Detected 546.617 MHz processor. .... MSDOS FS: Using codepage 866 SCSI subsystem driver Revision: 1.00 scsi0 : SCSI host adapter emulation for IDE ATAPI devices

Это то что у меня получается. А вот в рабочем варианте: .... zone(2): 0 pages. Kernel command line: ro root=LABEL=/ hdd=ide-scsi ide_setup: hdd=ide-scsi Initializing CPU#0 Detected 546.617 MHz processor. .... MSDOS FS: Using codepage 866 hdc: ATAPI 40X CD-ROM drive, 128kB Cache, UDMA(33) Uniform CD-ROM driver Revision: 3.12 SCSI subsystem driver Revision: 1.00 scsi0 : SCSI host adapter emulation for IDE ATAPI devices Vendor: MATSHITA Model: CD-RW CW-7586 Rev: 1.08 Type: CD-ROM ANSI SCSI revision: 02

Где копать ?? Может быть забыл какую-нить опцию в ядре включить ??

Re: kernel+ide_setup - проблема :-((

проверь на наличие в конфиге ядра такие строчки:
CONFIG_BLK_DEV_IDESCSI=m
CONFIG_SCSI=m
CONFIG_BLK_DEV_SD=m
CONFIG_CHR_DEV_ST=m
CONFIG_BLK_DEV_SR=m
CONFIG_CHR_DEV_SG=m

DiMoN ★★★ ()

kernel+ide_setup - проблема :-((

Таже фигня :(( Даж уже и не знаю куда копать... может Груб шутит ??

NeoNMaN ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.