LINUX.ORG.RU

ATI V5200. [8.39.4] vs [8.44.3]. beryl, compiz, opera, quake III.


0

0

Видеокарта: ATI FireGL V5200. При дровах 8.39.4: Beryl не раб. т.к. нет composite в дровах. Compiz не раб. т.к. нет composite в дровах. Opera летает. Quake III ~100FPS при 1600x1200, на каждом пункте видеонастройки выбрана максимально крутая опция.

При дровах 8.44.3 Beryl в основном летает, но лагает на 0.5 сек, сжирая целое ядро проца при попытке: 1. Создать новое окно (секунды две). 2. Изменить размер окна (секунд пять, чёрт возьми). 3. Сразу после щелчка средней клавиши мыши (вход в режим вращения куба). Провисает где-то на 0.2 сек, после чего вращение летает.

Пока 1, 2, 3 не происходят, beryl "летает" со всеми прозрачностями, снегами, дождями.

Compiz. Если написать 'compiz', оно не находит "GLX_EXT_texture_from_pixmap" (а glxinfo эту строку печатает). Если написать 'compiz-start', xterm, в котором пишу это: 1. Может стать fullscreen 2. Может остаться где был, превратясь в белый прямоугольник. Наверное это лицо compiz, надо почитать мануал к нему аккуратнее.

Opera. Лагает в разных местах, что-то ждёт (strace показал, что она оттягивается где-то по полсекунды в вызове poll на сокете "/tmp/.X11-unix/X0". Особенно долго при наведении мыши на боковой 'panel toggle' (tools -> appearance -> panels -> [V]Show panel toggle at edge of window)

Quake III. При тех же установках ~30FPS.

Такие пироги с котятами. (бабушка, кто такие Скотята) icq 297566544

Re: ATI V5200. [8.39.4] vs [8.44.3]. beryl, compiz, opera, quake III.

Сынок, ты фаергыэл брал чтоб в игрушки играться, ага? Пробейте его айпи и черкните начальству.

Gharik ()
Ответ на: Re: ATI V5200. [8.39.4] vs [8.44.3]. beryl, compiz, opera, quake III. от iRunix

Re: ATI V5200. [8.39.4] vs [8.44.3]. beryl, compiz, opera, quake III.

>ССЗБ. Иди на винду, там все работает

а в LInux не должно?

я дома тож в ку3 играю(правда компиз/берил не использую)

S_Paul ★★★★★ ()

Re: ATI V5200. [8.39.4] vs [8.44.3]. beryl, compiz, opera, quake III.

К сожалению, по ряду причин помочь не могу. Начиная с того, что у меня другая ATI (HD2600XT), кончая тем, что beryl давно помер и приходится мучиться с compiz-fusion.

В общем, с 3D (GLQuake, UFO-AI, Googleearth, Warsow и т.п.) нареканий нет.

Compiz-fusion тормозит, но тормозит он всюду, в т.ч. на Intel 965, NVidia 6200 и т.п... Это вам не Beryl.

Если не считать тормозов, то проблема с compiz только одна - мерцающее проигрывание xvideo. Так что приходится на тулбаре держать две кнопки - metacity и compiz. Хочется "красивостей" - жмём вторую, надо кино посмотреть - первую. Но реально из-за тормозов compiz'а последнего времени, перестал им пользоваться. А вот на beryl просидел весь его период существования, от появления до смерти :) Правда, тогда ещё X800GTO стояла.

KRoN73 ★★★★★ ()

Re: ATI V5200. [8.39.4] vs [8.44.3]. beryl, compiz, opera, quake III.

XGL поставь. Да-да, костыли, знаю. Но работать будет.

svr4 ()
Ответ на: Re: ATI V5200. [8.39.4] vs [8.44.3]. beryl, compiz, opera, quake III. от svr4

Re: ATI V5200. [8.39.4] vs [8.44.3]. beryl, compiz, opera, quake III.

>XGL поставь. 

Он давно уже не собирается. С подобными ошибками:

 gcc -DHAVE_CONFIG_H -I. -I../include -DHAVE_DIX_CONFIG_H -DXGLServer -D_BSD_SOURCE -DHAS_FCHOWN -DHAS_STICKY_DIR_BIT -I/usr/include/freetype2 -I../include -I../include -I../Xext -I../composite -I../damageext -I../xfixes -I../Xi -I../mi -I../miext/shadow -I../miext/damage -I../render -I../randr -I../fb -O3 -march=prescott -fomit-frame-pointer -pipe -s -MT renderedge.lo -MD -MP -MF .deps/renderedge.Tpo -c renderedge.c  -fPIC -DPIC -o .libs/renderedge.o
In file included from /usr/include/X11/extensions/renderproto.h:31,
                 from glyphstr.h:30,
                 from picturestr.h:30,
                 from renderedge.h:29,
                 from renderedge.c:30:
/usr/include/X11/extensions/render.h:29: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'Glyph'
/usr/include/X11/extensions/render.h:30: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'GlyphSet'
/usr/include/X11/extensions/render.h:31: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'Picture'
/usr/include/X11/extensions/render.h:32: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'PictFormat'

KRoN73 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.