LINUX.ORG.RU

сеть есть только при запущенном wireshark


0

0

Привет All.
У меня подключение к провайдеру происходит напрямую. Т.е. мне выдали 
локальный адрес и адрес шлюза. Еще при настройке запросили MAC адрес.
Вчера я поменял мать и соответственно встроенную сетевуху. На всякий 
случай прописал туда старый MAC. Теперь связь есть только если 
интерфейс прослушивается в wireshark.

Вот мой /etc/network/interfaces

auto lo eth1 eth1:0
allow-hotplug eth1 eth1:0
iface eth1 inet static
	address 192.168.2.156
	netmask 255.255.255.0
	network 192.168.2.0
	broadcast 192.168.2.255
	gateway 192.168.2.99
	dns-nameservers 192.168.2.99
	hwaddress ether 00:17:31:3B:F5:C6 # Добавил только эту строку
iface eth1:0 inet static
	address 10.9.27.12
	netmask	255.255.0.0

что делать? тех. сапорт до понедельника не работает, да и не уверен 
что они смогут мне помочь.
★★

Re: сеть есть только при запущенном wireshark

Звони с суппорт и скажи им новый mac адрес, по другому видимо никак.

Reset ★★★★★ ()

Re: сеть есть только при запущенном wireshark

iface eth1 inet static
    ...
    up ip link set $IFACE promisc on
    down ip link set $IFACE promisc off

Хотя действительно лучше сказать техподдержке новый MAC (но они попросят подойти лично с паспортом).

AEP ★★★★★ ()

Re: сеть есть только при запущенном wireshark

Но MAC я поменял на старый. По крайней мере ifconfig так показывает. т.е для провайдера это должно быть прозрачно. И в том же wireshark видно, что пакеты исходящие от меня и ответы имеют правильный старый MAC.

Vinick ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.