LINUX.ORG.RU

XFree вешается при подключенной сети.


0

0

Тут есть подозрение на конфиг IRQ. Но меня больше всего удивляет вот следующее:

$ cat /proc/interrupts CPU0 0: 19265820 IO-APIC-edge timer 7: 0 IO-APIC-edge parport0 8: 1 IO-APIC-edge rtc 9: 1 IO-APIC-level acpi 10: 0 IO-APIC-edge MPU401 UART 14: 211584 IO-APIC-edge ide0 15: 846768 IO-APIC-edge ide1 169: 88630 IO-APIC-level uhci_hcd:usb1 177: 0 IO-APIC-level uhci_hcd:usb2 185: 1535315 IO-APIC-level EMU10K1, ohci_hcd:usb4 193: 329110 IO-APIC-level Intel ICH2, ohci_hcd:usb5, ohci1394 201: 1392206 IO-APIC-level eth0 209: 336 IO-APIC-level ohci_hcd:usb3, saa7133[0] 217: 5 IO-APIC-level ehci_hcd:usb6 225: 4624779 IO-APIC-level radeon@PCI:1:0:0 NMI: 0 LOC: 19265563 ERR: 0 MIS: 0

201-е прерывание -- это как и что? :-O

А собственно сабж: приходится кабель выдёргивать ДО момента запуска XFree (4.3.0, видяха radeon 9250 vivo, ядро 2.6.16 из дебиана). Иначе виснет вусмерть (при чём, похоже, только консоль -- винтом моргает потом).

До этот были как-то проблемы вроде как пакеты принимает и не передаёт, или наоборот. В несколько более другой конфигурации. Лампочками весело моргало, а пакеты в одну сторону не шли. Вставил PCI-ную карточку и забыл. А теперь вот слотов не хватает.

Матьплату апгрейдить не хочу. Посоветуйте что ли, от безысходности, USB-сетевуху.


Re: XFree вешается при подключенной сети.

Ну ты хоть для порядку ядро поновее возьми. Зачем люди страються, ошибки чинят?

fishor ()

Re: XFree вешается при подключенной сети.

можно попробовать поиграться с опциями ядра acpi_*, noapic, nolapic, noacpi. В первую очередь я бы попытался вырубить ACPI в биосе и применить опцию nolapic к едру. Далее, если не поможет, курить /usr/src/linux/Documentation/kernel-parameters.txt . Погугли на предмет самой материнки, возможно кто-то ужо знает рецепт.

bugmaker ★★★★☆ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.