LINUX.ORG.RU

Кулер перестает работать после сна

 , , , ,


0

2

Привет всем! У меня возникла проблема с кулером на ноутбуке. После сна (suspend), кулер пару секунд крутится и останавливается. И как бы высока температура проца не была, кулер не стартует. Если перезагрузиться, все работает штатно до первого сна.

После непродолжительных поисков, я нашел следующее в выводе sensors:

До сна:

acpitz-acpi-0
Adapter: ACPI interface
temp1: +40.1°C  (crit = +105.0°C) #Температура ниже Ядер на пару градусов

После сна:

acpitz-acpi-0
Adapter: ACPI interface
temp1: +26.8°C  (crit = +105.0°C) #Температура статична и не меняется до перезагрузки

Проблема появилась месяца 2 назад.

Пытался откатить ядро (вплоть до 4.19) и lm_sensors (на предыдущую версию) - без результатов.

dmesg молчит.

Подскажите, пожалуйста, в каком направлении копать?

Немного инфы:

Kernel: x86_64 Linux 5.4.2-zen1-1-zen
DE: Cinnamon 4.4.3
WM: Muffin
CPU: Intel Celeron N2840 @ 2x 2.5823GHz
GPU: Mesa DRI Intel(R) Bay Trail 
RAM: 2152MiB / 7843MiB

Если нужны выводы других команд, напишите. Спасибо!


Windows в дуалбуте нет?

dmesg молчит

может ты его пока не услышал? ;)

Поспешил я... Вот похожая тема: Проблема с кулером на ASUS X541SC Решилось так, от этого комментария и далее распутывается «клубок проблемы» (на мой взгляд).

anymouze ★★ ()
Последнее исправление: anymouze (всего исправлений: 1)
Ответ на: комментарий от anymouze

Испробовал варианты:

  1. загрузка с параметрами ядра - тоже поведение: после сна температура ACPI interface = +26.8°C;
  2. ручное изменение состояния всех cooling_device* на 1 после сна - кулер не стартует;
  3. использовать acer_es.pl, тоже самое.

Очень сильно волнует вопрос почему же температура ACPI становится статичной (+26.8°С) после сна? В этом я думаю главная проблема, т.к. отсюда берется информация по работе кулера: раз температура низкая, то кулер и включать не надо.

Raiim ()
Ответ на: комментарий от Raiim

загрузка с параметрами ядра - тоже поведение: после сна температура ACPI interface = +26.8°C;

Какие параметры использовали? (чтобы, повторно их не советовали)

ручное изменение состояния всех cooling_device* на 1 после сна - кулер не стартует

До сна ручное управление работает?

Очень сильно волнует вопрос почему же температура ACPI становится статичной (+26.8°С) после сна? В этом я думаю главная проблема, т.к. отсюда берется информация по работе кулера: раз температура низкая, то кулер и включать не надо.

Видимо, не совсем так. Связь есть (показания температуры не меняются, кулеры не включаются), но утверждать что на что влияет я не берусь.

Я бы начал изучать dmesg:

в первую очередь, всё что касается ACPI

  • в процессе загрузки
  • в момент засыпания
  • после пробуждения
  • опционально, в процессе выполнения каких-либо воздействий
anymouze ★★ ()

lmsensors могут врать сколько угодно, даже не показывая температуру, а вместо него показывая потребление. На работу это не влияет. Главное чтобы BIOS не был кривым. На аналогичном n4200 проблем не замечено. Так что или BIOS или кулер сломался.

anonymous ()

Проблема не в sensors, проблема в том, что у тебя superio после саспенда перестает обновлять показания температуры. Кулер перестает крутиться по той же причине: он видит, что по датчику температура низкая и останавливается. Во многих ноутах это софтово никак не настраивается, все сделано аппаратно.

Как вариант, можно попробовать вообще не грузить драйверы датчиков.

Khnazile ★★★★★ ()

Обновить BIOS, попробовать другой дистрибутив загрузить хотя бы в Live. Потому что если это какая-нибудь федора, то там багов может быть огромное количество.

anonymous ()
Ответ на: комментарий от Khnazile

Примерно 2 месяца назад все прекрасно работало! (системе 3,5 года) Поэтому я и думаю, что это софтверная проблема. На днях попробую начисто установленный Arch.

Как вариант, можно попробовать вообще не грузить драйверы датчиков.

Подскажите, как это реализовать?

Raiim ()
Ответ на: комментарий от Raiim

Отключить службу lm_sensors, например. или заблеклистить соответствующие драйверы в /etc/modprobe.d/. Все зависит от того, как реализована загрузка этих драйверов в конкретном дистрибутиве.

Khnazile ★★★★★ ()
Ответ на: комментарий от Raiim

раз уж речь зашла у меня тоже такая проблема с вентилятором на федоре. Останавливается время от времени, запускается только после ребута. На убунте или взять хотябы близкого родственника редхата опенсузе, которая тащит оттуда многое, такого не наблюдал. Но с поиском решения я пока не заморачивался

jtad ()
Ответ на: комментарий от Raiim

Много времени прошло с момента моего последнего поста.

В общем, попробовал разные дистрибутивы (Ubuntu 19.10/18.04/17.10, ElementaryOS 5.1.2 Hera, openSUSE 15.1) на предмет такой же проблемы - везде после просыпания кулер крутится пару секунд и встает.

Везде sensors выдает:

acpitz-acpi-0
Adapter: ACPI interface
temp1:        +26.8°C  (crit = +105.0°C)

Попробовал с Windows 10 провернуть тоже самое. Итог: после сна, кулер работает в штатном режиме.

Значит дело в Линуксе. Хотя странно: еще летом все работало и с оглядкой на это пробовал старые версии дистрибутива ubuntu. Но везде один и тот же результат.

Сегодня попробую еще чистый Arch.

Raiim ()
Ответ на: комментарий от Raiim

Значит дело в Линуксе.

Ясное дело!:-) Самое забавное то что если по искать в инете «fan stop after suspend» то чаще пишут что не могут остановить вентилятор. От рута посмотри

ls -al /sys/class/thermal/cooling_device*

что скажет?

SergeySVold ★★★★ ()
Ответ на: комментарий от Raiim

Попробовал с Windows 10 провернуть тоже самое. Итог: после сна, кулер работает в штатном режиме.

Значит дело в Линуксе. Хотя странно: еще летом все работало и с оглядкой на это пробовал старые версии дистрибутива ubuntu. Но везде один и тот же результат.

может ты выводы неверные делаешь? может что-то эта самая 10-ка делает с чем линукс не справляется*? ты же пробовал старые ядра и не помогло (хотя раньше работало – с твоих слов)

anonymous ()
Ответ на: комментарий от SergeySVold

ls -al /sys/class/thermal/cooling_device*:

lrwxrwxrwx 1 root root 0 фев 20 08:04 /sys/class/thermal/cooling_device0 -> ../../devices/virtual/thermal/cooling_device0
lrwxrwxrwx 1 root root 0 фев 20 08:04 /sys/class/thermal/cooling_device1 -> ../../devices/virtual/thermal/cooling_device1
lrwxrwxrwx 1 root root 0 фев 20 08:04 /sys/class/thermal/cooling_device2 -> ../../devices/virtual/thermal/cooling_device2
lrwxrwxrwx 1 root root 0 фев 20 08:05 /sys/class/thermal/cooling_device3 -> ../../devices/virtual/thermal/cooling_device3

может ты выводы неверные делаешь? может что-то эта самая 10-ка делает с чем линукс не справляется*? ты же пробовал старые ядра и не помогло (хотя раньше работало – с твоих слов)

Ради старых ядер и пробовал старые версии Ubuntu. Пытался на Арче откатить ядро (хотя бы на то, что стояло летом - v5.1), но не получилось, много «зависимостей» ломается. Хочу попробовать поэкспериментировать с Windows 8.1 и 7


Пытался отключить acpi в grub:

  • с параметром acpi=off система не стартует: висит на надписи загрузки ядра.
  • с параметром noapic система запустилась, но каких то изменений я не обнаружил.
Raiim ()
Ответ на: комментарий от Raiim

Дополнительно пытался следующие параметры загрузки:

  • acpi_osi=off
  • acpi_osi=copy_dsdt
  • acpi_osi=Windows
  • acpi_osi=!"Linux"

результат везде один и тот же.


После suspend в dmesg | grep acpi появляются следующие записи

[   74.310805] ACPI: EC: interrupt blocked
[   74.323359] ACPI: Preparing to enter system sleep state S3
[   74.325799] ACPI: EC: event blocked
[   74.325804] ACPI: EC: EC stopped
[   74.331586] ACPI: Low-level resume complete
[   74.331673] ACPI: EC: EC started
[   74.333628] ACPI: Waking up from system sleep state S3
[   74.341925] ACPI: EC: interrupt unblocked
[   74.379216] ACPI: EC: event unblocked
[   74.902810] acpi LNXPOWER:02: Turning OFF
[   74.903022] acpi LNXPOWER:01: Turning OFF
[   74.903221] acpi LNXPOWER:00: Turning OFF
Raiim ()
Ответ на: комментарий от Raiim

Блин! А что хоть за ноутбук? У меня в починке Lenovo G500 с Fedora на борту я такого эффекта добиться не могу.:-) За счет настроек bios и acpi добивался разных эффектов - то не возможно в suspend загнать, то через несколько секунд он опять запускается.. в общем разные вариации но вот чтобы один кулер засыпал…. такого не получается.

SergeySVold ★★★★ ()
Ответ на: комментарий от SergeySVold

а если по смотреть

cat /proc/acpi/wakeup

после пробуждения?

Хоть до, хоть после пробуждения, инфа в wakeup не меняется:

Device	S-state	  Status   Sysfs node
XHC1	  S4	*enabled   pci:0000:00:14.0
RP01	  S4	*disabled  pci:0000:00:1c.0
PXSX	  S4	*disabled
RP02	  S4	*disabled
PXSX	  S4	*disabled
RP03	  S4	*disabled  pci:0000:00:1c.2
PXSX	  S4	*disabled  pci:0000:02:00.0
RP04	  S4	*disabled  pci:0000:00:1c.3
PXSX	  S4	*disabled  pci:0000:03:00.0
		*disabled  platform:rtsx_pci_sdmmc.0
EHC1	  S3	*disabled
PWRB	  S4	*enabled   platform:PNP0C0C:00
BRCM	  S0	*disabled
BRC3	  S0	*disabled

Блин! А что хоть за ноутбук?

Ноутбук Acer Aspire ES1-311 с одним кулером) BIOS урезан донельзя. Также поставлялся из коробки с Windows 8.1

Raiim ()
Ответ на: комментарий от Raiim

По этой модели очень много сообщений о проблемах с спящим режимом. Вот решений попалось только одно.

I also have an Acer ES311 and I also had this hibernation >problem. I also installed the new 4.2 kernel today. But again no >success. Then I started trying weird things. The solution was turning off «xHCI Support» in the BIOS >Configuration. With this option you can enable/disable the >external USB3.0 controller.

Now the hibernate mode and turning off works perfectly fine.

SergeySVold ★★★★ ()
Последнее исправление: SergeySVold (всего исправлений: 1)