LINUX.ORG.RU

MegaRAID проблемы при загрузке

 , , ,


0

1

Здравствуйте. Столкнулся со странной проблемой.

Железо: мать - supermicro x9scm-f, проц intel xeon e3-1228, 2x8Gb RAM ECC Unbuffered, 128Gb SSD SATA, 1TB HDD SATA

RAID контроллер LSI MegaRAID SAS (ven 1000 dev 0073) к контроллеру подключено 4-ре SAS диска.

IPMI и BIOS обновлен до последней версии.

Суть, пока в MegaRAID контроллере не создан Virtual Drive (т.е. RAID) комп грузится нормально, все работает ништяк, система на SSD SATA, там все грузится.

Если я захожу в MegaRAID WebBIOS и создаю там RAID массив, то при загрузке компа после того как контроллер загрузился просто черный экран и моргает белый курсор!! Комп на ctrl+alt+del не реагирует, приходится ребутить через IPMI. В биос зайти тоже не могу, грузит до курсора, WebBIOS (ctrl+h) тоже не могу зайти.

Можно зайти только в cli тулзу MegaRAID при загрузке (ctrl+y), если через нее я удалю RAID командой -CfgClr -aALL и отправлю комп в ребут, то все ОК. Все работает!!!

Кто сталкивался?? Как мне заставить комп грузить с созданным RAID?

Подскажите люди добрые!

ЯННП. У тебя стоит система. Работает без рейда. Ты создаешь в контроллере рейд и считаешь, что система должна продолжить работать без реинсталла?

Deleted ()
Ответ на: комментарий от Deleted

Ты создаешь в контроллере рейд и считаешь, что система должна продолжить работать без реинсталла?

А что ей мешает работать без реинсталла?

Deleted ()
Ответ на: комментарий от Deleted

То, что прошивка контроллёра вполне может писать метаданные непосредственно на диск и затирать таблицу разделов хотя бы. Не, не в курсе? А ещё прошивка может несколько «сдвигать» LBA дисков. И много ещё чего может делать.

Deleted ()
Ответ на: комментарий от Deleted

подключено 4-ре SAS диска.

А если он 10 рейд собирает - тогда вообще не ясно чего он хочет. Даж теоретически загрузка не возможна. Если с RAID1 я еще как-то могу представить... То со всеми остальными уровнями - нет. Учить матчасть.

Deleted ()
Ответ на: комментарий от Deleted

Даж теоретически загрузка не возможна.

Объясни что ты имеешь в виду.

По поводу того, что у ТС перестаёт грузиться система после создания RAID, он же не написал, что у него ssd диск используется в RAID массиве. Насколько понимаю он его не трогает. В этом случае как грузилась система с SSD так и должна грузиться.

Но тут уже вопрос к ТС дать более полное описание.

anonymous ()
Ответ на: комментарий от anonymous

Причем тут агрузка с RAID10. Тут хохма в том, что в системе меняется как минимум порядок дисков и, скорее всего, загрузки. А если у него диск подключен к контроллеру и он его включает в массив - схрена ли он должен грузиться с него? Признаюсь, не внимательно прочитал стартовый пост. Но у него тупо система пытается грузиться с другого носителя.

Deleted ()

Ему вроде проприетарный драйвер нужен для работы. Но могу ошибаться. Давно это было. Ещё вроде этот драйвер работал только с ядром 2.6.9 от тогдашнего sles.

DELIRIUM ☆☆☆☆☆ ()
Ответ на: комментарий от Deleted

Но у него тупо система пытается грузиться с другого носителя.

вот тоже склоняюсь к такому выводу, но это не объясняет проблемы с заходом в WebBIOS после создания массива.

У нас похожая вещь была, когда у одного из дисков было плохое подключение и контроллер иногда зависал ожидая ответа, но там контроллер был совсем никакой.

anonymous ()

я пару лет назад на X9SCA мучался с запуском.

Пока в биосе не отключил все связанное с uefi - не взлетало.

Мне в эту мать нужно было воткнуть всего лишь 2 устройства: Adaptec ASR5805 и интеловская сетевушка X540-AT2 (10G).

На сетевой карте биос пришлось отключать переставит ее в другую машину.

Нет ли опции в мегарейде отключить доступ к VD через биос ( или сделать их недоступными для загрузки через биос) ?

Попробуй отключить биосы на встроенных сетевухах.

vel ★★★★★ ()
Последнее исправление: vel (всего исправлений: 2)

Ну и надо понимать, что из этого контроллера (SAS 2008 Falcon) так себе raid. Проще и эффективнее перешить его в IT mode и массив собрать софтовый.

Bloody ()
Ответ на: комментарий от Deleted

Суть в том, что после создания RAID не важно 10 это или 1-й или 0-вой, не суть какой, я пробовал разные, после инициализации RAID карты и дисков, идет надпись ...ctrl+h - webbios, ctrl+y cli консоль И ТУТ на этом месте даже просто в BIOS не зайти, в webbois тоже, работает только ctrl+y.

То есть когда создан RAID массив (Virtual Drive) то даже в BIOS от матери не зайдешь, жму DEL при включении компа и один хер он застревает на курсоре после надписей MegaRAID контроллера.

Удаляю Virtual Drive и можно заходить в BIOS и в WebBIOS и т.д.

Такая херня, тут до загрузки дело вообще не доходит, даже если Я подключу CD-ROM через IPMI не смогу систему установить, удалю VD то тогда он только диск читать начинает, в самом BIOS контроллер стоит на 3-м месте по загрузке. Сперва IPMI CD-Rom, потом SSD потом только контроллер.

dirsex ()
Ответ на: комментарий от dirsex

Так у вас свапнутый девайс, вам по любому его шить надо, скачивайте комплект прошивок и заливайте их, только смотрите не зашейте файл с словом SPD (емнип его размер 256 байт), это тайминги памяти, он сразу убьёт его.

steemandlinux ★★★★★ ()
Последнее исправление: steemandlinux (всего исправлений: 1)