LINUX.ORG.RU

ALSA нет звука

 ,


0

1
speaker-test

speaker-test 1.0.28

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
ALSA lib pcm_dmix.c:1022:(snd_pcm_dmix_open) unable to open slave
Playback open error: -2,No such file or directory

Даже в LXDE на панель не выводит Volume Control

Ответ на: комментарий от Vsevolod-linuxoid
00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 04)
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Cape Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series]
FM_Stick ()

Сравни вывод
aplay -l
с тем, какие устройства по-умолчанию указаны в /usr/share/alsa/alsa.conf

toney ★★★★★ ()
Ответ на: комментарий от FM_Stick

У тебя 3 аудиокарты: HDMI в видеокарте, HDMI в процессоре и аналоговая. Звук выводиться на одну из них, но она не подключена; его надо перенаправить на другую.

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от FM_Stick

Объясняю популярно. «default» в alsa - это устройство #0. У тебя звук пытается выводиться по HDMI вместо «Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller». С высокой долей вероятности, это не то что тебе нужно.

Тут есть два варианта: либо сменить дефолт (через alsa.conf), либо сменить порядок карт (через прописывание options snd slots=bla-bla). Второе, как ни странно проще.

anonymous ()
Ответ на: комментарий от FM_Stick

/etc/modprobe.d/local.conf

Заработает только после перезагрузки.

anonymous ()
Ответ на: комментарий от FM_Stick

btw, ты совершенно зря скопипастил оттуда строчку, имя драйвера у тебя будет другим, что-то типа snd_hda_intel

anonymous ()
Ответ на: комментарий от anonymous

Вставил в local.conf

options snd slots=snd-hda-intel
Но что то без результатов. А если вручную в cards поменять местами? Либо цифры изменить?

FM_Stick ()
Ответ на: комментарий от FM_Stick

«cards» - это генерируемый файлик, на основе того, как ядро видит звуковые карты.

snd-hda-intel

В оригинале были не "-", а «_». Не надо угадывать, посмотри точное имя через lsmod | grep intel

anonymous ()
Ответ на: комментарий от deep-purple

Я уже пробовал в alsamixer, там только в одном разделе подымаются и упоскаются ползунки, да и то они уже давно на максимуме.

FM_Stick ()
Ответ на: комментарий от Avial

Наушники, колонки. Да дело даже не в только в этом, тут в LXDE есть модуль для панели Volume Control, так вот он даже не ставится на панель, видимо проблема глубже чем вывод на колонки или наушники.

FM_Stick ()
Ответ на: комментарий от FM_Stick

https://wiki.debian.org/ru/ALSA#A.2BBCEEPgQyBDwENQRBBEIEPQQ.2BBDU_.2BBDgEQQQ....

Создать файл /home/username/.asoundrc со следующим содержанием:

defaults.pcm.!device 1
defaults.ctl.!device 1
ZenitharChampion ★★★★★ ()
Последнее исправление: ZenitharChampion (всего исправлений: 1)
Ответ на: комментарий от FM_Stick

запусти lxpanel из консоли, попробуй добавить апплет. все-таки вангую, что это из-за неверной аудикарты по умолчанию.
можешь сделать так - поставить audacious, там в настройках богатый выбор устройств вывода. и посмотреть, на котором зазвучит. и дальше танцевать от этого.

Avial ★★★★★ ()
Ответ на: комментарий от anonymous
Found hardware: "HDA-Intel" "Intel Haswell HDMI" "HDA:80862807,80860101,00100000" "0x8086" "0x2010"
Hardware is initialized using a generic method

Насчёт переключения default карты получилось так:

nano /etc/asound.conf

defaults.ctl.card 1
defaults.pcm.card 1

FM_Stick ()
Ответ на: комментарий от FM_Stick

Звук з'явився , чи ні ? З alsamixer ще пограйся . Після sudo alsactl init , там встановлюється гучність на 50% .

anonymous ()
Ответ на: комментарий от FM_Stick

Тоді не знаю . Мені завжди допомагало sudo alsactl init .

anonymous ()
Ответ на: комментарий от FM_Stick

Спробуй видалити те лайно , що тобі тут порадили . Віднови систему в початковий стан , видали зайві конфіги і знову виконай sudo alsactl init .

anonymous ()
Ответ на: комментарий от FM_Stick

Можно по русски?

Нам це не викладали . Англійську вчили , а твою мову - ні . Але завжди є Google - перекладач .

anonymous ()
Ответ на: комментарий от FM_Stick

Похоже, у тебя выставлен Mute в регуляторе громкости. Посмотри в alsamixer. Смменить карту на нужную. Нажать кнопку M, чтобы включить/выключить звук, и стрелочки вправо-влево, чтобы перемещаться по настройкам.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

Вообще нигде Mute нету, везде 00. Все ползунки на максимум поставил, когда микрофоны последнии подымаю появляется шип в наушниках.

FM_Stick ()

в микшере выбери нужное устройство

amorpher ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.