LINUX.ORG.RU

Первый драйвер с поддержкой Vulkan доступен для AMD

 , ,


0

2

Вчера, разработчик из AMD John Bridgman, на форуме phoronix.com представил превью первого драйвера с поддержкой Vulkan для видеокарт AMD, основанных на GCN 1.2. Главной отличительной особенностью драйвера является то, что что он построен на открытом модуле ядра - amdgpu. Список поддерживаемых видеокарт - AMD Radeon™ R9 Fury X, AMD Radeon™ R9 380X, AMD Radeon™ R9 Fury, AMD Radeon™ R9 380, AMD Radeon™ R9 Nano, AMD Radeon™ R9 285, AMD Radeon™ R9 M395X. Главные особенности:

  • OpenGL 4.5 and GLX 1.4
  • OpenCL 1.2
  • Vulkan 1.0
  • VDPAU
  • KMS
  • Базовая поддержка дисплеев
  • Базовые функции управления питанием

Недостатки:

  • Собран только для Ubuntu 14.04.4
  • Малое число поддерживаемых видеокарт
  • Нет поддержки мульти-GPU
  • Больше 3-х дисплеев не поддерживается
  • Только базовые функции поддержки дисплея и управлением питания.
  • Rand 1.4 не поддерживается
  • Opencl поддерживается не полностью
  • Suspend to disk (S4) не поддерживается

http://support.amd.com/en-us/kb-articles/Pages/AMDGPU-PRO-Beta-Driver-for-Vul...

Ждем историй успеха от лоровцев, которые могут его поставить.


ГлавноЙ отличительной особенностьЮ драйвера является то, что он построен на открытом модуле ядра - amdgpu.

kostik87 ★★★★★ ()

Интересно, как у него с производительностью?

Собран только для Ubuntu 14.04.4

Это называется «собран только для линукса, дистрибутивы ждут».

user42 ★★ ()
Ответ на: комментарий от user42

Судя по этому

Только базовые функции поддержки дисплея и управлением питания

Производительность будет не ахти. Самое главное, что есть первые результаты. Скорее всего, это amdgpu модуль с поддержкой Vulkan и OpenGL 4.5. Меня интересует, есть ли утилита управления, ака catalyst control center и поддержка разгона. Кстати, свежее сравнение amdgpu против nvidia - http://www.phoronix.com/scan.php?page=article&item=nvidia-amd-xenial&...

Solar ()

моя история успеха пока только запуск opencl и vulkanonfo, 3д увы не удалось запустить, убунтушные пакеты уж очень много перекрывают дистрибутивного, и довольно старые версии.

http://www.gearsongallium.com/?p=2939

Novell-ch ★★★★★ ()
Ответ на: комментарий от Novell-ch

А какое у тебя там ядро? Пробовал с 4.2?

anonymous ()
Ответ на: комментарий от iz_tabakerki

7850 это GCN1.0? Сейчас поддерживается только GCN1.2, как я понял обещали добавить 1.1 и подумать насчет 1.0.

Behem0th ★★★★★ ()
Ответ на: комментарий от Novell-ch

Вот интересно, оно же юзерспейсное полностью. Есть ли шанс использовать от этого только opencl и vulkanonfo а 3д месовское?

Behem0th ★★★★★ ()

Нет поддержки мульти-GPU
Только базовые функции поддержки дисплея и управлением питания.
Opencl поддерживается не полностью

Бетка, кароч.

anonymous ()

простите но это смешно

год назад я думал-покупать нвидию 7xx серию или радеон 2xx....

и я почемуто думал что вулкан будет для радеонов R7

и в то время как нвидия выпустила вулкан драйвер для пятилетних видеокарт....амд выпускает только для карт за последний год еще с такими фичами

Suspend to disk (S4) не поддерживается Opencl поддерживается не полностью

что скажут местные фанатики радеона(если такие остались,ибо уже самый тупой фанатик перешел на нвидию)

hif43872 ()
Ответ на: комментарий от Behem0th

Есть ли шанс использовать от этого только opencl и vulkanonfo а 3д месовское?

DO WANT!

anonymous ()
Ответ на: комментарий от hif43872

Успокойся, будет версия и для R7. Не может не быть, т.к. все бюджетные и средние видеокарты - GNC 1.0 и GCN 1.1. Популярный R7 370 - GCN 1.0. Это бета версия со всеми плюсами и недостатками.

Solar ()
Ответ на: комментарий от hif43872

А что скажут фанатеги членвидии на умышленное снижение производительности драйверами зеленых?

YLoS ★★★ ()
Ответ на: комментарий от YLoS

Что это миф? В худшем случае они плохо оптимизируют дрова для стаарых чипов под новые игры, но в падении производительности после обновления драйверов вроде замечены не были.

templarrr ★★★★★ ()
Ответ на: комментарий от Behem0th

оно так и есть, по сути опенкл только и работает, это все поверх нормальной месы, нужно только лд прелод выполнять для опенкл приложений, скорость выше кловера, наверно в финале еще будет лучше.

Novell-ch ★★★★★ ()
Ответ на: комментарий от Solar

Успокойся, будет версия и для R7. Не может не быть

Ну я бы так категорично не заявлял. Тем более что для венды сразу сделали http://support.amd.com/en-us/kb-articles/Pages/Radeon-Vulkan-Beta.aspx?webSyn...

Пока же пилить будут, время ещё идти будет, а там уже и не стыдно средний палец показать.

fornlr ★★★★★ ()
Последнее исправление: fornlr (всего исправлений: 1)
Ответ на: комментарий от fornlr

Ну это будет не логично. Зачем поддерживать два драйвера - RadeonSI и amdgpu для одного семейства. На форумах phoronix John Bridgman говорил, что для них главная задача - это доделать поддержку Southern Island, а это GCN 1.0, тем более что GCN 1.1 уже неоффициально работает.

Solar ()
Ответ на: комментарий от YLoS

А что скажут ... на умышленное снижение производительности драйверами зеленых?

Не знаю о чем там бабки на лавочках говорят, но если Nvidia этак в два раза понизит производительность своего драйвера под линуксами, то наверно будет причина переходить на AMD

fornlr ★★★★★ ()
Ответ на: комментарий от Novell-ch

Не совсем тебя понимаю. Ты говоришь что это будет или по факту? Если по факту то это клево, месовского 3д за исключением пары расширений хватает для всех игр. А подгрузить ради опенцл/вулкана лишнбб библиотеку так даже удобней.

cкорость выше кловера, наверно в финале еще будет лучше.

Надеюсь что на кловер не забьют и он в конечном итоге будет самый бысрый.

Behem0th ★★★★★ ()
Ответ на: комментарий от hif43872

Гейворкс, хуанг, печ, за свободу нужно платить — не жалко купить fury x чтобы получить производительность проблобованой gtx 950. У меня все игры идут, потому что игры новее dx9 не нужны и их нет.

anonymous ()
Ответ на: комментарий от anonymous

Ещё оптимус забыл, он мне очень мешает на домашнем пк.

anonymous ()
Ответ на: комментарий от YLoS

То, что ты балбес. Там не снижение, а отсутьствие наращивания(оптимизации) для старых карт. У амд то же самое, причём можно прошить биос от новых карт в старые и станет быстрее.

anonymous ()
Ответ на: комментарий от Novell-ch

У меня сейчас вопрос возник, вроде не слышал об этом ранее. Этот новый блоб требует для работы amdgpu ядерный модуль как и radeonsi. А требует ли он модуля в llvm? Для 3Д и opencl radeonsi его же использует и там довольно приличный кусок кода с кучей оптимизаций. Да и вообще интересно что у этого блоба внутри, как они так быстро написали «рабочий» драйвер по функционалу опережающий открытый и по скорости с ним наравне.

http://www.phoronix.com/scan.php?page=article&item=amd-radeonsi-progl&amp...

Не могли они взять существующий стек, дописать недостоющиее без оглядки на архитектуру галлиум и другие драйвера и скомпилировать это в одну либу? На много какие куски кода лицензия МИТ которая вроде позволяет так сделать.

Просто мне не совсем понятно как за меньшее время можно написать более функциональный блоб. Ведь для на расширениями для месы работает несколько компаний + энтузиасты.

Behem0th ★★★★★ ()
Последнее исправление: Behem0th (всего исправлений: 2)

Очень хорошие новости. Когда этот допилят, свободный станет не нужен.

lagavulin16 ()
Ответ на: комментарий от Behem0th

какие то символы есть от ллвм но их слишком мало, скорее всего они пилили этот блоб и amdgpu модуль к нему одновременно, не так уж мало времени и прошло.

Novell-ch ★★★★★ ()
Ответ на: комментарий от Novell-ch

Мало я имел в виду по сравнением сколько месу пилят.

Behem0th ★★★★★ ()
Ответ на: комментарий от lagavulin16

Он и есть свободный, норкоман. Там только libGL.so и для OpenCL библиотека проприетарные.

anonymous ()
Ответ на: комментарий от anonymous

В жопу только на пол-*уя даёшь, и потому гей-шлюхой себя не считаешь?

anonymous ()

А нет ли информации, когда будут подобные драйвера доступны для более старых карт, например для Radeon 7ХХХ серии?

STepeR ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.