LINUX.ORG.RU

Мышь на COM-порту в Slackware-14.1

 , ,


0

2

Недавно понадобилось запустить древнюю двухкнопочную мышь на COM-порту под Slackware-14.1 с XFCE на древнем компьютере. Система запускается на 4-м runlevel.

Нашёл инструкцию, что это можно сделать через inputattach. Если от рута в терминале выдать после загрузки Х :

inputattach --microsoft /dev/ttyS0

то мышь работает и в консоли, и в Х.

Но если я вписываю эту команду в стартовые скрипты (/etc/rc.d/rc.local), то inputattach завершается сразу же после старта. Я пробовал такие варианты: inputattach --microsoft /dev/ttyS0&

Опять-же если это запустить вручную в консоли после старта X, то всё работает. Также пробовал запускать через nohup, В таких вариантах:

honup inputattach --microsoft /dev/ttyS0&
nohup inputattach --microsoft /dev/ttyS0 > /dev/null 2>&1 &

Также пробовал вписывать эти команды в различных вариантах в xinitrc . inputattach не хочет стартовать в фоне через стартовый скрипт. Как правильно вписать этот inputattach в стартовый скрипт?

Ответ на: комментарий от CYB3R

Пробовал через файлы в каталоге xorg.conf.d, но видимо вписывал не в тот файл, и ничего не заработало. Завтра на работе попробую ещё раз.

DarthVadimius ★★★ ()
Ответ на: комментарий от ashot

Если сделать указанные замены, то мышь в консоли начинает работать, но не в X. Итоговая строка получилась следующая:

/usr/bin/gpm -m /dev/ttyS0 -t bare

Там ещё есть интересная приписка, что можно добавить параметр -R и мышь может начать транслировать данные в Х. Затем нужно её подключать через секцию Pointer:

Section "Pointer"
 Protocol "MouseSystems"
 Device "/dev/gpmdata"
EndSection

Если запустить gpm через параметр -R и дописать указанной в xorg.confd.d/10-evdev.conf , то файл gpmdata создаётся но в Х мышь не движется. Как правильно задействовать этот gpmdata я пока не сообразил.

DarthVadimius ★★★ ()
Ответ на: комментарий от DarthVadimius

Вписал в 10-evdev.conf следующее и ничего не заработало:

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
EndSection
DarthVadimius ★★★ ()
Ответ на: комментарий от ashot

И если в консоли работает можно так попробовать (наверное без -R):

Option "Protocol" "Microsoft"
Option "Device" "/dev/ttyS0"

ashot ★★★★ ()
Ответ на: комментарий от ashot

modprobe sermouse тоже не помогло. Пока вопрос решился тем, что я добыл PS/2 мыши, с которыми нет проблем. COM-мыши отложил до лучших времён.

DarthVadimius ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.