LINUX.ORG.RU

Debian 8, проблемы с Bumblebee

 , , ,


0

1

Здравствуйте. Наконец-то поставил себе Debian, намучавшись, предварительно, с несколькими убунтами, минтами и прочими сусями. Доволен, наконец-то, всем. Кроме одного.

После установки поставил дрова нВидии по вот этой инструкции: https://wiki.debian.org/NvidiaGraphicsDrivers#Version_340.65 Осталось только установить и запустить nvidia-xconfig, и вдруг я случайно прокручиваю страничку до Configuration. Естественно, никаких xconfigов, бежим ставить Bumblebee. Поставили, а оно не может в аксесс секондари джипию. Так понимаю - косяк мой. Как исправить? Яндекс не помог, в здешних темах именно такого сценария не нашёл.

Помогите пожалуйста. Очень не хочется переустанавливать один и тот же Дебиан уже третий раз (лоханулся уже пару раз).

P.S. На Минте всё работало само, причём хорошо. Имелась даже клацалка в трее для переключения между Интелом и нВидией. Скучаю по клацалке...

намучавшись, предварительно, с несколькими убунтами, минтами

там как раз на раз-два ставится это, в отличии от

запустить nvidia-xconfig

не надо его как раз запускать

оно не может в аксесс секондари джипию

в /etc/bumblebee/xorg.conf.nvidia раскомментируй BusID «PCI:01:00:0» (уточни где она у тебя)

Имелась даже клацалка в трее для переключения между Интелом и нВидией. Скучаю по клацалке...

это не для этого и оно только в cinnamon вроде только есть в минтовском, а так просто индикатор добавить (их 2 есть)

amorpher ★★★★★ ()
Последнее исправление: amorpher (всего исправлений: 1)
Ответ на: комментарий от amorpher

в /etc/bumblebee/xorg.conf.nvidia раскомментируй BusID «PCI:01:00:0» (уточни где она у тебя)

Раскомментировал (это ведь просто снять решётку означает?)

Section "ServerLayout"
    Identifier  "Layout0"
    Option      "AutoAddDevices" "false"
    Option      "AutoAddGPU" "false"
EndSection

Section "Device"
    Identifier  "DiscreteNvidia"
    Driver      "nvidia"
    VendorName  "NVIDIA Corporation"

#   If the X server does not automatically detect your VGA device,
#   you can manually set it here.
#   To get the BusID prop, run `lspci | egrep 'VGA|3D'` and input the data
#   as you see in the commented example.
#   This Setting may be needed in some platforms with more than one
#   nvidia card, which may confuse the proprietary driver (e.g.,
#   trying to take ownership of the wrong device). Also needed on Ubuntu 13.04.
    BusID "PCI:01:00:0"

#   Setting ProbeAllGpus to false prevents the new proprietary driver
#   instance spawned to try to control the integrated graphics card,
#   which is already being managed outside bumblebee.
#   This option doesn't hurt and it is required on platforms running
#   more than one nvidia graphics card with the proprietary driver.
#   (E.g. Macbook Pro pre-2010 with nVidia 9400M + 9600M GT).
#   If this option is not set, the new Xorg may blacken the screen and
#   render it unusable (unless you have some way to run killall Xorg).
    Option "ProbeAllGpus" "false"

    Option "NoLogo" "true"
    Option "UseEDID" "false"
    Option "UseDisplayDevice" "none"
EndSection
Может там ещё какие опшены поправить можно, кроме ProbeAllGpus? Если только оно ничем не грозит? Например, что будет, если «НоуЛого» поставить на «фолс», а «АутоЭдд...» на «тру»?

там как раз на раз-два ставится это

Да, но зато там куча других проблем и неприятных особенностей

не надо его как раз запускать

По инструкции для неоптимусов надо было, но как раз его я и не сделал, прочитав случайно абзац Configuration

это не для этого и оно только в cinnamon вроде только есть в минтовском

По-моему, как раз в мятной корице оно и переключало Интел<-->нВидия... вроде бы.

а так просто индикатор добавить (их 2 есть)

Списибо, нашёл (правда один всего), только придётся свой свг туда нарисовать, а то какой-то не халяльный совсем.

Mellatau ()
Ответ на: комментарий от amorpher
$ lspci | egrep 'VGA|3D'
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GK107M [GeForce GT 650M] (rev a1)
$ optirun inxi -Gx
[  319.247675] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied

[  319.247732] [ERROR]Aborting because fallback start is disabled.

Не хочет :(

Mellatau ()
Ответ на: комментарий от Mellatau

Может там ещё какие опшены поправить

не надо

Да, но зато там куча других проблем и неприятных особенностей

каких ещё? тот же debian testing/sid, только там уже рутина вся сделана

Списибо, нашёл (правда один всего), только придётся свой свг туда нарисовать, а то какой-то не халяльный совсем.

ищи по «nvidia» и «bumblebee», их 2

Не хочет :(

в группу bumblebee себя конечно добавил уже?
ну и ещё до кучи — в /etc/bumblebee/bumblebee.conf:

Driver=nvidia
KernelDriver=nvidia-НОМЕР_ВЕРСИИ
LibraryPath=/usr/lib/nvidia-НОМЕР_ВЕРСИИ:/usr/lib32/nvidia-НОМЕР_ВЕРСИИ
XorgModulePath=/usr/lib/nvidia-НОМЕР_ВЕРСИИ/xorg,/usr/lib/xorg/modules

выполни (от root или sudo):

dpkg-reconfigure bbswitch-dkms && dpkg-reconfigure bumblebee

перезагрузись и проверь с чем-нибудь, например:

optirun glxgears

amorpher ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.