LINUX.ORG.RU

gentoo && bcm43142

 , ,


0

1

Купил недавно ноут, решил накатить туда Gentoo, поиграться. Обнаружилась проблема с wifi-модулем.

02:00:00 Network controller: Broadcom Corporation BCM43142 802.1b/g/n (rev 01)
Subsystem: Lite-On Communications Inc Device 6645
Flags: bus master, fast devsel, latency 0, IRQ 19
Memory at b34000000 (64-bit non-prefetchable) [size=32K]
...
Kernel driver in use: wl
Kernel modules: wl
По выводу, думаю, понятно, что накатывал broadcom-sta. Всячеcкие b43, ssb, etc в ядре выключены (посмотрел, на что при сборке ругается и что требуется, поправил в конфиге ядра). Собственно, сам беспроводной интерфейс есть, только он нифига не работает.
iwconfig wlan0
wlan0     no wireless extensions
Посмотрел вывод dmesg после modprobe wl:
wl0: online cpu 1
wl_init_rfkill: rfkill registered
wlan0: Broadcom BCM4365 802.11 Hybrid Wireless Controller 6.30.223.248 (re487524)
Заметно, что BCM4365 != BCM43142. Проблема в этом? Если да, то что можно сделать? Какие вообще идеи есть?

запустить любой нормальный дистрибутив в видел livecd, посмотреть, как там сделано

anonymous ()
Ответ на: комментарий от anonymous

Через bcmwl-kernel-source. Как я понял, то же самое, что и broadcom-sta. Правда, в Убунте модуль таки работал и работал хорошо.

cherry_boy ()
Ответ на: комментарий от cherry_boy

Заметно, что BCM4365 != BCM43142.

А что там в конфиге ядра? Может можно вырубить этот драйвер для BCM4365?

BattleCoder ★★★★★ ()
Ответ на: комментарий от BattleCoder

Судя по всему, BCM4365 и BCM43142 суть есть одно и то же. Возможно, надо с более старым ядром попробовать, фиг знает.

cherry_boy ()

Там ещё один какой-то сраный драйвер был, я только название не помню. Тоже на «b» начинается. Я его заблеклистил и всё стало работать.

ee1337a ()

Вот что у меня включено в секции Networking support -> Wireless:

CONFIG_CFG80211=y
CONFIG_CFG80211_DEFAULT_PS=y
Остальное отключено. В Device Drivers -> Network device support -> Wireless LAN:
CONFIG_HOSTAP=y
Остальное отключено. Хотя CONFIG_HOSTAP, скорее всего, не влияет. Также у меня отключено CONFIG_BCMA, CONFIG_SSB

В логах ядра также пишет:

[    4.952169] wlan0: Broadcom BCM4365 802.11 Hybrid Wireless Controller 6.30.223.248 (r487574)
На iwconfig такая же реакция. Но все работает, попробуй запустить wpa_supplicant с дебагом и посмотреть, что он найдет

anonymous ()

Отбой

Собрал ядро через genkernel, добавил в блэклист b43, bcma, ssb, mac80211 - iwconfig стал нормально отрабатывать.
Я до этого сам через menuconfig все настраивал - скорее всего, что-то недовключил.
Сравню потом конфиги, м.б. поднастрою что-нибудь, а пока и так сойдет.

cherry_boy ()
Ответ на: Отбой от cherry_boy

Re: Отбой

Да, сравни плз, самому интересно, ну или выложи куда-нибудь оба конфига.

anonymous ()
Ответ на: Re: Отбой от anonymous

Там дифф на 4 тыщи строк. Хрен разберешься. :)

cherry_boy ()
Ответ на: комментарий от cherry_boy

Я уже разобрался :) . Нужно CONFIG_CFG80211_WEXT=y. Правда, в описании говорят, что от этого мы получаем «old userspace», так что отсутствие опции не должно быть критично.

anonymous ()
Ответ на: комментарий от anonymous

Подтверждаю. Добавил в предыдущий конфиг этот флаг, проблема ушла.

cherry_boy ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.