LINUX.ORG.RU

HP Officejet Pro L7480

 


1

1

у меня стоит Manjaro. При подключении принтера HP Officejet Pro L7480 драйвера не определяет. Пытался установить через HPLIP, но там ошибка:

Using connection type: usb

Using device: hp:/usb/Officejet_Pro_L7400?serial=MY87T2506G


Setting up device: hp:/usb/Officejet_Pro_L7400?serial=MY87T2506G



---------------------
| PRINT QUEUE SETUP |
---------------------

Using queue name: Officejet_Pro_L7400
Locating PPD file... Please wait.
error: No PPD found for model officejet_pro_l7400 using old algorithm.
error: Unable to find an appropriate PPD file.

yould you like to specify the path to the correct PPD file to use (y=yes, n=no*, q=quit) ? 

Версия дистрибутива?
Ядро?
Что пишут в гугле и на сайте производителя про этот принтер и линуксы?
Что ты вообще сделал, чтобы решить проблему?

Zhbert ★★★★★ ()
Ответ на: комментарий от Zhbert

1) Manjaro 0.8.12 Ascella 2) x86_64 Linux 3.19.0-1-MANJARO 3) На сайте производителя не могу найти даже драйвера для windows, а в руководстве пользователя указывается лишь linux в списке поддерживаемых систем. В гугле о L7480 и linux ничего. На сторонних сайтах драйверов направляют на HPLIP. 4) Искал программы hp в репозиториях. Пытался скачать драйвера через программу производителя hplip. Искал PPD файл.

DarkNoys ()
Ответ на: комментарий от DarkNoys

Понятно.
Ну я погуглил тоже, на сайте они и правда отправляют к HPLIP.
Судя по твоей ошибке - error: Unable to find an appropriate PPD file. - оно не может найти нужный PPD. Непонятно почему, но есть ИМХО один вариант - возьми виртуальную машину и поставь принтер в нее, и уже из виндовой версии дров вытащи файл описания.

Zhbert ★★★★★ ()
Ответ на: комментарий от DarkNoys

подключаешь интернет , запускаешь hp-check , ставишь пакеты на которые ругается , после из под рута hp-setup и следуешь визарду. у меня M1212nf - hp-setup сам скачивает нужный PPD c сайта HP

Tsvetkov ()
Ответ на: комментарий от anonymous

Спасибо большое. Но тут опять возникла проблема при попытке установить ppd файл через hp-setup вылезает ошибка:

error: Printer queue setup failed. Error : Unable to connect to CUPS server 
Пытался запустить демон через systemctl, но не видит ни cups, ни cupsd.

DarkNoys ()
Ответ на: комментарий от DarkNoys

hp-check - запускал ? при запуске(от обычного пользоваля в консоли) будет проверка установленного софта - весь требуемый софт стоит?
hp-setup - запуск от рута - запусти консоль, залогинился рутом, запусти hp-setup - всякие sudo на катят

Tsvetkov ()
Ответ на: комментарий от Tsvetkov

hp-check выводит:

error: cups          CUPS - Common Unix Printing System                           REQUIRED        1.1             2.0.2           MISSING    'CUPS may not be installed or not running'
***
***
 error: python3-reportlab Reportlab - PDF library for Python                           OPTIONAL        2.0             3.1.44          MISSING    'python3-reportlab needs to be installed'
 error: python3-pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x)         REQUIRED        4.0             -               MISSING    'python3-pyqt4 needs to be installed'
***
***
 error: python3-notify2 Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL        -               -               MISSING    'python3-notify2 needs to be installed'

hp-setup под рутом не помогает.

DarkNoys ()
Ответ на: комментарий от DarkNoys

имхо - надо сносить cups 2.0.2 и ставить 1.7.5 - еще не заточили hplip под второй cups - нет в релиз нотесах hplip сообщения о поддержке. На счет python3-reportlab (у меня 3.1.8) странно, что ругается на 3.1.44 , а python3-pyqt4 надо ставить.

Мой кусок вывода про софт - на Fedora 20 - http://pastebin.com/5e76b0zD

Tsvetkov ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.