LINUX.ORG.RU

lspci не видит i350 на Supermicro X9QRi-F+ под debian wheezy.

 ,


0

1

Доброго времени суток all. Второй день пытаюсь запустить NIC на intel i350 под wheezy.

Сначала сделал всё по ману от производителя сетевухи. Собрал igb.ko, скопировал куда нужно, сделал modprobe igb, драйвер в dmesg сказал, что загрузился. Однако eth0 не появился. Полез в lspci, а там тишина. Ни одного устройства с идентификатором 8086:15XX (или словами ethernet|network в описании) нет.

Грешу на джампер отключения сетевых портов, но проверять буду только в крайнем случае - сервант опечатан (да и маловероятно, что его кто-то трогал). К тому же при вставлении хвоста в порт на NIC светодиод «линк» на морде сервера загорается. Попытка загрузиться по PXE через сетевуху не даёт ничего. Даже экран PXE ROM не показывает (в биосе настройку UEFI network stack и NIC PXE ROM поставил).

В чём могут быть грабли?

1)Может ли lspci не видеть устройство по каким-либо нетривиальным причинам (конфликт ресурсов, отсутствие фирмвари, кривые настройки ядра)?

2)Есть ли у кого платформа Supermicro, проверить, что бывает когда ставят в положение disable джампер на отключение сетевухи (конкретно поднимается ли при этом линк)?

3)Есть ли какие-то настройки BIOS, которые я не упомянул, но оторые могут влиять на работоспособность NIC?

4)Есть ли ещё идеи, куда копать?

Если это интегрированная сетевуха. то смотри в биосе. Некоторые биосы позволяют включать PXE bootrom на отключенной сетевушке.

2 - скорее всего нет. Скорре всего так отключат подачу дежурного питания на сетевушку для WoL

vel ★★★★★ ()

0) Обновление всех фирмварей до последних, сбросить биос на дефолт (это вообще-то делается всегда при приёме сервера, сначал фирмвари, потом операционка)

1) Смотреть в биосе настройку

Deleted ()
Последнее исправление: Deleted (всего исправлений: 1)
Ответ на: комментарий от Deleted

Фирмварь свежая (фраза про отсутствие фирмвари означала её отсутствие в дистре). Биос сбрасывал.

Очевидной настройки на эту тему, кроме указанных, не нашёл.

2 vel:

2 - скорее всего нет. Скорре всего так отключат подачу дежурного питания на сетевушку для WoL

В мане просто сказано «JPTG1 enables or disables the LAN Port1/LAN Port2 on the motherboard»

sometyx ()
Ответ на: комментарий от sometyx

фраза про отсутствие фирмвари означала её отсутствие в дистре

Вообще то я про обновление BIOS'а и IPMI.

В мане просто сказано «JPTG1 enables or disables the LAN Port1/LAN Port2 on the motherboard»

Ну и в каком положении JPTG1? Его можно увидеть через дырявые заглушки слотов. И вообще, зачем покупать запечатанный сервер...

Deleted ()
Последнее исправление: Deleted (всего исправлений: 2)

FWIMC

Если кому вдруг пригодится:

Q: The server is 8047R-TRF+. The onboard network devices does not work under Windows 2012 OS. It cannot be driving even after LAN driver installation. The firmware is current official revision. What could be the cause?

A: Please note that 4CPUs are necessary to functioning onboard i350. CPU3/4 must be installed to enable onboard NIC.

http://www.supermicro.com/support/faqs/faq.cfm?faq=18408

Да, я идиот.

sometyx ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.