LINUX.ORG.RU

usb wifi свисток


0

1

Железяка увиделась, после тряски бубном поднялся интерфейс, но не wlan0 а маловнятные сочетания букв, причем в iwconfig одно имя, в ifconfig другое. WTF?

Картинка такова, есть usb wifi Bus 001 Device 004: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter

iwconfig показывает его вот так: wlp0s29f7u4 IEEE 802.11bgn ESSID:off/any Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm Retry long limit:7 RTS thr=2347 B Fragment thr:off Encryption key:off Power Management:off

ifconfig:

wlp0s29f7 Link encap:Ethernet HWaddr 00:13:EF:70:00:E7 inet addr:192.168.123.1 Bcast:192.168.123.255 Mask:255.255.255.0

dhcpd обслуживать это чудо не хочет, говорит:

No subnet declaration for wlp0s29f7 (no IPv4 addresses).

Сам вопрос: где я накосорезил?

Ответ на: комментарий от mky

ip addr

3: wlp0s29f7u4: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN qlen 1000 link/ether 00:13:ef:70:00:e7 brd ff:ff:ff:ff:ff:ff inet 192.168.123.1/24 brd 192.168.123.255 scope global wlp0s29f7u4 valid_lft forever preferred_lft forever

ip link

3: wlp0s29f7u4: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DORMANT qlen 1000

everest2014 ()
Ответ на: комментарий от daemonpnz

Я громоздю свою точку доступа для всяких там телефонов, планшетов с ноутбуками.

everest2014 ()
Ответ на: комментарий от ii343hbka

option domain-name «homenest.org»; option domain-name-servers 8.8.8.8, 62.176.15.100; option routers 192.168.123.1; max-lease-time 9000; authoritative ; log-facility local7; ddns-update-style none; default-lease-time 86400; subnet 192.168.123.0 netmask 255.255.255.0 { option subnet-mask 255.255.255.0; option broadcast-address 192.168.123.255; option routers 192.168.123.0; option domain-name-servers 8.8.8.8; option domain-name «homenest.org»; interface wlp0s29f7; authoritative ; range 192.168.123.1 192.168.123.254; default-lease-time 3600; max-lease-time 3600; }

everest2014 ()
Ответ на: комментарий от daemonpnz

RTFM'нул, благодарствую, цитирую конфиг повторно:
option domain-name «rustik2005.org»;
option domain-name-servers 8.8.8.8, 62.176.15.100;
option routers 192.168.123.1;
max-lease-time 9000;
authoritative ;
log-facility local7;
ddns-update-style none;
default-lease-time 86400;
subnet 192.168.123.0 netmask 255.255.255.0 {
option subnet-mask 255.255.255.0;
option broadcast-address 192.168.123.255;
option routers 192.168.123.0;
option domain-name-servers 8.8.8.8;
option domain-name «rustik2005.homenest.org»;
interface wlp0s29f7;
authoritative ;
range 192.168.123.1 192.168.123.254;
default-lease-time 3600;
max-lease-time 3600;
}

everest2014 ()
Ответ на: комментарий от everest2014

Расшифровываю: systemd переименовывает имена интерфейсов в уникальные имена, дабы те не попутались при ребуте.

vova7890 ★★★ ()
Ответ на: комментарий от vova7890

Расшифровываю: systemd переименовывает имена интерфейсов в уникальные имена, дабы те не попутались при ребуте.

Познавательно конечно, но если бы я все на подобном слэнге спросил, то кто бы меня понял? Пуркуа па?

everest2014 ()
Ответ на: комментарий от daemonpnz

что-то тут не так, нафига ты адрес всей подсетки сюда пишешь?!

Я уже конкретно туплю - что в этой строчке не так? Разрешаю обзывать как хочется, засыпаю уже и не понимаю, вроде бы кошерная строчка.

everest2014 ()
Ответ на: комментарий от everest2014

тут ты должен указать шлюз для твоей подсетки, а ты указываешь в качестве шлюза всю подсетку, похоже на бред. По идее должно быть 192.168.123.1

daemonpnz ★★★★★ ()
Последнее исправление: daemonpnz (всего исправлений: 1)
Ответ на: комментарий от everest2014
range 192.168.123.1 192.168.123.254;

должно быть

range 192.168.123.2 192.168.123.254;
как минимум

daemonpnz ★★★★★ ()
Ответ на: комментарий от daemonpnz

Зайдем немного с другой стороны, systemd-udev перекореживает имя wlan0 в набор букв, отсюда неразбериха с именем интерфейса свистка с сопутствующими неведомыми граблями. Попытка прибить гвоздями имя интерфейса в 70-persistent-net.rules эффекта не дала. Вот строчка оттуда:
SUBSYSTEM==«net», ATTRS{address}==«00:13:EF:70:00:E7», NAME=«wlan0»

До кучи нагуглилось, что hostapd плохо дружит с реалтековскими драйверами. Это видимо, чтобы жизнь медом не казалась :)

everest2014 ()
Ответ на: комментарий от everest2014

ты для начала подними попробуй интерфейс ручками, а потом уже будешь разбираться с predictable network inteface names.

I don't like this, how do I disable this?

You basically have four options:

* You disable the assignment of fixed names, so that the unpredictable kernel names are used again. For this, simply mask udev's rule file for the default policy: ln -s /dev/null /etc/udev/rules.d/80-net-setup-link.rules (since v209: this file was called 80-net-name-slot.rules in release v197 through v208)
* You create your own manual naming scheme, for example by naming your interfaces «internet0», «dmz0» or «lan0». For that create your own udev rules file and set the NAME property for the devices. Make sure to order it before the default policy file, for example by naming it /etc/udev/rules.d/70-my-net-names.rules
* You alter the default policy file, for picking a different naming scheme, for example for naming all interface names after their MAC address by default: cp /usr/lib/udev/rules.d/80-net-setup-link.rules /etc/udev/rules.d/80-net-setup-link.rules, then edit the file there and change the lines as necessary.
* You pass the net.ifnames=0 on the kernel command line (since v199)

daemonpnz ★★★★★ ()
Ответ на: комментарий от daemonpnz

ifconfig wlp0s29f7u4 down
ifconfig wlp0s29f7u4 up

Вполне себе отрабатывает, dhcpd натравленный на полное имя интерфейса (wlp0s29f7u4) запустился без возражений и ругани в логи.

everest2014 ()
Ответ на: комментарий от everest2014

ну вот, и оставь название интерфейса как есть, не мучайся.

daemonpnz ★★★★★ ()
Ответ на: комментарий от daemonpnz

dhcpd запустился без ругани при указании полного имени интерфейса видимого через iwconfig. Нужно теперь как-то привести имена интерфейсов в одно внятное имя и видимое обоими тулузами (iwconfig/ipconfig)одинаково - wlan0 мне видится наиболее предпочтительным. Хотя может быть я пробиваю лбом стену - хз.

everest2014 ()
Ответ на: комментарий от everest2014

ну так ifconfig wlp0s29f7u4 up отработал же ж, значит iwconfig/ifconfig видят одинаково этот интерфейс, вот и используй его.

daemonpnz ★★★★★ ()
Ответ на: комментарий от everest2014

Ой, а что вы тут делаете? hostapd сам поднимает интерфейс. Можно вообще не мучатся с dhcpcd, а в тестовых целях прописать айпишники ручками. Кстати чего говорит systemctl status hostapd?

А дистрибутив какой?

naszar ()
Последнее исправление: naszar (всего исправлений: 1)
Ответ на: комментарий от naszar

hostapd.service - Hostapd IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator
Loaded: loaded (/usr/lib/systemd/system/hostapd.service; disabled)
Active: active (running) since Вс 2014-07-13 17:43:49 MSK; 4min 44s ago
Main PID: 14561 (hostapd)
CGroup: /system.slice/hostapd.service
└─14561 /usr/sbin/hostapd /etc/hostapd.conf

июл 13 17:43:49 linux-twu5 systemd[1]: Started Hostapd IEEE 802.11 AP, IEEE 802.1X/...r.
Hint: Some lines were ellipsized, use -l to show in full.

everest2014 ()
Ответ на: комментарий от everest2014

Хм, попробовал сейчас, да, если опустить интерфейс hostapd не помирает и думает, что работает. Не правильно как-то это. Я думаю надо не ip link set wlp0s29f7u4 up, а systemctl restart hostapd. Возможно адаптер засыпает в целях экономии питания.

naszar ()
Ответ на: комментарий от everest2014

Не сильно в курсе как dhcpd работает как сервер(пользовал для этого dnsmasq), но интерфейсу айпишник не нужно прописывать? Откуда он там появится?

naszar ()
Последнее исправление: naszar (всего исправлений: 1)
Ответ на: комментарий от naszar

Дистрибутив opensuse 13.1. Я тут своими шаловливыми руцями hostapd с https://github.com/jenssegers/RTL8188-hostapd собрал и у меня теперь по 2 интерфейса :) Как точка доступа вообще должна выглядеть через iwconfig?

iwconfig:

wlp0s29f7u4 IEEE 802.11bgn Mode:Master Tx-Power=20 dBm
Retry long limit:7 RTS thr=2347 B Fragment thr:off
Power Management:off

mon.wlp0s29f7u4 IEEE 802.11bgn Mode:Monitor Tx-Power=20 dBm
Retry long limit:7 RTS thr=2347 B Fragment thr:off
Power Management:on

ifconfig:
mon.wlp0s Link encap:UNSPEC HWaddr 00-13-EF-70-00-E7-00-00-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:305 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:53513 (52.2 Kb) TX bytes:0 (0.0 b)

wlp0s29f7 Link encap:Ethernet HWaddr 00:13:EF:70:00:E7
inet addr:192.168.123.1 Bcast:192.168.123.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:19 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:4212 (4.1 Kb)

everest2014 ()
Ответ на: комментарий от everest2014

По факту, пересборка этого велосипеда с гитхаба принесла результат, точку доступа я вижу! Остался тюнинг: отрубание power managment и подвинчивание скорости с выдачами IP клиенту ну и верчение iptables'ом. Всем огромное спасибо. Чуть позже нарисую выстраданное в этой же теме.

everest2014 ()
Ответ на: комментарий от everest2014

Ну вот и поднялась у тебя точка доступа. Так и должно быть два интерфейса.

daemonpnz ★★★★★ ()
Ответ на: комментарий от everest2014

В дистрибутивах с systemd настраивал только из NetworkManager, там надо чтобы wpa_supplicant был собран с опцией 'CONFIG AP=y', не знаю, как оно в openSUSE. Ещё такая графическая прога есть http://software.opensuse.org/package/wifi-hostapd-ap Это если конечно графикой пользуетесь.

anonymous ()
Ответ на: комментарий от everest2014

Как точка доступа вообще должна выглядеть через iwconfig?

Весь выхлоп:

$ iwconfig
wlp3s0    IEEE 802.11bgn  Mode:Master  Tx-Power=15 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          
lo        no wireless extensions.

enp2s0    no wireless extensions.
mon.wlp0s29f7u4 - это адаптер в режиме монитора, для точки доступа обычно не нужно. Точке доступа нужен только в режиме Master. Хотя у вас тюнинговый hostapd, надо посмотреть, может это костыль какой. Главное чтобы этот mon.wlp0s29f7u4 не скакал по каналам. Ясность может внести вся последовательность команд для поднятия вайфая и /etc/hostapd.conf.

И да, не нужно переименовывать интерфейс от этого потом всякие забавные баги случаются.

naszar ()
Последнее исправление: naszar (всего исправлений: 1)
Ответ на: комментарий от everest2014

Остался тюнинг: отрубание power managment

wlp0s29f7u4 IEEE 802.11bgn Mode:Master Tx-Power=20 dBm
Retry long limit:7 RTS thr=2347 B Fragment thr:off
Power Management:off
mon.wlp0s29f7u4 IEEE 802.11bgn Mode:Monitor Tx-Power=20 dBm
Retry long limit:7 RTS thr=2347 B Fragment thr:off
Power Management:on

Тут странность, что зачем нужен этот режим монитора. Железка по факту одна, модуля скорее всего два, интерфейса, точно - два. Монитор управляет питанием, а другой - нет. По идее, через iwconfig можно отрубить управление питанием iwconfig mon.wlp0s29f7u4 power off, другой вопрос, зачем их два?

naszar ()
Ответ на: комментарий от naszar

Штатный hostapd из репозитория не хочет жить с rtl свистком, я сходил в родное гнездовье этой штуки, стянул свежайшую версию 2.2, в надежде что там поправлено, посмотрел изумительные фиги в логе с руганью на rl80211. Пусть уже этот хромой велосипед работает, раз уж он это осилил.

everest2014 ()
Ответ на: комментарий от naszar

И да, не нужно переименовывать интерфейс от этого потом всякие забавные баги случаются.

Эксперименту для оторвал переименовывание интерфейсов вообще, глюков огреб полной ложкой. Твой совет уже проверен :)

everest2014 ()
Ответ на: комментарий от everest2014

Можно подвести резюме: точка пашет, но скорость не айс - клиентская машинка (opensuse) цепляется на скорости 65 мбит и подумав меняет скорость на 1 мбит, странички грузятся, но вяло :) Если интересно кому напишу все что громоздил.

everest2014 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.