LINUX.ORG.RU

Раскладка клавы в иксах Sarge


0

0

В Woody все было нормально, как обновился пошли глюки. Перечитал про новые версии иксов, пробовал переключение разными клавишами, прописывал вручную options через запятую "us,ru". Пробовал xf86cfg и xf86config, dpkg-reconfigure xserver-xfree86 - ничего не помогает. Независимо от того, какая раскладка прописана, всегда получаю только ru или en при простом комментировании строчек options. Киньте кто-нибудь конфиг и настройки работающие, если не сложно.

anonymous

Re: Раскладка клавы в иксах Sarge

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "Protocol" "Standard"
Option "XkbModel" "pc104"
Option "XkbRules" "xfree86"
Option "XkbLayout" "us,ru(winkeys)"
Option "XkbOptions" "grp:ctrl_shift_toggle,grp_led:scroll"
EndSection

arax ()
Ответ на: Re: Раскладка клавы в иксах Sarge от arax

Re: Раскладка клавы в иксах Sarge

В общем пробовал как написано. Пробовал полностью снести иксы, удалить все конфиги из /etc/X11 и /usr/X11R6, поставил все пакеты заново, выбирал только анлгийскую раскладку, а вылезает все время только русская, так что в иксах в терминале не набрать ни одной команды!

Иксы стартуют через startx. В xserverrs, xinitrc, xsession вроде ничего подозрительного нет.

Хоть ставь из-за такой ерунды всю систему заново. Где чего могло накрыться?

anonymous ()
Ответ на: Re: Раскладка клавы в иксах Sarge от anonymous

Re: Раскладка клавы в иксах Sarge

Не знаю где что в иксах слетело, но помогла команда setxkbmap -rules xfree86 -model pc104 -layout "us,ru(winkeys)" -option "grp:alt_shift_toggle, grp_led:scroll"

Я ее записал в startfluxbox, но может кому-то пригодиться ее использовать после запуска иксов другим способом.

А через конфиги по прежнему нифига не работает.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.