LINUX.ORG.RU

Обновился, мля. Перестали работать комбинации Ctrl+B, Ctrl+I и т.д. для форматирования текста в Qt приложениях на русской раскладке


0

2

Как и заведено в Linux, пришлось мне на днях обновиться, чтобы поставить одну-единственную программу.

Не готов к десктопу: Установка KDENlive требует удаления 20 нужных программ

Ведь все луноходы обновляются каждую пару недель, и система становится только лучше.

Но диавол кроется, как обычно, в мелочах. И помимо новых глюков, которые можно кое-как терпеть, появился еще один:

Перестали работать комбинации Ctrl+B, Ctrl+I и т.д. для форматирования текста в Qt приложениях на русской раскладке

То есть, теперь приходится чтобы сделать текст полужирным bold (через Ctrl+B), не забывать переключаться на английскую раскладку. А если попробуешь сделать текст курсивом (Ctrl+I), то сотрешь текст и влепишь вместо него гордый TAB. Ctrl+U тоже не ловится в русской раскладке.

Вопрос: это именно глюк системы, или применились какие-то новые настройки клавиатуры? Можно ли это исправить через «Параметры системы», или всё, абзац, ждать три года пока починят как чинили переключатель в третьекедах?

Система: Debian Testing, KDE4, обновился два дня назад.

★★★★★

Это баян. ЕМНИП, уже с середины лета не работает. Багрепорт где-то валялся, но в связи с закапыванием qt4 всем пофиг. А в qt5 вроде пофикшено уже.

anonymous ()
Ответ на: комментарий от hobbit

Приложения на Qt4.

Я проверяю на своей программе MyTetra и для интереса компиляю простой простую стороннюю разработку Edithtml. В ней вообще Ctrl+B и Ctrl+U не работают и в английской раскладке, а Ctrl+I лупит TAB на месте выделенного текста.

В Skype4 которая на Qt4 тоже Ctrl+I лупит TAB.

Xintrea ★★★★★ ()
Ответ на: комментарий от anonymous

Это баян. ЕМНИП, уже с середины лета не работает. Багрепорт где-то валялся, но в связи с закапыванием qt4 всем пофиг.

Вот, весь линуховый софт во всей свое красе.

Xintrea ★★★★★ ()
Ответ на: комментарий от markelov

Ну так переходи на вендоз или мак, чего мучаешься, бедненькый?

Часть проектов намертво к линуху привязана. Лочка не вендора так сказать.

Xintrea ★★★★★ ()
Ответ на: комментарий от Xintrea

А хер его знает, я свой дебиан недели две не обновлял и кутепрог у меня немного.

olibjerd ★★★★★ ()
Ответ на: комментарий от anonymous

Committer Gatis Paeglis<gatis.paeglis@digia.com>Sep 12, 2013 11:29 AM

Полтора дня назад.

Видимо, испанцев/ительянцев/португальцев тоже коснулся галлюн.

Интересно, когда же в тестовую дэбу фикс доползет?

Xintrea ★★★★★ ()

Можно ли это исправить через «Параметры системы»

Попробуй английскую раскладку сделать первой(по умолчанию).

anonymous ()
Ответ на: комментарий от kostik87

Пересоберите пакет сами.

Ну это само собой. В бинарных дистрах только так и решать проблемы, по-другому не получится.

Xintrea ★★★★★ ()
Ответ на: комментарий от Xintrea

А кто мешает сидеть на стейбле?..

anonymous ()
Ответ на: комментарий от hobbit

Какие, например, приложения?

Например, KolorPaint. Ctrl+Z в русской раскладке не работает.

Xintrea ★★★★★ ()
Ответ на: комментарий от kostik87

Ну вы же сами пересели на тестовую ветку, вас ни кто не тянул.

В стабильной ветке небыло тех программ которые мне нужны.

Xintrea ★★★★★ ()

Как и заведено в Linux, пришлось мне на днях обновиться, чтобы поставить одну-единственную программу.

разве qt sdk не доступно в виде архива со статической сборкой на оф сайте?

waker ★★★★★ ()
Ответ на: комментарий от Xintrea

А вы про смешивание веток в Debian не слышали ?

Можно оставаясь, к примеру, на стабильной ветке подключить, к примеру, репозиторий с тестовой веткой и указать, что нужно из тестовой ветки ставить только определённый пакет.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

А вы про смешивание веток в Debian не слышали ? Можно оставаясь, к примеру, на стабильной ветке подключить, к примеру, репозиторий с тестовой веткой и указать, что нужно из тестовой ветки ставить только определённый пакет.

Вы что, это же смертный грех!

Не готов к десктопу: Установка KDENlive требует удаления 20 нужных программ (комментарий)

Давайте все-таки определимся, кто из вас прав.

Xintrea ★★★★★ ()
Ответ на: комментарий от Xintrea

Ну тогда или тестируйте, либо сидите на стабильной ветке, либо переходите на роллинг релиз дистрибутив.

Ну и ни кто не заставляет ставить все подряд из другой ветки, я думаю один пакет не сломает систему.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

Ну тогда или тестируйте, либо сидите на стабильной ветке, либо переходите на роллинг релиз дистрибутив.

А можно без этих вот «или»? Просто чтобы работали те программы, которые нужны пользователю.

А то уже достало, что вмето нормально решения ставят перед выбором: «Вы уж выберите, кто вами будет руководить: вор, картежник или алкоголик. И помните - у вас свободный выбор!»


я думаю один пакет не сломает систему

Святая наивность :)

Xintrea ★★★★★ ()
Ответ на: комментарий от Xintrea

Мне кажется, проще всего в данной ситуации и правда скачать исходник (deb-src), поправить немного и пересобрать.

Adonai ★★★ ()
Ответ на: комментарий от Adonai

В данной ситуации уже проще всего просто обновиться. По крайней мере в sid уже пофикшено.

anonymous ()

Озвучьте версию qt4, чтобы другим было не повадно на неё обновляться.

По крайней мере в sid уже пофикшено.

Отлично.

Jurik_Phys ★★★★★ ()
Последнее исправление: Jurik_Phys (всего исправлений: 1)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.