LINUX.ORG.RU

Не ставится софт на бубунте. Проблема с обновлением.


1

1

Всем привет. Такая проблема: пытаюсь поставить мидори (в принципе, такая ж фигня с другим софтом) и терминал даёт такую картину:

apt-get install midori
Чтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
Будут установлены следующие дополнительные пакеты:
javascript-common libjs-mootools wwwconfig-common
Предлагаемые пакеты:
apache2 httpd mysql-client postgresql-client
НОВЫЕ пакеты, которые будут установлены:
javascript-common libjs-mootools midori wwwconfig-common
обновлено 0, установлено 4 новых пакетов, для удаления отмечено 0 пакетов, и 8 пакетов не обновлено.
Необходимо скачать 176 kB/1 314 kB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 4 706 kB.
Хотите продолжить [Д/н]? Д
ВНИМАНИЕ: Следующие пакеты невозможно аутентифицировать!
libjs-mootools wwwconfig-common javascript-common
Установить эти пакеты без проверки [y/N]? y
Ош http://archive.ubuntu.com/ubuntu/ natty/universe libjs-mootools all 1.2.5~debian1-2
404 Not Found [IP: 91.189.91.14 80]
Не удалось получить http://archive.ubuntu.com/ubuntu/pool/universe/m/mootools/libjs-mootools_1.2.... 404 Not Found [IP: 91.189.91.14 80]
E: Невозможно получить некоторые архивы, вероятно надо запустить apt-get update или попытаться повторить запуск с ключом --fix-missing


Я соответственно начинаю обновляться - и снова проблема.

apt-get update .... идет нормально всё и уже в самом конце:
Получено 64,5 kБ за 13с (4 876 Б/c) W: Не удалось получить http://extras.ubuntu.com/ubuntu/dists/natty/main/binary-i386/Packages 404 Not Found

W: Не удалось получить http://security.ubuntu.com/ubuntu/dists/natty-security/main/binary-i386/Packages 404 Not Found [IP: 91.189.92.202 80]

W: Не удалось получить http://security.ubuntu.com/ubuntu/dists/natty-security/restricted/binary-i386... 404 Not Found [IP: 91.189.92.202 80]

W: Не удалось получить http://security.ubuntu.com/ubuntu/dists/natty-security/universe/binary-i386/P... 404 Not Found [IP: 91.189.92.202 80]

W: Не удалось получить http://security.ubuntu.com/ubuntu/dists/natty-security/multiverse/binary-i386... 404 Not Found [IP: 91.189.92.202 80]

W: Не удалось получить http://archive.ubuntu.com/ubuntu/dists/natty/main/binary-i386/Packages 404 Not Found [IP: 91.189.91.15 80]

W: Не удалось получить http://archive.ubuntu.com/ubuntu/dists/natty/restricted/binary-i386/Packages 404 Not Found [IP: 91.189.91.15 80]

W: Не удалось получить http://archive.ubuntu.com/ubuntu/dists/natty/universe/binary-i386/Packages 404 Not Found [IP: 91.189.91.15 80]

W: Не удалось получить http://archive.ubuntu.com/ubuntu/dists/natty/multiverse/binary-i386/Packages 404 Not Found [IP: 91.189.91.15 80]

W: Не удалось получить http://getswiftfox.com/builds/debian/dists/unstable/non-free/binary-i386/Pack... 404 Not Found

W: Не удалось получить http://archive.ubuntu.com/ubuntu/dists/natty-updates/main/binary-i386/Packages 404 Not Found [IP: 91.189.91.15 80]

W: Не удалось получить http://archive.ubuntu.com/ubuntu/dists/natty-updates/restricted/binary-i386/P... 404 Not Found [IP: 91.189.91.15 80]

W: Не удалось получить http://archive.ubuntu.com/ubuntu/dists/natty-updates/universe/binary-i386/Pac... 404 Not Found [IP: 91.189.91.15 80]

W: Не удалось получить http://archive.ubuntu.com/ubuntu/dists/natty-updates/multiverse/binary-i386/P... 404 Not Found [IP: 91.189.91.15 80]

E: Some index files failed to download. They have been ignored, or old ones used instead.

Что с этим нужно делать, чтобы начать уже:

1. мочь апдейтиться
2. мочь доустанавливать софт

А, стоп, не к провайдеру. 11.04 не поддерживается, репозитория нет. Ставь более свежий релиз, желательно 12.04 или 13.04

Valkeru ★★★★ ()
Ответ на: комментарий от Valkeru

Так, вот это интересно:
1. как ты понял, что к провайдеру
2. 11.04 не поддерживается, но проблема в том, что 12 или 13 у меня идет гораздо медленней - слишком много всего в ядро напихали - и ставить её очень не хочется. Наоборот, иногда мысли на 9 откатиться.

неужели вручную нельзя поставить нужные пакеты чтобы геморроя не было?

AlexMcGregor ()
Ответ на: комментарий от AlexMcGregor

11.04 не поддерживается, но проблема в том, что 12 или 13 у меня идет гораздо медленней - слишком много всего в ядро напихали - и ставить её очень не хочется. Наоборот, иногда мысли на 9 откатиться.

ну не поддерживается! обновляйся! а лучше мигрируй на Debian.

i_gnatenko_brain ★★★★ ()
Ответ на: комментарий от AlexMcGregor

404 - сервер не найден. Впрочем, к делу это отношения не имеет.
2 - дело не в ведре, а в тормозной юнити, возьми Xubuntu или Lubuntu. Впрочем, если хочется юзать говно мамонта - сделай так

Valkeru ★★★★ ()
Ответ на: комментарий от Valkeru

у меня Mint. И вот как раз минт-то последний у меня и подтормаживает. Не даёт нужной скорости. Предыдущие значительно быстрей. Вот и не слезаю.

спасибо большое!

AlexMcGregor ()
Ответ на: комментарий от Valkeru

404 Not Found

К провайдеру

nslookup 91.189.91.15
Server:         192.168.0.254
Address:        192.168.0.254#53

Non-authoritative answer:
15.91.189.91.in-addr.arpa       name = likho.canonical.com.

Authoritative answers can be found from:
91.189.91.in-addr.arpa  nameserver = ns2.canonical.com.
91.189.91.in-addr.arpa  nameserver = ns1.canonical.com.
91.189.91.in-addr.arpa  nameserver = ns3.canonical.com.
ns2.canonical.com       internet address = 91.189.95.3
ns3.canonical.com       internet address = 209.6.3.210
ns1.canonical.com       internet address = 91.189.94.173

canonical.com

К провайдеру

конгениально.

novitchok ★★★★★ ()
Ответ на: комментарий от novitchok

К провайдеру
А, стоп, не к провайдеру. 11.04 не поддерживается, репозитория нет. Ставь более свежий релиз, желательно 12.04 или 13.04

конгениально.

Вырвал фразу из контекста, учитывая что человек сразу исправился.

Из тебя хороший политик выйдет, они тоже любители вырывать фразы из контекста.

demsi ()
Ответ на: комментарий от AlexMcGregor

у меня Mint. И вот как раз минт-то последний у меня и подтормаживает

Надеюсь, Mint с mate?

Также, можно LMDE (== Mint Debian). Ну или если так хочется убунту, можно попробовать 10.04 - она-то еще долго будет поддерживаться

michwill ★★★★★ ()
Ответ на: комментарий от demsi

Вырвал фразу из контекста

ну да, ну да, в том контексте было-то всего цитирование ошибки в ответе апта и мометальный диагноз про провайдера, богатый контекст, да, есть что выдирать, да.

учитывая что человек сразу исправился

ога, это каким гением надо быть, видя ответ зеркала на запрос, сразу искать затык у местного провайдера, на последней миле? давай, адвокатствуй дальше, у тебя хорошо получается, адвокаты тоже любители отрицать явное.

novitchok ★★★★★ ()
Ответ на: комментарий от novitchok

РЕШЕНО! Спасибо большое всем, кто помогал!

Решено следующим образом (для нубов, которые как и я будут пытаться понять, что же с этим всем делать)

1. открываем терминал

2. пишем nano /etc/apt/sources.list

3. Первой строчкой ставим следующее:

### Интернет-репозитарии для старых релизов Ubuntu
deb http://old-releases.ubuntu.com/ubuntu natty main universe

*обратить внимание - natty - это название моего 11.04 дистрибутива, у вас название будет другим, а universe ставить надо - в любом случае

ВСЕ ОСТАЛЬНЫЕ ССЫЛКИ НА РЕЛИЗЫ КОММЕНТИРУЕМ ЗНАКОМ # (т.е. перед всеми остальными желтыми и зелеными строками ставим # перед deb)

4. сохраняем (ctrl+o), выходим ctrl+x

5. apt-get update

6. запускаем установку того софта, который собирались

AlexMcGregor ()
Ответ на: РЕШЕНО! Спасибо большое всем, кто помогал! от AlexMcGregor

Тот, кто так делает - ССЗБ. Тогда у тебя будет недоступен ряд репозиториев.

http://ru.archive.ubuntu.com/ubuntu/
или что там у тебя, везде замени на
http://old-releases.ubuntu.com/ubuntu
а не комментируй.

Valkeru ★★★★ ()
Последнее исправление: Valkeru (всего исправлений: 1)
Ответ на: комментарий от dvrts

Блин, вот мне интересно, а если мне нужно чтобы система быстро работала, тогда мне что, новый комп покупать? Или ставить недооси вроде дамнсмолла/элементари?

AlexMcGregor ()
Ответ на: комментарий от Valkeru

404 - сервер не найден

Учи матчасть.

anonymous ()
Ответ на: комментарий от Valkeru

учту но у меня без комментирования ВСЕГО система упорно выдавала кучу ошибок

я конечно понимаю, что щас она просто никуда не обращается, но мидори-то встал, вот что важно

что такое ССЗБ?)

AlexMcGregor ()
Ответ на: комментарий от LongLiveUbuntu

1. проблема решилась 2. в чем конкретный плюс сидеть на актуальной версии? Она просто медленней да и всё, в чем разница-то?

AlexMcGregor ()
Ответ на: комментарий от AlexMcGregor

Блин, вот мне интересно, а если мне нужно чтобы система быстро работала, тогда мне что, новый комп покупать? Или ставить недооси вроде дамнсмолла/элементари?

Мир заканчивается на убунте? Овер мульйон дистрибутивов есть под старое/слабое железо, которые активно развиваются и поддерживаются. Тебе же почему-то не пришло в голову сюда ставить 98-ю венду, которая на таком летала бы?

dvrts ★★★ ()

Список твоего железа в студию. Камень, мать, видяшка, что с дисковым накопителем?

LongLiveUbuntu ★★★★★ ()
Ответ на: комментарий от AlexMcGregor

новый комп покупать?

Debian. Возможно дело в используемом софте, так что не панацея.

Winnerer ()
Ответ на: комментарий от LongLiveUbuntu

Атом, даже KDE. Как печатная машинка работает нормально.

Winnerer ()
Ответ на: комментарий от Winnerer

Наркоман? В 11.04 какие бэкпорты, когда она уже не поддерживается?

Valkeru ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.