LINUX.ORG.RU

ubuntu 13.04 не видит eth0 MSI GE60

 , ,


0

1

Доброго времени суток!

Купил себе ноутбук MSI GE60, поставил Ubuntu 13.04, система не видит сетевуху Qualcomm Atheros Bigfoot Killer E2200 Ethernet. Пообщался с урлой, нашел ман на забугорном форуме, линк)

Первая строчка кода

sudo apt-get install build-essential linux-headers
— не понял, для чего она, у меня в терминале пишет слеущее:
Пакет linux-headers — виртуальный, его функции предоставляются пакетами:   linux-headers-3.8.0-28-lowlatency 3.8.0-28.20   linux-headers-3.8.0-24-lowlatency 3.8.0-24.16   linux-headers-3.8.0-20-lowlatency 3.8.0-20.14   linux-headers-3.8.0-30-generic 3.8.0-30.44   linux-headers-3.8.0-28-generic 3.8.0-28.41   linux-headers-3.8.0-24-generic 3.8.0-24.35   linux-headers-3.8.0-20-generic 3.8.0-20.31   linux-headers-3.8.0-26-lowlatency 3.8.0-26.18   linux-headers-3.8.0-25-lowlatency 3.8.0-25.17   linux-headers-3.8.0-26-generic 3.8.0-26.38   linux-headers-3.8.0-25-generic 3.8.0-25.37   linux-headers-3.8.0-29-lowlatency 3.8.0-29.21   linux-headers-3.8.0-27-lowlatency 3.8.0-27.19   linux-headers-3.8.0-22-lowlatency 3.8.0-22.15   linux-headers-3.8.0-29-generic 3.8.0-29.42   linux-headers-3.8.0-27-generic 3.8.0-27.40   linux-headers-3.8.0-23-generic 3.8.0-23.34   linux-headers-3.8.0-22-generic 3.8.0-22.33   linux-headers-3.8.0-21-generic 3.8.0-21.32   linux-headers-3.8.0-19-generic 3.8.0-19.30   linux-headers-3.8.0-19-lowlatency 3.8.0-19.13 Вы должны явно указать, какой именно вы хотите установить.  E: Для пакета «linux-headers» не найден кандидат на установку

Решил, что тут у меня всё в порядке, команда

uname -a выдаёт 
Linux Twilight 3.8.0-30-generic #44-Ubuntu SMP Thu Aug 22 20:52:24 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
Перешел к следующему шагу — скачал и распаковал архив compat-wireless-2012-05-10-p.tar.bz2, скачал патч compat-patch.txt — их можно найти здесь Извлёк архив, пропатчил его, закинув патч в извлечённую папку и выполнив две команды
patch --dry-run -p2 < /path/to/compat-patch.txt
patch -p2 < /path/to/compat-patch.txt
Потом выполняю make и мне выдаёт ошибку —
twilight@Twilight:~/compat-wireless-2012-05-10-p$ sudo make
make -C /lib/modules/3.8.0-30-generic/build M=/home/twilight/compat-wireless-2012-05-10-p modules
make[1]: Вход в каталог `/usr/src/linux-headers-3.8.0-30-generic'
  CC [M]  /home/twilight/compat-wireless-2012-05-10-p/drivers/bcma/main.o
In file included from /home/twilight/compat-wireless-2012-05-10-p/include/linux/bcma/bcma.h:8:0,
                 from /home/twilight/compat-wireless-2012-05-10-p/drivers/bcma/bcma_private.h:8,
                 from /home/twilight/compat-wireless-2012-05-10-p/drivers/bcma/main.c:8:
/home/twilight/compat-wireless-2012-05-10-p/include/linux/bcma/bcma_driver_pci.h:207:23: ошибка: expected «=», «,», «;», «asm» or «__attribute__» before «bcma_core_pci_init»
In file included from /home/twilight/compat-wireless-2012-05-10-p/drivers/bcma/main.c:8:0:
/home/twilight/compat-wireless-2012-05-10-p/drivers/bcma/bcma_private.h:16:15: ошибка: expected «=», «,», «;», «asm» or «__attribute__» before «bcma_bus_register»
/home/twilight/compat-wireless-2012-05-10-p/drivers/bcma/main.c:142:15: ошибка: expected «=», «,», «;», «asm» or «__attribute__» before «bcma_bus_register»
/home/twilight/compat-wireless-2012-05-10-p/drivers/bcma/main.c:17:21: предупреждение: «bcma_bus_next_num» определена, но нигде не используется [-Wunused-variable]
/home/twilight/compat-wireless-2012-05-10-p/drivers/bcma/main.c:86:12: предупреждение: «bcma_register_cores» определена, но нигде не используется [-Wunused-function]
make[3]: *** [/home/twilight/compat-wireless-2012-05-10-p/drivers/bcma/main.o] Ошибка 1
make[2]: *** [/home/twilight/compat-wireless-2012-05-10-p/drivers/bcma] Ошибка 2
make[1]: *** [_module_/home/twilight/compat-wireless-2012-05-10-p] Ошибка 2
make[1]: Выход из каталога `/usr/src/linux-headers-3.8.0-30-generic'
make: *** [modules] Ошибка 2

без sudo такая же фигня. Помогите, буду благодарен.

P.S.: wi-fi работает нормально.


Ответ на: комментарий от kostik87

Отлично!

Константин, всё работает! Спасибо огромное!

Как ставить ядро узнал здесь.

Enfos ()

Для владельцев GX60

Те, кто использует видеокарту от AMD (MSI GX60, например) и будет обновлять ядро до 3.10, должны быть осторожны. Проприетарные драйверы AMD пока не работают на этом ядре.

scoutov ()
Ответ на: Для владельцев GX60 от scoutov

Ge Force

У меня ноут с видюхой Ge Force — ноут перед покупкой выбирал зная, что с атишной проблемы могут быть под линухом. Спасибо за беспокойство!

Enfos ()
10 декабря 2013 г.
Ответ на: Ge Force от Enfos

Поставил Kernel 3.10.0

Поставил Kernel 3.10.0 но проблема всеравно сохраняется, как её устранить? maxim@maxim-GT70:~/Загрузки/compat-wireless-2012-05-10-p$ sudo make make -C /lib/modules/3.10.0-031000-generic/build M=/home/maxim/Загрузки/compat-wireless-2012-05-10-p modules make[1]: Вход в каталог `/usr/src/linux-headers-3.10.0-031000-generic' CC [M] /home/maxim/Загрузки/compat-wireless-2012-05-10-p/drivers/bcma/main.o In file included from /home/maxim/Загрузки/compat-wireless-2012-05-10-p/include/linux/bcma/bcma.h:8:0, from /home/maxim/Загрузки/compat-wireless-2012-05-10-p/drivers/bcma/bcma_private.h:8, from /home/maxim/Загрузки/compat-wireless-2012-05-10-p/drivers/bcma/main.c:8: /home/maxim/Загрузки/compat-wireless-2012-05-10-p/include/linux/bcma/bcma_driver_pci.h:207:23: ошибка: expected «=», «,», «;», «asm» or «__attribute__» before «bcma_core_pci_init» In file included from /home/maxim/Загрузки/compat-wireless-2012-05-10-p/drivers/bcma/main.c:8:0: /home/maxim/Загрузки/compat-wireless-2012-05-10-p/drivers/bcma/bcma_private.h:16:15: ошибка: expected «=», «,», «;», «asm» or «__attribute__» before «bcma_bus_register» /home/maxim/Загрузки/compat-wireless-2012-05-10-p/drivers/bcma/main.c:142:15: ошибка: expected «=», «,», «;», «asm» or «__attribute__» before «bcma_bus_register» /home/maxim/Загрузки/compat-wireless-2012-05-10-p/drivers/bcma/main.c:17:21: предупреждение: «bcma_bus_next_num» определена, но нигде не используется [-Wunused-variable] /home/maxim/Загрузки/compat-wireless-2012-05-10-p/drivers/bcma/main.c:86:12: предупреждение: «bcma_register_cores» определена, но нигде не используется [-Wunused-function] make[3]: *** [/home/maxim/Загрузки/compat-wireless-2012-05-10-p/drivers/bcma/main.o] Ошибка 1 make[2]: *** [/home/maxim/Загрузки/compat-wireless-2012-05-10-p/drivers/bcma] Ошибка 2 make[1]: *** [_module_/home/maxim/Загрузки/compat-wireless-2012-05-10-p] Ошибка 2 make[1]: Выход из каталога `/usr/src/linux-headers-3.10.0-031000-generic' make: *** [modules] Ошибка 2

Different ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.