LINUX.ORG.RU

lilo отсутствует kernel

 ,


0

1

Cистема Gentoo. Какая-то мистика. Отсутствует ядро, на которое указывает загрузчик.
ls -la /boot

total 8
drwxr-xr-x  2 root root 4096 Oct 11  2012 .
drwxr-xr-x 20 root root 4096 Aug  5 16:27 ..
cat /etc/lilo.conf
boot = /dev/sda
map = /boot/map
prompt
timeout = 50
vga = normal
default = gentoo
image = /boot/kernel-3.3.8
        label=gentoo
        read-only
        root = /dev/sda3
Не пойму, как такое может быть. Куда все делось и откуда теперь собственно lilo берет образ для загрузки. Система грузится.
lilo
Warning: LBA32 addressing assumed
Fatal: open /boot/kernel-3.3.8: No such file or directory


Лол, echo image = /boot/kernel-socnie-pisecki-6.6.6 >>/etc/lilo.conf

anonymous ()
Ответ на: комментарий от kostik87

Это другая система, с той я решаю. Была попытка сравнить настройки с работающей системой - вот и всплыло. Вопрос откуда лило грузит остается открытым.
cat /etc/fstab

/dev/sda1               /boot           ext3            noauto,noatime  1 2
/dev/sda3               /               ext4            noatime         0 1
/dev/sda2               none            swap            sw              0 0
/proc                   none            proc            default         0 0

delen ()
Ответ на: комментарий от delen

Была попытка сравнить настройки с работающей системой - вот и всплыло.

С вероятностью 90% у вас не правильно сконфигурировано ядро, я же вам указал, что нужно показать.

У вас /boot на отдельном разделе

/dev/sda1               /boot           ext3            noauto,noatime  1 2

Либо указывайте в конфиге lilo:

image = /kernel-3.3.8
Либо создайте в /boot символическую ссылку:
mount /boot
cd /boot
ln -s ./ boot

kostik87 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.