LINUX.ORG.RU

LILO не запускается


0

0

RH 9.0 2.4.20 hda1=NTFS hda2=ext3 hda3=swap hda5=vfat AthXP2100/512-2700 HDD=Maxtor/70Gb

Выбор операционной системы реализован через boot.ini, LILO установлен на hda2.
После выбора "Linux" из меню, появляется

LIL-

Дальнейшая загрузка не продолжается.
Загрузка с дискеты завершается успешно.
Перед тем как это случилось устанавливал пакеты руссификации (Cyrilllic Ed), добавлял сушествующему ядру поддержку NTFS ядерным патчем (RPM), в результате чего, в файл /etc/lilo.conf добавилась новая запись (текущее и первоначальное содержимое приведено ниже). Ручной правкой lilo.conf с последующим выполнением #lilo проблема не решилась. Подскажите пожалуйста, как решить эту проблему?


Первоначальное содержимое /etc/lilo.conf:
prompt
timeout=50
default=linux
boot=/dev/hda2
map=/boot/map
install=/boot/boot.b
message=/boot/message
lba32

image=/boot/vmlinuz-2.4.20-8
label=linux
initrd=/boot/initrd-2.4.20-8.img
read-only
append="hdd=ide-scsi root=LABEL=/"


Текущее содержимое /etc/lilo.conf:
timeout=50
default=2.4.20-13.9
boot=/dev/hda2
map=/boot/map
install=/boot/boot.b
message=/boot/message
lba32
prompt

image=/boot/vmlinuz-2.4.20-13.9
label=2.4.20-13.9
initrd=/boot/initrd-2.4.20-13.9.img
read-only
append="hdd=ide-scsi,root=/dev/hda2"

image=/boot/vmlinuz-2.4.20-8
label=2.4.20-8
initrd=/boot/initrd-2.4.20-8.img
read-only
append="/hdd=ide-scsi,root=/dev/hda2"


И ещё, стоит заметить: все файлы упомянутые в файле /etc/lilo.conf существуют и находятся на своих местах.
Однако, команда $rpm -qpl /mnt/cdrom/lilo-21.4.4-22.i386.rpm демонстрирует файлы;

/etc/lilo.defines (не существует)
/etc/lilo.conf (существует)
/etc/diktab (не существует)
/sbin/lilo (существует)
/boot/bootNNNN (существует boot0302)
/boot/partNNNN (существует)
/boot/map (существует)
/boot/*.b (существует несколько)

Спасибо.


Re: LILO не запускается

Мне так КААтся что у тебя просто слетел загрузчик, попробуй его востановить. Сразу скажу как это делать не знаю поскольку лилой не пользовался.

cyclon ★★★★★ ()
Ответ на: Re: LILO не запускается от cyclon

Re: Re: LILO не запускается

А вы загляните в доки - там написано в каком месте траблы в зависимости от того, на какой букве виснет LILO.

Сорри за дурацкий ответ. =)

e-max ()

Re: LILO не запускается

Проблема решена.
LILO не мог запуститься из-за того, что после изменения файла /etc/lilo.conf и запуска #lilo, изменилась загрузачная область hda2, которую необходимо было скопировать и перенести в файл, к которому ссылается строка boot.ini (напомню, выбор ОС у меня реализован средствами NT-Loader).
После изменения этого файла, LILO стал нормально запускаться, но ни одно ядро из списка не удавалось загрузить до конца (Kernel panic: no init found. Try passing init=option to Kernel) Эта проблема решилась изменением конфигурации /etc/lilo.conf :

prompt
timeout=50
default=2.4.20-13.9
boot=/dev/hda2
map=/boot/map
install=/boot/boot.b
message=/boot/message
lba32

image=/boot/vmlinuz-2.4.20-13.9
label=2.4.20-13.9
initrd=/boot/initrd-2.4.20-13.9.img
append hdd=ide-scsi root=/dev/hda2

image=/boot/vmlinuz-2.4.20-8
label=2.4.20-8
initrd=/boot/initrd-2.4.20-8.img
append hdd=ide-scsi root=/dev/hda2


Проблема обсуждалась на следующих форумах:
http://by.ru/serv/book/view?book=opensoft
http://knoppix.ru/forum3/index.php
http://www.linux.org.ru/view-group.jsp?group=126
http://www.linuxshop.ru/forum/

artra ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.