LINUX.ORG.RU

ubuntu vpn pptp и resolv.conf


0

1

Приветствую товарищи!

Такая проблема: создал vpn соединение штатными средствами ubuntu 12.04, но не для доступа интернета, а для подключения к серверу. И теперь когда подключается vpn - в файл resolv.conf прописываются dns полученные от этого vpn соединения, как можно отключить получение dns от vpn сервера?

В «виндовсе» это делалось просто: снималась галка в настройках впн подключения: «Использовать основной шлюз в удалённой сети».

Что бы интернет оставался работать как до подключения vpn?!

Помогите пожалуйста!?


кое что получилось, НО не до конца

поправил конфиги впн соединения, убрав, часть, которая отвечает за получение DNS и копирование их в resolv.conf

/etc/ppp/ip-down.d/<имя впн соединения>
/etc/ppp/ip-up.d/<имя впн соединения>

Вот результат route -n

Таблица маршутизации ядра протокола IP
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0         0.0.0.0         0.0.0.0         U     0      0        0 ppp0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 eth0
192.168.1.0     0.0.0.0         255.255.255.0   U     1      0        0 eth0
192.168.1.130   0.0.0.0         255.255.255.255 UH    0      0        0 ppp0
<внешний IP>  192.168.1.1     255.255.255.255 UGH   0      0        0 eth0
<внешний IP>  192.168.1.1     255.255.255.255 UGH   0      0        0 eth0
<внешний IP>  192.168.1.1     255.255.255.255 UGH   0      0        0 eth0

Думается, что маршруты какие то всё равно пишутся при подключении. Не знаю как наладить...

babel ()
Ответ на: кое что получилось, НО не до конца от babel

что бы было ещё понятнее...

Как то была практика использования open vpn, так было всё замечательно, ни каких лишних маршрутов, подключаешься к серверу и видишь только сервер, а интернет или локальная сеть продолжает работать так же и после подключения!

Помогите!

babel ()

А если попробовать убрать из файла /etc/ppp/options.pptp опцию usepeerdns? Это должно отключить получение dns.

Nokman ()
Ответ на: комментарий от Nokman

Нет такой опции

Спасибо за ответ!

Посмотрел файл, там нет опции «usepeerdns». а вообще получение dns я уже убрал из конфигов самого соединения.

ТУТ ПРОБЛЕМА В ДРУГОМ - маршруты нужно убрать или предотвратить вообще их получение при установке соединения, Как это сделать?

babel ()
Ответ на: Нет такой опции от babel

Скорее всего нужно написать скрипт, который будет удалять маршруты, закинуть его в /etc/ppp/ip-up.d/script_name.sh хотя не уверен. Возможно есть более правильное решение.

Nokman ()

Кстати, как вариант можно еще тогда попробовать прописать в options.pptp опцию nodefaultroute - не менять дефолтный маршрут. Поможет?

Nokman ()
Ответ на: Ничего не вышло с "nodefaultroute" от babel

Re: Ничего не вышло с "nodefaultroute"

Маршруты: До подключения:

/etc/ppp# route -n
Таблица маршутизации ядра протокола IP
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0         192.168.2.1     0.0.0.0         UG    0      0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 eth0
192.168.2.0     0.0.0.0         255.255.255.0   U     1      0        0 eth0
195.46.165.163  192.168.2.1     255.255.255.255 UGH   0      0        0 eth0

После:

route -n
Таблица маршутизации ядра протокола IP
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0         0.0.0.0         0.0.0.0         U     0      0        0 ppp0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 eth0
192.168.1.130   0.0.0.0         255.255.255.255 UH    0      0        0 ppp0
192.168.2.0     0.0.0.0         255.255.255.0   U     1      0        0 eth0
<ip сервера vpn>  192.168.2.1     255.255.255.255 UGH   0      0        0 eth0
<ip сервера vpn>  192.168.2.1     255.255.255.255 UGH   0      0        0 eth0

как видно, поменял подсеть, а то у удалённой сети тоже было 192.168.1.0.

что ж делать то?

babel ()
Ответ на: Re: Ничего не вышло с "nodefaultroute" от babel

ПОЛУЧИЛОСЬ!

Пробовал, пробовал и получилось: 1. Скачал альтернативный ВПН клиент: http://code.google.com/p/vpnpptp/downloads/list 2. Взял оттуда только «vpnpptp-allde-0.3.8-amd64.deb», так как l2tp не требуется, а pptp вроде как уже есть, раз не спросил. 3. Установил. 4. Запустил конфигуратор «vpnpptp» через меню. 5. Настройки сделал как обычно, со своими настройками, ничего не мудрил. На третьем шаге настроек поставил галочку «Не изменять дефолтный (боже, кто переводил?) шлюз, запустив VPN PPTP в фоне».

После этого стало работать, НО я до этого пробовал и другие различные варианты: Например: «Solved my own problem. I had to set DEFAULT_FORWARD_POLICY in /etc/default/ufw to „ACCEPT“ Thanks for the help though.» с иностранного форума: полный текст по ссылке: http://ubuntuforums.org/showthread.php?t=2021763.

А через штатный ВПН клиент так и не получилось добиться результата.

Может кому поможет!

Спасибо всем за помощь!

babel ()

Не могу разобраться как в Ubuntu 14.04 LTS (более ранние версии тоже пробовал), настроить pptp подключение, так что бы основной шлюз оставался интернет провайдера, а не pptp сервера. Я думаю, Вам знакома ситуация, когда в Windows подключаешься через VPN сервер и трафик заворачивается через VPN Server. То бишь, сайты открываются не через локальный провайдер, а через VPN Server. В Windows это решается снятием галочки «использовать основной шлюз в удаленной сети». Помогите разобраться с Ubuntu, я новичек. Пробовал через vpnpptp, не получилось. Кто-то сталкивался с таким?

proxi ()
Ответ на: комментарий от proxi

man pppd:

defaultroute Add a default route to the system routing tables, using the peer as the gateway, when IPCP negotiation is successfully completed. This entry is removed when the PPP connection is broken. This option is privileged if the nodefaultroute option has been specified.

т.е. defaultroute имеет приимущество над nodefaultroute и если первый есть где-то в конфиге, то второй не поможет.

В процессе еще может учавствовать файл /etc/ppp/options. pppd call <your_connection> dryrun, чего говорит?

//на даты посмотрел.. зачем так делать?

naszar ()
Последнее исправление: naszar (всего исправлений: 3)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.