LINUX.ORG.RU

kexec смена mac-адреса

 ,


0

1

в определенный момент (предположительно после установки kexec) при каждой перезагрузке (как с использованием kexec, так и без) начал меняться mac-адрес сетевой карты.
собственно вопрос в том, кто виноват и что делать?
debian sid, amd64, ядро дефолтное
вывод lspci -v

02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)
        Subsystem: ASUSTeK Computer Inc. U6V/U31J laptop
        Flags: bus master, fast devsel, latency 0, IRQ 43
        I/O ports at e800 [size=256]
        Memory at fafff000 (64-bit, prefetchable) [size=4K]
        Memory at faff8000 (64-bit, prefetchable) [size=16K]
        Expansion ROM at fbef0000 [disabled] [size=64K]
        Capabilities: [40] Power Management version 3
        Capabilities: [50] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [70] Express Endpoint, MSI 01
        Capabilities: [ac] MSI-X: Enable- Count=4 Masked-
        Capabilities: [cc] Vital Product Data
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [140] Virtual Channel
        Capabilities: [160] Device Serial Number 78-56-34-12-68-4c-e0-00
        Kernel driver in use: r8169

★★★★★

Ответ на: комментарий от mky

разный, уже 91 запись о сетевухах в /etc/udev/rules.d/70-persistent-net.rules

maloi ★★★★★ ()

Обнови ядро.
Сбрось BIOS (или попробуй только HPET попереключать).
У меня перестала пока-что глючить после выставления HPET в 64бит режим.

# uname -a; lspci -s 02:00.0 -v; modinfo r8169
Linux fs.local 3.1.5-gentoo #2 SMP Wed Oct 31 14:15:24 EET 2012 x86_64 Intel(R) Core(TM) i3 CPU 550 @ 3.20GHz GenuineIntel GNU/Linux
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)
        Subsystem: ASUSTeK Computer Inc. M4A785TD Motherboard
        Flags: bus master, fast devsel, latency 0, IRQ 43
        I/O ports at e800 [size=256]
        Memory at f4fff000 (64-bit, prefetchable) [size=4K]
        Memory at f4ff8000 (64-bit, prefetchable) [size=16K]
        Expansion ROM at f7ef0000 [disabled] [size=64K]
        Capabilities: [40] Power Management version 3
        Capabilities: [50] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [70] Express Endpoint, MSI 01
        Capabilities: [ac] MSI-X: Enable- Count=4 Masked-
        Capabilities: [cc] Vital Product Data
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [140] Virtual Channel
        Capabilities: [160] Device Serial Number 00-00-00-00-00-00-00-00
        Kernel driver in use: r8169
        Kernel modules: r8169

filename:       /lib/modules/3.1.5-gentoo/kernel/drivers/net/r8169.ko
firmware:       rtl_nic/rtl8105e-1.fw
firmware:       rtl_nic/rtl8168e-3.fw
firmware:       rtl_nic/rtl8168e-2.fw
firmware:       rtl_nic/rtl8168e-1.fw
firmware:       rtl_nic/rtl8168d-2.fw
firmware:       rtl_nic/rtl8168d-1.fw
version:        2.3LK-NAPI
license:        GPL
description:    RealTek RTL-8169 Gigabit Ethernet driver
author:         Realtek and the Linux r8169 crew <netdev@vger.kernel.org>
srcversion:     3E842CC3B34475192563328
alias:          pci:v00000001d00008168sv*sd00002410bc*sc*i*
alias:          pci:v00001737d00001032sv*sd00000024bc*sc*i*
alias:          pci:v000016ECd00000116sv*sd*bc*sc*i*
alias:          pci:v00001259d0000C107sv*sd*bc*sc*i*
alias:          pci:v00001186d00004302sv*sd*bc*sc*i*
alias:          pci:v00001186d00004300sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008169sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008168sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008167sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008136sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008129sv*sd*bc*sc*i*
depends:
vermagic:       3.1.5-gentoo SMP mod_unload modversions
parm:           use_dac:Enable PCI DAC. Unsafe on 32 bit PCI slot. (int)
parm:           debug:Debug verbosity level (0=none, ..., 16=all) (int)

DiMoN ★★★ ()
Ответ на: комментарий от DiMoN

Обнови ядро.

до которого? у меня 3.2

У меня перестала пока-что глючить после выставления HPET в 64бит режим.

не уверен что в биосе есть что-то подобное, но поищу.

maloi ★★★★★ ()
Ответ на: комментарий от DiMoN

ноутбучные биосы не могут похвастаться большим количеством настроек, в моем ничего про HPET нет. я уж было подумал что такое может быть от отсутсвия риалтековской фирмвари в дебиановском ядре, но её установка не изменила ситуацию. сброс биоса на дефолт тоже ничего не изменил (кроме времени загрузки - теперь там PXE клиент какое-то время думает, прежде чем в grub попадет).

есть ещё какие-нибудь идеи? или просто добавить правило для udev, чтобы имя было всегда одно и не мучать себя?

maloi ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.