LINUX.ORG.RU

Отказано в доступе 2


0

1

Суть такова, монтируется (bind) каталог /srv:

cat /etc/fstab | grep /whs
/dev/system/whs /mnt/whs ext4 defaults 1 2
/mnt/whs/srv /srv auto bind,exec,users 1 2

Обратим внимание на параметр exec

Сразу после загрузки:

cat /proc/mounts | grep /srv
/dev/mapper/system-whs /srv ext4 
rw,nosuid,nodev,noexec,relatime,barrier=1,data=ordered 0 0

umount /srv
mount /srv

cat /proc/mounts | grep /srv
/dev/mapper/system-whs /srv ext4 rw,relatime,barrier=1,data=ordered 0 0 

То есть, изначально устанавливается атрибут noexec, после umount / mount все становится как надо.

Как починить?

// вопрос не связан с первой частью, это другая система и другой комп.

В третьем «cat» вместо /etc/fstab должно быть /proc/mounts?

Kiborg ★★★ ()

Заменить exec,users на users,exec

ABW ★★★★ ()
Ответ на: комментарий от linuxnewb

man mount> This option implies the options noexec, nosuid, and nodev

...и более поздняя опция переопределяет более раннюю

YAR ★★★★★ ()
Ответ на: комментарий от linuxnewb

А хз. Может опции вступают в действие только после использования users по основному назначению - разрешить пользователю смонтировать/отмонтировать диск?

YAR ★★★★★ ()
Ответ на: комментарий от YAR

Действительно хз, но оно ввело меня в заблуждение. Ладно, изменение порядка параметров сработало. Спасибо еще раз.

linuxnewb ()
Ответ на: комментарий от YAR

При загрузке не mount что ли монтирует? Я бы зарепортил баг.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.