LINUX.ORG.RU

Ошибка при компиляции ядра 2.4


0

0

Rad Hat. Все компилится. Но когда make modules install - вылезает ошибка

depmod: Can't open /lib/modules/2.4.21-4.ELcustom/modules.dep for writing /lib/modules/2.4.21-4.ELcustom is not a directory.

действительно нету /lib/modules/2.4.21-4.ELcustom Что-то сомнительно, что ее надо ручками создавать :) Как исправить?

Спасибо!

anonymous

Re: Ошибка при компиляции ядра 2.4

ага - и в Makefile есть строка

EXTRAVERSION = -4.ELcustom

здесь поправить?

anonymous ()
Ответ на: Re: Ошибка при компиляции ядра 2.4 от anonymous

Re: Ошибка при компиляции ядра 2.4

не надо там ниче править!

EXTRAVERSION это уникальное имя ядра твоего! как там напишешь так и будет твое ядро называться, например EXTRAVERSION = my_config даст результат твоего ядра 2.4my_config

соответственно в /lib/modules будет папка с модулями по имени твоего ядра, для примера выше /lib/modules/2.4my_config; для твоего примера /lib/modules/2.4.21-4.ELcustom так и получается!

команда modules install как раз и переносит модули в /lib/modules/2.4.21-4.ELcustom (в твоем случае), этаже команда должна создавать этот каталог

berkuf ()

Re: Ошибка при компиляции ядра 2.4

вообще-то команда называется
make modules_install

и делать ее надо до make install

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.