LINUX.ORG.RU

3.3.1 kernel + ath9k

 


0

4

При установке нового ядра (3.3.1-pf) отвалился wifi. Один раз непонятным образом удалось подключиться. Нагуглил, что проблема в ath9k драйвере.

Вот ещё: https://forums.mageia.org/en/viewtopic.php?f=15&t=2172

Им в репы пришло какое-то обновление в фиксом.

Кто сталкивался? Кто-то починил?

★★★

Было такое на 3.3.?-pf, но сейчас на на следующей версии снова заработал. Сейчас работает:

$ uname -r

3.2.6-pf

ymuv ★★★★ ()

3.3.1-1-ARCH
После суспенда приходится выгружать модули, иначе не подключается ни к какой сети.

cheerfulboy ()

такая же фигня сейчас... наверное, придётся откатываться на более старый.

и что там постоянно ломают? лучше бы починили :(

BattleCoder ★★★★★ ()
Ответ на: комментарий от cheerfulboy

та же фигня, но у меня ни разу не подключилось... поставил lts ядро, всё ок.

outsider ★★ ()

У меня всё гуд. Софт АП работает, не отваливалась...

Pakostnik ★★★ ()

У меня тоже отвалилось! Сижу на 3.3.0 Давай вместе разбираться :)

xorik ★★★★★ ()

починили в 3.4

anonymous ()

А если попробовать ему подсунуть или собрать с модулем из 3.2.* или 3.4? Какие могут быть проблемы? Соберется?

tyakos ★★★ ()

Сталкивался с подобным иногда при просыпании ноута. Как-то эпизодически проявляется.

imul ★★★★★ ()

Спасибо тебе мил человек за то, что уберег мой мозг от насилия. Теперь точно не буду обновлять свое 3.0.4-ck

partyzan ★★★ ()

скину другу смс что бы не спешил обновляться

zibert ★★★ ()
Ответ на: комментарий от tyakos
Дебианщик? До 3.2.14 можно обновлять спокойно.

Гентушник. Просто на моем конфиге начиная с 3.1 или 3.2 (не помню уже) в dmesg портянки сыпались. Жаль забыл уже по какому поводу. Помню только то, на что ругалось работало, но все равно осталось ощущение, что то работает не так как надо.

partyzan ★★★ ()
Ответ на: комментарий от tyakos

Просто подсунуть не выйдет. Надо вытаскивать сорц из 3.2 и пересобирать для 3.3 с последующей заменой оригинального модуля ядра 3.3 на самосборный.

carasin ★★★★★ ()

Подтверждаю, после обновления на 3.3.1 вайфай после старта системы работает, потом рандомно отваливается и возвращаться не желает без перезагрузки.

pss ()

cast xorik BattleCoder outsider

Получилось решить. В исходниках заменил ath на версию из 3.2.14. Собралось, запустилось. С версией из 3.4-rc2 не собралось. Если кому-то надо, могу попробовать скинуть модули.

tyakos ★★★ ()
Ответ на: комментарий от tyakos

для себя смысла не вижу, откатился на 3.2.14 и всё =) мне 3.3 сильно не нужно (особых вкусностей там не вижу).

я бы и не обновлялся... да вот только wifi у меня дома раньше всегда работал. а вот в другом месте (используется WPA2) с недавних пор (с этого года) отвалился... бываю там редко, поэтому точный момент назвать трудно.

и они там что-то перенастраивали... вот и не знаю. может, версия wpa_supplicant кривая, или networkmanager кривой, и не в ядре дело...

p.s. раз уж так, можете багрепорт написать (хотя может его уже написал кто?), вместе с решением проблемы... чтобы кривой код заменили на старый.

BattleCoder ★★★★★ ()
Ответ на: комментарий от BattleCoder

Я его ставил, потому что оно pf. А на 3.2.7 откатываться не хочу.

Мне, кстати, в Арч недавно обновление wpa_supplicant прилетало. Посмотрите ченжлог, может пофиксили Вашу проблему.

tyakos ★★★ ()
Ответ на: комментарий от tyakos

было бы ещё здорово хоть знать, в чём проблема... сначала попробую просто с последней версией подключиться.

логи мало говорят, может, debug надо где-то включать. постараюсь разобраться подробнее.

BattleCoder ★★★★★ ()
Ответ на: комментарий от tyakos

надо попробовать у себя дома wpa поднять... и тогда мне проще уже будет от этого отталкиваться =)

но это нецелесообразно... для дома. и вдруг wpa enterprise. ладно бы wpa-psk

BattleCoder ★★★★★ ()

Поставил linux-lts, linux-lts-headers, nvidia-lts и virtualbox-source.

Ну нафиг эти обновления ядра бесконечные. Лучше бы оставался на gentoo.

cheerfulboy ()
Ответ на: комментарий от cheerfulboy

я с gentoo и пишу =) если что. там проблема такая же. на тестовой ветке ядра, да...

потому и откатился на более старое

BattleCoder ★★★★★ ()
Ответ на: комментарий от BattleCoder

В генте хотя бы откатиться по-человечески можно было.

$ downgrade linux

 The following packages are available in your cache:
        1       local   linux-3.3.1-1-x86_64.pkg.tar.xz [installed]
        2       local   linux-3.2.14-1-x86_64.pkg.tar.xz
        3       local   linux-3.2.13-1-x86_64.pkg.tar.xz

        please choose a version, [s]earch A.R.M., or [q]uit: 2
загрузка пакетов...
предупреждение: откат версии пакета linux (3.3.1-1 => 3.2.14-1)
разрешение зависимостей...
проверка на взаимную несовместимость...
ошибка: не удалось подготовить запрос (не удалось удовлетворить зависимости)
:: nvidia: требует linux>=3.3
:: virtualbox-modules: требует linux>=3.3
 could not install package /var/cache/pacman/pkg/linux-3.2.14-1-x86_64.pkg.tar.xz

Понимаю, что нытье, ССЗБ и RTFM, но от этого не легче.

cheerfulboy ()

Все отлично на стоковых арчевских ядрах.

MaZy ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.