LINUX.ORG.RU

3G МТС Интернет + Wvdial: No carrier


0

1

Всем доброго времени суток. И вот назгрела очередная проблема с 3G Интернет.

Каждый день после выключения модема на 10-12 часов, его включения доступ к интернету становится не возможным.

При попытке связаться с интернет через 3G модем (Hauwei E171) пишет ошибку: No carrier, каждый раз при попытке связаться по телефону. Проблема временно решается при помощи запуска через modem manager, хотя и не спервого раза. Например уже при 5 попытке связи, доступ к модему полностью прерывается, network manager пишет что модем не найден а после доступ появляется вновь. Убедился что проблема не в PIN и не PUK. Кажется проблема так же и не в wvdial, так как через chat-scrips пишет эквивалентную ошибку.

Конфиги: http://pastebin.ru/sUQEUbFG

Дистрибутив: Gentoo Linux, Kernel 3.2.1

Udev собственно пересобран с extras как и установлен usb_modeswitch, используется usb 2.0 и echi контроллер.

попробуй на другой /dev/ttyUSBx вызов делать

TERRANZ ★★★★ ()
Ответ на: комментарий от kostik87

не помогло

Я пробовал не помогает. dmesg говорит что модем определяется в ttyUSB0, для управления указан tttyUSB2, я пробовал и его. Но без толку.

tuxradar ()
Ответ на: не помогло от tuxradar

Ваша учётная запись есть в группе uucp ?

Ещё раз говорю, у меня такой же модем, абсолютно, с этим конфигом всё работает.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

ну, разумеется

щё раз говорю, у меня такой же модем, абсолютно, с этим конфигом всё работает.

Разумеется. Обращу внимание что я также коннектюсь и через root. :) Эх, повезло вам. =)

tuxradar ()
Ответ на: ну, разумеется от tuxradar

Значит у вас проблемы с ядром, или вы не всё показали и рассказали.

Да, я не использюю usb_modeswitch.

И да, у меня Gentoo, ядро ванильное 3.0.0.

kostik87 ★★★★★ ()
Ответ на: конфиг ядра от tuxradar

Добавьте эту опцию:

CONFIG_USB_SERIAL_IPW

Эту опцию я не включал:

CONFIG_USB_SERIAL_GENERIC

Хотя вообще странно, вы же пишете, что вы подключаетесь к 3g сети, но затем не можете подключиться 12 часов.

Что-то странное.

Пересоберите ядро указав отсутствующую у вас опцию, уберите usb_modeswitch, скопируйте мой конфиг в /etc/wvdial.conf и дайте команду:

wvdial

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

спасибо :)

kostik87

Прошу прощения, я имел ввиду 12 часов лично выключал. После 12 часов, возвращаюсь к компу и не могу подключиться.

kostik87

Спасибо Вам, я попробую сделать как вы мне указали. Потом отпишусь, что получилось.

tuxradar ()

Прошивка в модеме какая? Может обновить стоит?

imul ★★★★★ ()

Это, скорей всего, к делу не относится, но у меня была проблема с мтсовксим модемом: сеть постоянно отваливалась и он подолгу не пропускал пакеты, хотя интерфейс не падал. В итоге оказалось, что он засыпает, если через него долго не идут данные. Разбираться как не давать ему это делать мне было лень, и в итоге я запихал в автозагрузку скрипт, который вечно пингует яндекс. В итоге все хорошо, коннект больше не пропадает.

gaga ()

Дело тут не в модеме/генте/wwdial тупо уровень сигнала низкий.

partyzan ★★★ ()

У меня раньше с ZTE mf100 такое было, подключается и работает, но потом инет отрубался, хотя коннект был, оказалось просто пропадал сигнал.

doomgl ()
Ответ на: [Решено] от tuxradar

....

partyzan

В той территории где живу я отличный сигнал. Всегда ловит 3G. :))

imul

Модем слишком новый, чтобы выполнять прошивку.

tuxradar ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.