LINUX.ORG.RU

[archlinux]не монтируются ntfs-харды через gvfs (ntfs-3g)


0

1

До этого всё мышевозно монтировалось Thunar'ом. Накачал апдейтов

upgraded gvfs (1.10.0-2 -> 1.10.1-1)
upgraded udev (173-3 -> 175-1)
fuse (2.8.5-1 -> 2.8.6-1)
polkit (0.101-2 -> 0.102-1)
pam (1.1.4-1 -> 1.1.5-1)
dbus-glib (0.94-2 -> 0.98-1)
(и многое другое) и Thunar не монтирует выводя сообщение «Authentication is required.» (пробовал pcmanfm и та же история)

Пробовал откатить то, что представлено выше и не помогло. Может можно ещё что-то откатить или нужны какие-то манипуляции, о которых я не подозреваю?

В группах disk(нововведение в новой версии udev для archlinux), storage состою.

Сессию запускал так:

exec ck-launch-session dbus-launch startxfce4
и так:
exec ck-launch-session startxfce4
и так:
#В /etc/X11/xinit/xinitrc.d лежит какой-то скрипт который что-то делает с dbus.
if [ -d /etc/X11/xinit/xinitrc.d ]; then
  for f in /etc/X11/xinit/xinitrc.d/*; do 
    [ -x "$f" ] && . "$f" 
  done
  unset f
fi
exec ck-launch-session startxfce4

★★★★

засунул всё в fstab.

проблема оказывается только в монтировании внутренних разделов а не ntfs (наконец-то нашёлся проверить ntfs-флешку). так что можно сказать, решено.

jeuta ★★★★ ()
Ответ на: комментарий от jeuta

Можно поподробнее?

У меня похожая проблема с монтированием внешнего usb-харда. Что дописать в fstab?

yura_ts ★★ ()

УМВР. xfce запускается из /etc/inittab. В настройках xfce выбрано автомонтирование внешних накопителей (и ntfs-3g, и vfat работают).

Группы пользователя:

unfo@unfo-job:~> groups
lp wheel games video audio optical storage power users

Все пакеты, конечно, последние.

unfo ★★★★★ ()
Ответ на: комментарий от unfo

Я запускаю xfce через startx.

В настройках тоже выбрано автомонтирование, группы все те же самые. Однако почему-то флэшка монтируется нормально, а внешний хард монтируется только для чтения.

ЧЯДНТ?

yura_ts ★★ ()

Проще hillman поставить для мышемонтирования носителей, чем каждый раз копаться с автомаунтом. Фиг знает, какие ещё идеи придут в голову дистростроителям.

kraftello ★★★★★ ()
Ответ на: комментарий от jeuta

polkit-gnome

ну до установки отвечал также, после установки спрашивает рутовый пароль и монтирует (как и написано в описании пакета)

mrZombie ()
Ответ на: polkit-gnome от mrZombie

polkit-gnome установил. Рутовый пароль у меня не спрашивается. Я просто щелкаю мышкой по иконке харда на рабочем столе, выбираю «Подключить том», и все как и было - монтируется только для чтения, ничего записать на диск нельзя.

yura_ts ★★ ()
Ответ на: комментарий от kraftello

hillman сказал перед монтированием внешнего харда, что файловая система может быть смонтирована только для чтения. WTF??

yura_ts ★★ ()
Ответ на: комментарий от yura_ts

Так, проблема решена:) Оказывается, не стояли ntfs-3g и ntfsprogs

yura_ts ★★ ()
Ответ на: polkit-gnome от mrZombie

может стоило перезагрузиться попробовать(я только перелогинивался)? сейчас не могу проверить... но это уже и не критично.

jeuta ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.