LINUX.ORG.RU

Где взять репозитарии для Ubuntu 9.04 (Jaunty) ?


0

1

Есть машина с Ubuntu 9.04 Jaunty, на которую надо установить пару древних программ, которые конечно же были в репозитарии этого дистра.

Проблема в том, что спустя два года эти репозитарии Canonical уже выпилила со своих северов.

Подскажите, где найти репозитарии Ubuntu для нынче неактуальных версий?

Я проверил:

1. http://ru.archive.ubuntu.com/ubuntu/ - там jaunty нет вообще.

2. http://archive.canonical.com/ubuntu/ - там каталог jaunty есть, но синхронизация пакеты не находит. То есть, в /etc/sources.list прописано:

deb http://archive.canonical.com/ubuntu/ jaunty main restricted universe multiverse               
deb http://archive.canonical.com/ubuntu/ jaunty-updates main restricted universe multiverse       
deb http://archive.canonical.com/ubuntu/ jaunty-security main restricted universe multiverse

Но при at-get update получаю:

В кеше http://archive.canonical.com jaunty Release.gpg
Игн http://archive.canonical.com jaunty/main Translation-ru
Игн http://archive.canonical.com jaunty/restricted Translation-ru
Игн http://archive.canonical.com jaunty/universe Translation-ru
Игн http://archive.canonical.com jaunty/multiverse Translation-ru
В кеше http://archive.canonical.com jaunty-updates Release.gpg
Игн http://archive.canonical.com jaunty-updates/main Translation-ru
Игн http://archive.canonical.com jaunty-updates/restricted Translation-ru
Игн http://archive.canonical.com jaunty-updates/universe Translation-ru
Игн http://archive.canonical.com jaunty-updates/multiverse Translation-ru
В кеше http://archive.canonical.com jaunty-security Release.gpg
Игн http://archive.canonical.com jaunty-security/main Translation-ru
Игн http://archive.canonical.com jaunty-security/restricted Translation-ru
Игн http://archive.canonical.com jaunty-security/universe Translation-ru
Игн http://archive.canonical.com jaunty-security/multiverse Translation-ru
В кеше http://archive.canonical.com jaunty Release
В кеше http://archive.canonical.com jaunty-updates Release
В кеше http://archive.canonical.com jaunty-security Release
W: Не удалось загрузить http://archive.canonical.com/ubuntu/dists/jaunty/Release  Unable to find expected entry  main/binary-i386/Packages in Meta-index file (malformed Release file?)

W: Не удалось загрузить http://archive.canonical.com/ubuntu/dists/jaunty-updates/Release  Unable to find expected entry  main/binary-i386/Packages in Meta-index file (malformed Release file?)

W: Не удалось загрузить http://archive.canonical.com/ubuntu/dists/jaunty-security/Release  Unable to find expected entry  main/binary-i386/Packages in Meta-index file (malformed Release file?)

E: Некоторые индексные файлы не загрузились, они были проигнорированы или вместо них были использованы старые версии

Вот. Где нынче взять репозитарии эти в интернете?

Они вот здесь: http://old-releases.ubuntu.com . Убери все галочки обычных репозитариев и впиши эти в дополнительные. main, restricted, ну и так далее, 4 или 5 строчек будет, а к ним main updates ну и так далее, 7 слов где-то.

ZenitharChampion ★★★★★ ()

Фух, нашел.

Все-таки при поиске в интернете надо прикидываться кретином и думать «как пишут тупые пользователи и маркетологи».

deb http://old-releases.ubuntu.com/ubuntu/ jaunty main restricted universe multiverse             
deb http://old-releases.ubuntu.com/ubuntu/ jaunty-updates main restricted universe multiverse     
deb http://old-releases.ubuntu.com/ubuntu/ jaunty-security main restricted universe multiverse
webhamster ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.