LINUX.ORG.RU

[AR9285][Ubuntu 11.04] Снова фризы.


0

1

Уже изрядно задолбало,на 10.04(как и на всех ядрах *.32) работает, но очень криво(падает уровень сигнала(с точкой доступа все в порядке), пропадает сеть вообще), вообще не работают: Звуковая карта(connexant HD CX20590), Ethernet-контроллер(Atheros 8152), bluetooth. Все эти устройства работают на ядрах от 2.6.38, но wlan приходится выключать в BIOS, чтобы загрузить систему. compat-wireless не помогает(Хотя от 3.1 еще не пробовал) , зависания происходят при получении IP-адреса через DHCP. Как заставить эту карту все-таки работать на ядрах новее 2.6.32?

UPD: compat-wireless 3.1-rc8 тоже не взлетел

Купи какую-нибудь юсбэшную, главное, чтобы работала наверняка и не мучайся.

imul ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

Еще лучше, как я по вашему буду делать git clone, если kernel.org отключен

N1ghtmare ★★ ()
Ответ на: комментарий от Deleted

Эта проблема проявляется в SuSE в новейших версиях, помогает обновление

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

Эта проблема проявляется в SuSE в новейших версиях, помогает обновление

Ещё раз: зачем скачивать compat-wireless из git, если в первом сообщении автор темы написал, что свежий (3.1-rc8) compat-wireless он уже пробовал? ИМХО маловероятно, что между 3.1-rc8 и git есть какие-то живительные коммиты...

Deleted ()
Ответ на: комментарий от ZenitharChampion

ну наверное я что-то не так делаю. Как я устанавливаю compat-wireless:

чтобы попасть в систему, отключаю контролер через BIOS

./scripts/driver-select ath9k
make
sudo make install
sudo make unload

Потом перезагружаюсь, т.к. нужно включить контроллер в BIOS

и при запуске получаю мертвый фриз системы. ЧЯДНТ?

N1ghtmare ★★ ()

На ядре 2.6.38 compat-wireless отлично помогал. На ядре 2.6.37 всё работало отлично само. Выше версии ядер не пробовал (да и нет уже у меня того ноута с AR9285). На 2.6.33 - 2.6.36 всё было печально, да.

carasin ★★★★★ ()
Ответ на: комментарий от carasin

Как вариант, можно попробовать этот compat-wireles. Если соберётся, то должно работать. Если нет - увы.

carasin ★★★★★ ()
Ответ на: комментарий от N1ghtmare

А как конкретно не взлетает? Не собирается?

carasin ★★★★★ ()
Ответ на: комментарий от carasin

Все собирается, устанавливается, но так же зависает при запуске

N1ghtmare ★★ ()
Ответ на: комментарий от N1ghtmare

Ээ... Не подумал об этом, сорри :D
Вот. Сохранился со времён использования Asus EeePC 1201N (прошу прощения за iFolder, но быстрогуглением ничего более внятного не нашёл).
P.S.: А откатиться до 2.6.37 - 2.6.38 не вариант? Я, например, ещё на 2.6.35 сижу.

carasin ★★★★★ ()
Ответ на: комментарий от N1ghtmare

Ни фига ж себе! Может, проблема тогда как раз не в драйвере, а в железе?

carasin ★★★★★ ()
Ответ на: комментарий от carasin

Хотя... А если попробовать pci=nomsi в параметры ядра?

carasin ★★★★★ ()
Ответ на: комментарий от carasin

pci=nomsi не помогает. С железом все ок, ибо под оффтопом или если поднимать вручную через wpa_supplicant все работает,можно конечно поднимать все в ручную, но нужен GUI. Ядро у меня дистрибутивное *.38

N1ghtmare ★★ ()
Ответ на: комментарий от N1ghtmare

А если всё-таки на 2.6.37? Оно, как и 2.6.32, работает отлично с ath9k на этой карте.

carasin ★★★★★ ()
Ответ на: комментарий от carasin

на убунту не получается накатить не-дистрибутивное ядро. Она перестает грузиться. может я и неосилятор, но конфиги дистрибутивного ядра и самосборного ядра абсолютно идентичны, но система отказывается запускаться

N1ghtmare ★★ ()
Ответ на: комментарий от carasin

Дык весь прикол в том, что у других она работает на убунте из коробки(релиз убунты тот же, ревизия контроллера та же) а у меня только на старом ядре, и то через пень-колоду

N1ghtmare ★★ ()
Ответ на: комментарий от carasin

Все попытки завести контроллер увенчались неуспехом, пошел ставить максимальную до лучших времен

N1ghtmare ★★ ()
Ответ на: комментарий от N1ghtmare

Чой-то я вспомнил про ndiswrapper. Такой вариант рассматривался?

carasin ★★★★★ ()
Ответ на: комментарий от carasin

Вы не поверите! заблеклистил ath9k, ath5k. Подгрузил Ndiswrapper, попытался подключиться...и опять словил фриз! Хочу заметить, что под самой виндой все ок работает

N1ghtmare ★★ ()
Ответ на: комментарий от N1ghtmare

Есть подозрение, что проблема железячного характера, а именно родом из BIOS'а/ACPI (телепат мне подсказывает, что система подменяет IRQ карты WiFi, ибо с подобными фризами по этой причине я как-то сталкивался). Можно попробовать вручную в BIOS'е назначить карточке постоянное IRQ. Также можно ещё выставить параметр acpi=copy_dsdt (на нетбуке EeePC 1201N была беда). Ещё, как вариант, вдобавок к выше означенной опции прописать acpi_osi=Linux (варианты: acpi_osi=!Linux / acpi_osi=«Windows 2001 SP2» / acpi_osi="!Windows 2006" / acpi_osi=«Windows 2006» / etc.).
У меня в своё время получилось завести эту карту (и Ethernet AR8132) с относительно стабильным поведением системы следующим образом:

  1. Правим DSDT;
  2. Пересобираем ядро с вкомпиливанием новой DSDT в оное (на Ubunt'е можно как-то отделаться просто пересборкой initramfs/initrd);
  3. Пишем в параметры загрузки acpi=copy_dsdt, acpi_osi=Linux и pci=nomsi (последнее - для избавления от похожих симптомов, вызванных Ethernet-картой AR8132);
  4. Собираем compat-wireless.

Вот такой он - «искаробачный» ath9k/AR9285.

carasin ★★★★★ ()
Ответ на: комментарий от N1ghtmare

А если проблема в том, что BIOS отдаёт разным ОС отличающиеся таблицы ACPI, то проверить это можно просто, к примеру, параметром acpi_osi=«Windows 2001 SP2» (или что там в дизассемблированной DSDT Вашего ноута есть?).

carasin ★★★★★ ()
Ответ на: комментарий от carasin

а почему тогда все работает через wpa_supplicant?

anonymous ()
Ответ на: комментарий от N1ghtmare

А я откуда знаю? Когда у меня было подобное, я пытался осуществить соединение исключительно посредством nm-applet'а. Так что не исключено, что в консоли тоже получилось бы =)

carasin ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.