LINUX.ORG.RU

OpenVPN+OpenSSL 2-х версий


0

1

Доброго дня! В системе установлено 2 версии OpenSSL-1,0 и 0.9.8, пытаюсь запустить openvpn c версией openssl 0.9.8.

в /etc/init.d/openvpn добавил export LD_PRELOAD=/opt/openssl/lib/libcrypto.so.0.9.8

service openvpn start
пускается openvpn: ERROR: ld.so: object '/opt/openssl/lib/libcrypto.so.0.9.8' from LD_PRELOAD cannot be preloaded: ignored.
/usr/sbin/openvpn: error while loading shared libraries: libcrypto.so.0.9.8: cannot open shared object file: No such file or directory

Погуглив -

file /opt/openssl/lib/libcrypto.so.0.9.8
ls -la /opt/openssl/lib/libcrypto.so.0.9.8

Эфект тот же

service openvpn start
пускается openvpn: ERROR: ld.so: object '/opt/openssl/lib/libcrypto.so.0.9.8' from LD_PRELOAD cannot be preloaded: ignored.
/usr/sbin/openvpn: error while loading shared libraries: libcrypto.so.0.9.8: cannot open shared object file: No such file or directory

[root@centos paul]# locate libcrypto.so.0.9.8
/opt/openssl/lib/libcrypto.so.0.9.8

В файл /etc/ld.so.conf добавил /opt/openssl/lib ЧЯДНТ?


Ответ на: комментарий от shahid
[root@centos paul]# echo /opt/openssl/lib >> /etc/ld.so.conf
[root@centos paul]# ldconfig
[root@centos paul]# LD_PRELOAD=libcrypto.so.0.9.8 openvpn
ERROR: ld.so: object 'libcrypto.so.0.9.8' from LD_PRELOAD cannot be preloaded: ignored.
openvpn: error while loading shared libraries: libcrypto.so.0.9.8: cannot open shared object file: No such file or directory

не вышло...

arbyz ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.