LINUX.ORG.RU

[ubuntu64][ubuntu32]не настроить локалку. И вопрос по 3g модему.


0

1

первый вопрос из разряда мистических- есть три компа- убунту 11.04 64бит, убунту 10.04 32бит, виндовз7 64бит. IP 192.168.0.1 192.168.0.2 192.168.0.3 маска 255.255.255.0 соответственно. Если любой из компьютеров под управлением убунту подключать к винде- все работает- пинг идет, лампочки мигают. Если соединить два компа с убунту на борту- все мертво- ping Unreactable host лампочки на кабеле не мигают. Мистика?

Второй вопрос прозаичней- кто-нибудь запускал модем flyer u2 на 64битной ОС? У меня usb_modeswitch никак не хочет создавать /dev/ttyUSB*.

★★★★★

Ответ на: комментарий от post-factum

как дома буду покажу. А вообще мысли есть по имеющейся уже информации?

pyometra ★★★★★ ()
Ответ на: комментарий от post-factum
netstat -n -r
Таблица маршутизации ядра протокола IP
Destination Gateway Genmask Flags MSS Window irtt Iface
10.6.6.6        0.0.0.0         255.255.255.255 UH        0 0          0 ppp0
192.168.0.0     0.0.0.0         255.255.255.0   U         0 0          0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U         0 0          0 eth0
0.0.0.0         0.0.0.0         0.0.0.0         U         0 0          0 ppp0
pyometra ★★★★★ ()

По поводу сети - немного мб прозвучит банально, но все же. Фаервол проверил на этой вашей убунте? Не ходят пинги вообше? Или конкретно на одну из убунт? С винды на нее зайти можешь?

У меня на работе случай был как-то. Поставил на посмотреть Мандриву. Ну типа юзерфрендли, все дела. Ну и понесло меня на своем рабочем компе поднять фтпшник. Поднял. Но такая же фигня - я вижу и пингую всех в сети, меня не видит никто, и при пингах пишется «Unreactable host». Очень долго я долбался с ней, иптаблес пролопатил, все конфиги, чуть ли не ядро пересобрал. А оказалось все банально просто - мандривка имела какой-то свой фаерфол, который отключался в ее гуевом настройщке галочкой. Он-то и не пускал никого из сети ко мне. Снял галочку - заработало. Вот такое вот оно, это ваше юзерфрендли.

Zhbert ★★★★★ ()
Ответ на: комментарий от Zhbert

с винды захожу без проблем. сейчас проверю файрволл.

pyometra ★★★★★ ()
Ответ на: комментарий от pyometra

iptables полюбому есть. Попробуй сбросить все ветки в ACCEPT, вдруг все же.

И да, покажи еще hosts и..

Гы, только что прочитал, что лампочки на кабеле не мигают. Так это, когда витузха воткнута в сетевуху, один из светодиодов постоянно горит, а второй мигает, когда есть активность. Стало быть, сетевуха вообще не работает. Или все же горит одна из лампочек?

Zhbert ★★★★★ ()
Ответ на: комментарий от post-factum
 sudo iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination         

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination         
ratte@BrainEater:~$ 
pyometra ★★★★★ ()

0) дважды проверь адреса

1) кабелем напрямую соединяешь? Кабель кроссовый или прямой? А то есть вариант, что кабель прямой и железка с виндой новее - определяет это, а железки с убунтой - нет.

Alan_Steel ★★ ()
Ответ на: комментарий от pyometra

>как они хоть отличаются? я далёк от этого, если честно :)

Для передачи данныз по витой паре используются две пары проводов, одна пара на передачу, вторая на прием, соответственно. Если втыкаешь напрямую обычным кабелем (обжат одинаково с обоих концов), то получается что «прием» воткнут на «прием», а «передача» на «передачу». Сеть не пашет. Кросс-кабель обжат так, что «прием» попадает на «передачу» и наоборот. Сеть работает. Если используется свитч, то он сам там в себе разруливает все эти штуки, все втыкается прямыми поводами. Но это все действенно для старых сетевух, новые железки умеют сами определять, какой воткнут кабель и соответтсвено распределять «прием» и «передачу».

Zhbert ★★★★★ ()
Ответ на: комментарий от pyometra

>кросссовером (я так понимаю)

Внимательно посмотри на оба коннектора со стороны зажима. Цвета должны отличаться у двух пар - 1,2 и 3,6. Т.е. 3,6 первого приходят на 1,2 второго и наоборот. Ссылку тебе дали.

Zhbert ★★★★★ ()
Ответ на: комментарий от Zhbert

Для передачи данныз по витой паре используются две пары проводов, одна пара на передачу, вторая на прием, соответственно. Если втыкаешь напрямую обычным кабелем (обжат одинаково с обоих концов), то получается что «прием» воткнут на «прием», а «передача» на «передачу». Сеть не пашет. Кросс-кабель обжат так, что «прием» попадает на «передачу» и наоборот. Сеть работает. Если используется свитч, то он сам там в себе разруливает все эти штуки, все втыкается прямыми поводами. Но это все действенно для старых сетевух, новые железки умеют сами определять, какой воткнут кабель и соответтсвено распределять «прием» и «передачу».

о как. сейчас посмотрим.

pyometra ★★★★★ ()

всем спасибо, с локалкой всё решилось. буду иметь ввиду.

а что-нибудь насчет модема не подскажете?

pyometra ★★★★★ ()
Ответ на: комментарий от pyometra

>а что-нибудь насчет модема не подскажете?

Показывай выхлоп lsusb

Zhbert ★★★★★ ()
Ответ на: комментарий от Zhbert

ущё смешнее- у меня проблема с самим кабелем :( кстати он- Вариант по стандарту EIA/TIA-568B (используется чаще). прижимаю рукой разъём- работает, отпускаю- не работает. походу с виндой проблем не было потому, что комп в другом месте стоит и кабель слегка перекручивается. а я тут тему размусолил. извиняюсь.

pyometra ★★★★★ ()
Ответ на: комментарий от Alan_Steel

скачал архив с драйверами с оф сайта. сделал по инструкции для 64битных систем- положил /switch_modem64 в /usr/local/bin/switch_modem64, подправил /etc/wvdial-general.conf и последовательно ввожу команды

sudo /usr/local/bin/switch_modem64 1c9e f000


sudo /sbin/modprobe usbserial vendor=0x1c9e product=0x9603

и вот тут-то проблема- product не меняется с f000 на 9603.

ratte@BrainEater:~$ sudo /usr/local/bin/switch_modem64 1c9e f000
[sudo] password for ratte: 
vendor=1c9e, product=f000
ratte@BrainEater:~$ sudo /sbin/modprobe usbserial vendor=0x1c9e product=0x9603
ratte@BrainEater:~$ lsusb
Bus 002 Device 014: ID 1c9e:f000  
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 013: ID 0421:02e3 Nokia Mobile Phones 5230 (PC-Suite mode)
Bus 001 Device 012: ID 045e:00dd Microsoft Corp. Comfort Curve Keyboard 2000 V1.0
Bus 001 Device 010: ID 0458:5003 KYE Systems Corp. (Mouse Systems) G-pen 560 Tablet
Bus 001 Device 009: ID 058f:6254 Alcor Micro Corp. USB Hub
Bus 001 Device 004: ID 09da:000a A4 Tech Co., Ltd Port Mouse
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
ratte@BrainEater:~$ 
pyometra ★★★★★ ()
Ответ на: комментарий от pyometra

Там написано, что твой модем работает. Ну или как минимум несколько раз работал. Может быть в отквоченном тобой выводе модем кто-то переключает 2 раза? (один раз ты, руками, а ещё один раз - какой-нибудь usb_modeswitch)

Alan_Steel ★★ ()
Ответ на: комментарий от Alan_Steel

переключил я модем. И он даже подключается. Но соединение рвется через пару минут и больше не подключается. Пропадает устройство ttyUSB3. В терминале пишет, что модем разорвал связь. Что с ним может быть?

pyometra ★★★★★ ()
Ответ на: комментарий от pyometra

Незнаю, нужно читать логи. Выполни dmesg, запомни последнее сообщение, воткни модем, добейся повторения описанной ситуации, выведи dmesg ещё раз (там будет больше сообщений) и новый кусок выложи здесь или на пейстбине.

Догадка с потолка: в твоей клавиатуре или мышке садится батарейка, она начинает слать мусор, ядро рестартует usb хаб к которому в том числе подключен модем.

Alan_Steel ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.