LINUX.ORG.RU

Не получается нормально заюзать телек в Xorg'e.


0

0

Короче что имеем:
1. Хорг версии 6.7.0
2. Дрова от нвидии 6111
3. Нстройки xorg.conf, та часть которая относиться к телеку:

Section "Device"
Identifier "Albatron 4200"
Driver "nvidia"
Screen 0
#VideoRam 131072
# Insert Clocks lines here if appropriate

Option "OverlayDefaultVisual" "true"
Option "CIOverlay" "true"
Option "Overlay" "true"
Option "RenderAccel" "true"
Option "NoLogo" "true"
Option "NvAGP" "1"

Option "CursorShadow" "true"
Option "CursorShadowAlpha" "255"
Option "CursorShadowXOffset" "4"
Option "CursorShadowYOffset" "2"

Option "NoDDC"
Option "MetaModes" "1280x1024,800x600"
Option "SecondMonitorVertRefresh" "60"
Option "TVStandard" "PAL-I"
Option "ConnectedMonitor" "CRT,TV"
Option "TwinViewOrientation" "Clone"
Option "DPMS"
Option "SecondMonitorHorizSync" "35-75"
Option "TwinView"
Option "TVOutFormat" "Composite"

EndSection
Всё остальное настройки для видюхи и монитора.

Далее.
Три варианта происходящего:
1. Когда телек подключён и настройки не закоментированы, то я получаю сообщение об ошбки, Х-ы при этом есессено не стартуют:

(EE) NVIDIA(0): No modes remaning for display device TV-0
(EE) NVIDIA(0): ***Abotring***
(EE) NVIDIA(0): Screen found, but none have usable configuraion

2. Когда настройки закомментированы но телек не отключён, то при переходе в консоль монитор гаснет а при возврате в графу он опять загорается, переход производиться с помощью ctrl+alt+f1-f6 и ctrl+f7-f10.

3. Когда телек отключён и настройки закоментированы, то всё работает пучком.

4. Когда настройки не закоментированы и телек отключён, опять же всё работает.

Спрашиваю потому что под xfree эти настройки работали, но и там была похожая проблема пока я эти параметры не прописал в конфиг.

Мне сдаётся что при переходи в консоль из графы система включает телек в результате чего моитор и уходит в стендбай.

Заранее спасибо!!!
_________________
Дистриб Linux'a, как девушка, она либо нравиться, либо нет.

Живу в Gentoo 2004.1 + emerge sync + emerge -u world, at 2.6.8.1.
★★★★★

Re: Не получается нормально заюзать телек в Xorg'e.

модлайн для телевизора-то добавь.

jackill ★★★★★ ()

Re: Не получается нормально заюзать телек в Xorg'e.

Option "MetaModes" "1280x1024,1280x1024"
а так пробовал?

DDDs ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.