LINUX.ORG.RU

VirtualBox 4 и suspend


0

1

При запущенных виртуальных машинах на VirtualBox 4.0.10 если уйти в ждущий режим (suspend to ram), при возвращении отпадает сеть, причем сам адаптер работает, пинги на локалхост ходят, но дальше нет... висит что-то еще, системное, это выражается например в зависании conky, при релогине и вовсе рабочий стол не загружается до конца, помогает только перегруз. Перезапуск сети, включая NM, не помогает. Виртуальные машины везде используются с мостом (к eth0). Я удалил неиспользуемую виртуальную сеть, не помогло. На VirtualBox 3.2 таких фокусов не было, но возвращаться не охота.
Выписал из логов на момент пробуждения все подозрительное, что связано с VB:

Jul 2 14:57:02 Z-MC vmnetBridge: Adding interface eth0 index:7
Jul 2 14:57:02 Z-MC NetworkManager: (eth0): preparing device.
Jul 2 14:57:02 Z-MC NetworkManager: (eth0): deactivating device (reason: 2).
Jul 2 14:57:02 Z-MC vmnetBridge: Started bridge eth0 to virtual network 0.
Jul 2 14:57:02 Z-MC vmnetBridge: Removing interface eth0 index:7
Jul 2 14:57:02 Z-MC vmnetBridge: Stopped bridge eth0 to virtual network 0.
...
Jul 2 14:57:04 Z-MC kernel: /dev/vmnet: hub 0 does not exist, allocating memory.
Jul 2 14:57:04 Z-MC kernel: /dev/vmnet: port on hub 0 successfully opened
...
Jul 2 14:57:04 Z-MC kernel: bridge-eth0: up
Jul 2 14:57:04 Z-MC kernel: bridge-eth0: attached
Сохранять состояние машин перед уходом в сон конечно в некотором роде выход, но когда много запущенных машин это не удобно. Подозреваю, что какой-то модуль VB некорректно засыпает/просыпается.

★★★★★

Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.