LINUX.ORG.RU

Кластеризация Glassfish


0

1

Добрый день всем. Прошу помощи в настройке кластера glassfish v.2. Делаю кластер на двух машинах, развернул Glassfish на обоих, на основной машине создал cluster1, создал nodeagent1, запустил. На второй машине создаю nodeagent2 и пытаюсь прикрутить его к Das, при запуске он ругается на то что не может пройти синхронизацию с DAS и поэтому не стартует

[#|2011-05-16T12:49:20.203+0400|INFO|sun-appserver2.1|javax.ee.enterprise.system.nodeagent|_ThreadID=10;_ThreadName=main;|NAGT0038:Executing Synchronization for node-agent With DAS|#]

[#|2011-05-16T12:49:29.279+0400|SEVERE|sun-appserver2.1|javax.ee.enterprise.system.nodeagent|_ThreadID=10;_ThreadName=main;|NAGT0035:The NodeAgent failed to complete the intial synchronization with the DAS.  Please make sure the DAS is running and is accessible from the NodeAgents server|#]

[#|2011-05-16T12:49:31.282+0400|WARNING|sun-appserver2.1|javax.ee.enterprise.system.nodeagent|_ThreadID=10;_ThreadName=main;|NAGT0013:Stopping Node Agent...|#]

кто нибудь сталкивался с такой проблемой?

Хм, народ стал какой то не активный в последнее время.

Проблему решил сам. Если кому будет интересно то проблема была в том что удаленный nodeagent не мог подключиться к DAS через jmx. Glassfish открывает по умолчанию JMX_ADMIN на порту 8686. Локально к этому порту можно без проблем подключиться, но вот удаленно с настройками по умолчанию нельзя, надо немного пошаманить в конфиге glassfish. Как многие пишут надо добавить в конфиг:

<jvm-options>-Dcom.sun.management.jmxremote.ssl=false</jvm-options>
<jvm-options>-Dcom.sun.management.jmxremote.authenticate=false</jvm-options>

и изменить следующий параметр для jmx подключения accept-all поставить значение true по умолчанию стоит значение false

<jmx-connector accept-all="true" address="0.0.0.0" auth-realm-name="admin-realm" enabled="true" name="system" port="8686" protocol="rmi_jrmp" security-enabled="false">

Для ОС Windows этих телодвижений достаточно, но в Linux работать отказывается и на удивление практически нигде не написано. Для того чтобы заработало в linux необходимо добавить в конфиг glassfish следующую строку:

-Djava.rmi.server.hostname=your_hostname

Надеюсь кому нибудь будет полезно при построении кластера.

mrtmexx ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.