LINUX.ORG.RU

[gentoo][madwimax]internet


0

1

Доброго времени суток.

Есть:

/*\ linux kernel v2.6.36-gentoo-r5 (от genkernel)

/*\ device drivers -> network device support -> universal TUN/TAP device driver support (было * и M)

/*\ madwimax

/*\ samsung swc-u200

/*\ #modprobe tun

/*\ asus eee pc 1005ha

/*\ lsusb: Bus 001 Device 011: ID 04e8:6761 Samsung Electronics Co., Ltd

/*\ lspci -nn:

01:00.0 Ethernet controller [0200]: Attansic Technology Corp. Device [1969:1062] (rev c0)

02:00.0 Network controller [0280]: Atheros Communications Inc. Device [168c:002b] (rev 01)

Нету:

/*\ lsmod | grep tun

/*\ ./madwimax

Device found Claimed interface failed to allocate tap interface You should have TUN/TAP driver compiled in the kernel or as a kernel module. If 'modprobe tun' doesn't help then recompile your kernel.

Что я делаю не так/чего не делаю? // Спасибо

1. Добавьте загрузку модуля tun при старте системы.

# cat /etc/conf.d/modules
# You can define a list modules for a specific kernel version,
# a released kernel version, a main kernel version or just a list.
modules="tun"

2. Перезапустите /etc/init.d/modules

# /etc/init.d/modules restart

После этого выньте (если уже вставлен) и вставьте модем.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

Проблема в том, что модуля то и нет...

С некоторых пор автозагрузка модулей в /etc/modules.autoload.d/kernel-2.6 , вписывается же как 'tun'. Или тут речь о другом?

Kenarus ()
Ответ на: комментарий от Kenarus

Если вы выбрали device drivers -> network device support -> universal TUN/TAP device driver support [m], то поддержка tun/tap интерфейсов должны быть собрана модулем под ядро на которое указывает ссылка /usr/src/linux, и команда modprobe tun должна загружать модуль, так же как и модуль должен загружаться, по указанию в файле /etc/conf.d/modules сюда /etc/modules.autoload.d/kernel-2.6 ничего не надо вписывать.

Проверьте что редактируете конфигурационный файл того ядра, под которым работаете и соответственно собираете тоже правильную версию ядра, если у вас их несколько.

Выполните:

eselect kernel set `uname -r`
genkernel all --menuconfig

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

«по указанию в файле /etc/conf.d/modules» В этом и беда -

@@@ 7.e. Модули ядра

Настройка модулей

Модули, которые требуется загружать автоматически, нужно указать в /etc/modules.autoload.d/kernel-2.4 (или kernel-2.6). Также, при желании, модулям можно сообщить дополнительные параметры.

Для просмотра всех доступных модулей запустите команду find, заменив «<версия ядра>» на версию только что собранного ядра: ... @@@

1

!!! Error: Target «2.6.30-gentoo-r6» doesn't appear to be valid! exiting

2

* Gentoo Linux Genkernel; Version 3.4.10.907 * Running with options: all --menuconfig

* ERROR: kernel source directory «/usr/src/linux» was not found!

* — Grepping log... --

* Gentoo Linux Genkernel; Version 3.4.10.907 * Running with options: all --menuconfig

* ERROR: kernel source directory «/usr/src/linux» was not found!

* — End log... --

* Please consult /var/log/genkernel.log for more information and any * errors that were reported above.

* Report any genkernel bugs to bugs.gentoo.org and * assign your bug to genkernel@gentoo.org. Please include * as much information as you can in your bug report; attaching * /var/log/genkernel.log so that your issue can be dealt with effectively. * * Please do *not* report compilation failures as genkernel bugs! *

Kenarus ()
Ответ на: комментарий от Kenarus

Я вам написал что нужно редактировать файл /etc/conf.d/modules не просто так, так делается в Gentoo, стартовые скрипты используют этот файл настроек. Русская версия Handbook давно не обновлялась, поэтому там много ошибок и отличий от текущей версии системы, поэтому сделайте так как я вам написал и не надо упираться.

Если у вас нет /usr/src/linux не понятно как вы собирали ядро, вы его случаем не скопировали с minimalcd ?

Сейчас ставьте исходные коды ядра gentoo-sources и выполните конфигурирование и сборку ядра.

# emerge gentoo-sources
# eselect set <версия установленного пакета с исходными текстами ядра>
# genkernel all --menuconfig

При конфигурировании ядра не забудьте указать поддержку TUN/TAP устройств, поддержку контроллера жестких дисков (SATA/IDE) и фаловой системы корневого раздела.

После этого если tun/tap собран модулем укажите его загрузку там где я указал, если монолитно собран, то соответсвенно не надо.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

Именно так и поступил. Сейчас rtfm, прочтенным воспользуюсь спасибо!

Kenarus ()
Ответ на: комментарий от Zhbert

Делал так, неправильно полагаю?

# cp /etc/init.d/net.lo0 /etc/init.d/net.wimax0 # echo 'config_wimax0=«dhcp»' >> /etc/conf.d/net # /etc/init.d/net.wimax0 start /I do it ;) => !!!Error...

Или Вы говорите о том, что у Вас работает без «tun»?

// Предыдущую тему я отметил, как решенную => она закрыта? (Перед созданием этой. Другое дело - что решением служило создание аналогичной темы, но в другом разделе.)

Kenarus ()
Ответ на: комментарий от Kenarus

>Или Вы говорите о том, что у Вас работает без «tun»?

Насколько я помню, без. Ибо я никаких модулей ЕМНИП не подгружал.

Zhbert ★★★★★ ()
Ответ на: комментарий от Zhbert

Принял, возможно, когда-нибудь потом тогда..

Вроде как темы исчерпаны. ( http://www.linux.org.ru/forum/linux-hardware/6012202 http://www.linux.org.ru/forum/general/6014253 )

Решается:

rtfm (handbook: пункты 7d-8)

http://www.linux.org.ru/forum/general/6014253?lastmod=1300194827183#comment-6... (c) kostik87

Спасибо: Zhbert, kostik87(!), ChALkeR.

Темы можно закрыть.

Kenarus ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.