LINUX.ORG.RU

[lighttpd]Странное поведение


0

1

При включенном fastcgi лайти не отдает содержимое каталога. Стоит закомментировать все что связанно с fastcgi в конфиге - все отдается как надо.

Конфиг:

# lighttpd configuration file

server.modules = ( 

	"mod_fastcgi",

)

 fastcgi.server = ( 
 ".php" => 
   ( "localhost" => 
     ( 
       "socket" => "/tmp/php-fastcgi.socket", 
       "bin-path" => "/usr/bin/php-cgi" 
     ) 
   ) 
)

server.network-backend = "write"
dir-listing.activate	= "enable"

server.document-root = "/mnt/site"

index-file.names = ( "index.html", "default.html", "index.htm", "default.htm" )

## mimetype mapping
mimetype.assign = (  
	".pdf"   => "application/pdf",
	".class" => "application/octet-stream",
	".pac"   => "application/x-ns-proxy-autoconfig",
	".swf"   => "application/x-shockwave-flash",
	".wav"   => "audio/x-wav",
	".gif"   => "image/gif",
	".jpg"   => "image/jpeg",
	".jpeg"  => "image/jpeg",
	".png"   => "image/png",
	".css"   => "text/css",
	".html"  => "text/html",
	".htm"   => "text/html",
	".js"    => "text/javascript",
	".txt"   => "text/plain",
	".dtd"   => "text/xml",
	".xml"   => "text/xml"
 )


$HTTP["url"] =~ "\.pdf$" {
	server.range-requests = "disable"
}

static-file.exclude-extensions = ( ".php", ".pl", ".fcgi" )

server.pid-file = "/var/run/lighttpd.pid"

fastcgi.server = (
	".php" => (
		"localhost" => (
			"socket" => "/tmp/php-fastcgi.socket",
			"bin-path" => "/usr/local/bin/php"
		)
	)
)

Продублированный блок

fastcgi.server = (
   ".php" => (
      "localhost" => (
         "socket" => "/tmp/php-fastcgi.socket",
         "bin-path" => "/usr/local/bin/php"
      )
   )
)
так и задуман?

vaulter ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.