LINUX.ORG.RU

2gentoo OR openrc: clock_synctohc


0

1

В /etc/conf.d/hwclock задал:

# If you want to set the Hardware Clock to the current System Time 
# (software clock) during shutdown, then say "YES" here.
# You normally don't need to do this if you run a ntp daemon.
clock_systohc="NO"
как это должно работать?

задавал что YES , что NO. В результате все-равно при

rc-service ntp-client restart
rc-service hwclock restart
в системе получаю время биоса, а не наоборот, при обоих вариантах(!) или все правильно, что-то другое должно происходить?

★★★★★

Написано: «during shutdown». Т.е. этот параметр влияет только на то, будет ли системное время (soft clock) устанавливаться с биос при выключении. Бывает нужно, когда по какой-то причине системные и железные часы за время работы сильно расходятся.

Round ★★ ()
Ответ на: комментарий от Round

Т.е. для проверки работы этого сервиса/скрипта перезапустить машину обязательно надо?
Вроде как пробовал результат один и тот же, но пробовал как машины перезапуск, так и просто самого сервиса в данный момент (хоть и runlevel boot у него)

NK ★★★★★ ()
Ответ на: комментарий от daemonpnz

Посмотрел init-скрипт, там действительно что-то такое есть:

save()
{
	clock_systohc=yes
	stop
}
Не подскажите, а что это сделает, что обязательно команда такая нужна «/etc/init.d/hwclock save» ?

NK ★★★★★ ()
Ответ на: комментарий от daemonpnz

Сделал «/etc/init.d/hwclock save» - все записалось, надо же

# hwclock 
Чтв 03 Фев 2011 12:05:10  -0.596385 секунд
# /etc/init.d/hwclock save                 
hwclock           | * Setting hardware clock using the system clock [Local Time]  [ ok ]
# hwclock                 
Чтв 03 Фев 2011 13:42:45  -0.745001 секунд
Но возникает вопрос, при выключении/перезагрузки почему не записывается? Сейчас вот над эти вопросом думаю

NK ★★★★★ ()
Ответ на: комментарий от NK

Для того, чтобы сохранялось при перезагрузке hwclock должен быть в boot runlevel, а опция clock_systohc в файле /etc/conf.d/hwclock дожна быть YES.

daemonpnz ★★★★★ ()
Ответ на: комментарий от daemonpnz

hwclock должен быть в boot runlevel

# rc-update show | grep hwc
              hwclock | boot

опция clock_systohc в файле /etc/conf.d/hwclock дожна быть YES

# cat /etc/conf.d/hwclock | grep clock_synctohc=
clock_synctohc="YES"

Все так и проставлено, но что-то не срабатывает(

Только вот, как выяснилось на «/etc/init.d/hwclock save» срабатывает

NK ★★★★★ ()

Все, всем спасибо, ошибка в init-скрипте была с переменной(
возможно, после обновлений старый конфиг остался или сам скрипт

NK ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.