LINUX.ORG.RU

Как нарисовать структуру базы данных?


0

1

Мне не ясно, как нарисовать базу данных в Monodevelop
http://www.linux.org.ru/gallery/5547674.png
аналогично тому, как это делается в MS SQL Server Enterprise Manager
или erwin

Что посоветуете для gentoo? Предпочтительно плагин под Eclipse, в него больше веры.

Требования:
- бесплатность
- нативность (без всяких там wine, чтобы с исходниками)
- гентушность (наличие ebuild-а, отсутствие fetch restrictions)
- удобность

Так же помогли бы ссылки на статьи, где описано, как эту структуру рисовать под linux (где люди опытом делятся)

MySQL Workbench не готов - http://bugs.gentoo.org/show_bug.cgi?id=345021

Database Modeller - 0.3 (http://oxygene.sk/lukas/projects/dbmodel/)
http://www.linux.org.ru/news/opensource/4513433
Отсутствует экспорт в ddl

DBVisualiser
умеет по существующей структуре создавать схемы данных,
но тут структура должна уже существовать
и нельзя добавить коментарии на русском.

Dia
в диа нету ER для баз данных. UML это тоже не то. То, что на этом скриншоте - http://img.flashtux.org/img132b46d112a9xd49ee9e7.png
это злостная неюзабельность, сравните с MS SQL Enterprise Manager

UMLet = Free UML Tool for Fast UML Diagrams
http://www.umlet.com/
Потому что мне не нужен UML, мне нужен аналог ErWin, в котором нифига UML-ля не было раньше,
там все про базы данных, их модели, скрипты и как потом генерировать в обе стороны

Visual Paradigm UML Modeller Community Edition, в нем есть редактор диаграм БД
http://images.visual-paradigm.com/screenshots/vpuml70/linux/erd.png
при сохранении водяные знаки ставит

Oracle SQL Developer - я не понял, сохранять то, что рисуется при помощи Tools-Data Modeler, а так же как рисовать там.

либо MS SQL Enterprise Manager это проплаченный пост MS SQL Enterprise Manager, либо близится новый релиз MS SQL Enterprise Manager потому что MS SQL Enterprise Manager на единицу текста зашкаливает. MS SQL Enterprise Manager.

и таки не совсем понятно, чем тебе не угодил MS SQL Enterprise Manager?

Anoxemian ★★★★★ ()

гентушность

удобность


Logical error. System will be destroyed.


anonymous ()
Ответ на: комментарий от Anoxemian

не удовлетворяет требованиям бесплатности, навтивности и гентушности

ArsenShnurkov ()
Ответ на: комментарий от JFreeM

Для первого нет ебилдов
http://bugs.gentoo.org/show_bug.cgi?id=345063

для второго есть (в оверлее gentoo-taiwan), но не ставится:

# emerge -av =dev-db/dbdesigner-4.0.5.4

* IMPORTANT: 1 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy «x11-libs/kylixlibs3-borqt».
(dependency required by «dev-db/dbdesigner-4.0.5.4» [ebuild])
(dependency required by «=dev-db/dbdesigner-4.0.5.4» [argument])

ArsenShnurkov ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.