LINUX.ORG.RU

Установка Qt 4.7.0


0

1

Не собирается под Gentoo Qt 4.7.0:

In file included from ../../include/QtGui/private/qtextdocument_p.h:1,
                 from ../../include/QtGui/private/../../../src/gui/text/qtextengine_p.h:70,
                 from ../../include/QtGui/private/qtextengine_p.h:1,
                 from itemviews/qabstractitemdelegate.cpp:53:
../../include/QtGui/private/../../../src/gui/text/qtextdocument_p.h:256: ошибка: ‘QTextDocument::Stacks’ has not been declared
make[1]: *** [.obj/release-shared/qabstractitemdelegate.o] Ошибка 1
make[1]: *** Ожидание завершения заданий...
make[1]: Выход из каталога `/home/dominator/Packages/qt-everywhere-opensource-src-4.7.0/src/gui'
make: *** [sub-gui-make_default-ordered] Ошибка 2

Как исправить?

ложь!
собирается на раз!
как обновляешь?

megabaks ★★★★ ()
Ответ на: комментарий от megabaks

>т.е. ты считаешь софт установленный в обход пакет-манагера няшней?

Где ты там установку увидел? Там только компиляция.

bind2cppman ()
Ответ на: комментарий от bind2cppman

ты упоротый!
нах конпелять если не ставить?
пересобери мир тогда уж - полезней будет!
100% гарантия!

megabaks ★★★★ ()

ТС, а ты забавный ^_^
хочешь решения проблемы - тебе сказали что и как - ты кидаешься какашками
быдло на ЛОР-е!
галактико опасносте!

megabaks ★★★★ ()

Что эта тема делает в General?
По теме: эта ошибка при первой компиляции появляется или ты второй раз в одном дереве компилируешь?

UVV ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.