LINUX.ORG.RU

Проблемы с GRUB


0

0

Начну с начала. Решил поставить Ubuntu 10.04. На момент установки были подключены:

- винт с windows xp (первый ide-канал, позиция master, серый разьем (уже потом вычитал, что серый разьем отвечает за slave, черный - за master)) (sda);

- винт, на который будет устанавливаться Ubuntu (второй ide канал, позиция master, черный разьем) (sdb);

- dvd-rom (второй ide канал, позиция slave, серый разьем). На последнем экране установки выбрал ставить загрузчик на sda (винт с windows xp).

Ubuntu была успешно установлена. Позже был подключен еще один винт (sdc) на второй канал вместо dvd-rom'a. Потом мне захотелось подключить еще один винт на свободный разьем на первом канале. Подключил, во время загрузки Ubuntu выдала ошибку «The disk drive for /home is not ready yet or not present», нажал S. Ubuntu, естественно, толком не загрузилась. Подцепил dvd-rom на это же место - результат тот же. Тогда решил подключить sda к первому разьему на первом ide-канале. После POST-экрана выдало ошибку «no such device ...». Если оставляю в системе только один винт sda, на котором есть mbr, то система тоже не грузится. Получилось так, что sda и sdb зависят друг от друга. Хотя не понятно, почему sda зависит от sdb, mbr ведь на sda.

Решил тогда поставить GRUB на sdb, чтобы убрать зависимость винтов друг от друга. Подключил устройства следующим образом:

- винт с windows xp (первый ide-канал, позиция master, черный разьем) (sda);

- винт с Ubuntu (второй ide канал, позиция master, черный разьем) (sdb);

- dvd-rom (первый ide канал, позиция slave, серый разьем).

Загрузился с live-cd, выполнил команду grub-install /dev/sda, предварительно примонтировав нужные папки и разделы. GRUB поставился, выключил комп, отключил все винты кроме sdb. Включаю, загружается грубовское меню с теми же пунктами, что и раньше. Выбираю загрузку Ubuntu - во время загрузки выдает ошибку «The disk drive for /home is not ready yet or not present». Плюнул на это дело, поставил винты как раньше, за тем лишь исключением, что sda теперь стоит на черном разьеме первого ide-канала.

В общем, хочется-таки подключить четвертый винт и сделать так, чтобы sdb не зависел от sda. Как это осуществить? Материнская плата - Elitegroup L4S5MG3. Судя по документам, она поддерживает 4 ide-устройства. Винты и шлейфы исправны.

tldr

Маретинка старая похоже, раз два шлейва IDE — может быть чехарда с присвоением буквы.

«The disk drive for /home is not ready yet or not present»

Похоже, в fstab стоит привязка к букве, а не к ID. Надо внимательно отследить очередность наименования дисков.

anonymous ()

В общем, хочется-таки подключить четвертый винт и сделать так, чтобы sdb не зависел от sda.

grub install на sdb. Очевидно же.

На sda сделать fixboot, fixmbr из консоли восстановления Windows.

iZEN ★★★★★ ()

Слишкам многабукав, ниасилил

Какой sda sdb, пациент вы что? В нашей маленькой прогрессивной психиатрической больнице всем кроватям присвоены UUID!

darkshvein ☆☆ ()

У меня без отдельного хомяка нормально грузится. Да и буквы подправить в фстаб не так долго потом.

darkshvein ☆☆ ()

Никогда не рекомендовал вешать более одного устройства на один ide-канал... Переходите на sata, там проблем нет.

Igron ★★★★★ ()
Ответ на: комментарий от anonymous

Поправил fstab, прописав UUID. Теперь нормально загружается. Но четвертый винт подцепить так и не получилось. Система виснет еще на первом POST-экране на Detecting IDE drives. Грузится только если к первому каналу подключен один винт.

alter1989 ()

Загрузитесь с livecd, откройте терминал, поднимите сеть, набирайте:
sudo -i
wget -O chroot.sh http://omploader.org/vNTNqbA
fdisk -l # по размеру найдите свой раздел с ubuntu /
chmod u+x chroot.sh
./chroot.sh /dev/sdXY # XY подставить свои
dpkg-reconfigure grub-pc # ответьте на несколько вопросов, в частности, куда ставить загрузчик. попробуйте поставить загрузчик на все диски
exit
exit
exit # окно закроется

AITap ★★★★★ ()
Ответ на: комментарий от alter1989

>Поправил fstab, прописав UUID. Теперь нормально загружается. Но четвертый винт подцепить так и не получилось. Система виснет еще на первом POST-экране на Detecting IDE drives. Грузится только если к первому каналу подключен один винт.

Проверь перемычки. Винты на одном канале должны быть в разных режимах (master/slave).

AptGet ★★★ ()
Ответ на: комментарий от AptGet

Перемычки стояли в разных режимах, но BIOS по каким-то причинам не хотел видеть винт, висящий на primary slave. Недавно попереставлял винты местами и таки удалось добиться подключения всех четырех винтов. Таким образом, проблема решена. Всем спасибо за помощь.

alter1989 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.