LINUX.ORG.RU

Нестандартные проблемы со шрифтами


0

0

Поставил ttf шрифты как обычно это делал (скопировал все в папку /usr/share/fonts/ttf/, ttmkfdir, mkfontdir, прописал fontpath в XF86Config-4 и /etc/fonts/fonts.conf). Шрифты появились, но только в GTK2 и QT прогах. В GTK1, xlsfonts, xfontsel их не видно! Пробовал "порэдхатовски" - через XFS, безрезультатно. Дистр - RedHat 9.

anonymous

Re: Нестандартные проблемы со шрифтами

а LoadModule какие? поиграйся с "type1" "ttf", вроже еще "truetype" есть или как его там

hooj ★★ ()

Re: Нестандартные проблемы со шрифтами

If you wish to add new fonts to your Fedora Core 1 system, you must be aware that the steps necessary depend on which font subsystem is to use the new fonts.

For the core X font subsystem, you must:

1. Create the /usr/share/fonts/local/ directory (if it doesn't already exist):

mkdir /usr/share/fonts/local/

2. Copy the new font file into /usr/share/fonts/local/

3. Update the font information by issuing the following commands (note that, due to formatting restrictions, the following commands may appear on more than one line; in use, each command should be entered on a single line):

ttmkfdir -d /usr/share/fonts/local/ -o /usr/share/fonts/local/fonts.scale

mkfontdir /usr/share/local/

4. If you had to create /usr/share/fonts/local/, you must then add it to the X font server (xfs) path:

chkfontpath --add /usr/share/fonts/local/

Adding new fonts to the fontconfig font subsystem is more straightforward; the new font file only needs to be copied into the /usr/share/fonts/ directory (individual users can modify their personal font configuration by copying the font file into the ~/.fonts/ directory).

After the new font has been copied, use fc-cache to update the font information cache:

fc-cache <directory>

(Where <directory> would be either the /usr/share/fonts/ or ~/.fonts/ directories.)

Individual users may also install fonts graphically, by browsing fonts:/// in Nautilus, and dragging the new font files there.

NOTE: If the font filename ends with ".gz", it has been compressed with gzip, and must be decompressed (with the gunzip command) before the fontconfig font subsystem can use the font.

Due to the transition to the new font system based on fontconfig/Xft, GTK+ 1.2 applications are not affected by any changes made via the Font Preferences dialog.

For these applications, a font can be configured by adding the following lines to the file ~/.gtkrc.mine:

style "user-font" {

fontset = "<font-specification>"

}

widget_class "*" style "user-font"

(Where <font-specification> represents a font specification in the style used by traditional X applications, such as "-adobe-helvetica-medium-r-normal--*-120-*-*-*-*-*-*".)

Demetrio ★★★★★ ()
Ответ на: Re: Нестандартные проблемы со шрифтами от Demetrio

Re: Re: Нестандартные проблемы со шрифтами

Безрезультатно :(

Это я и выполнял, только проще и вместо chkfontpath вручную font path приписывал для XFS в /etc/X11/fs/config. После этих действий шрифты-то появляются, да только в GTK2 и QT прогах.

anonymous ()
Ответ на: Re: Re: Нестандартные проблемы со шрифтами от anonymous

Re: Re: Re: Нестандартные проблемы со шрифтами

А ты всё-таки сделай так, как там написано ;)

Тогда и работать всё будет.

Или тупо поставь rpm со шрифтами, он сам всё сделает.

Demetrio ★★★★★ ()

Re: Re: Re: Re: Re: Нестандартные проблемы со шрифтами

Чтобы сильно не мучаться -

убери всё что там копировал/редактировал и поставь это:

http://ftp.ibiblio.org/pub/Linux/distributions/contrib/texstar/pclinuxos/apt/...

http://ftp.ibiblio.org/pub/Linux/distributions/contrib/texstar/pclinuxos/apt/...

Demetrio ★★★★★ ()

Re: Нестандартные проблемы со шрифтами

Section "Module"
Load "freetype"
...

jackill ★★★★★ ()

Re: Нестандартные проблемы со шрифтами

Забыл - есть еще идиотизм, непонятно с чем связанный. Шрифты, названия которых набраны большими буквами, почему-то не видно, начиная с X4.3.0
Такая вот загадка.

jackill ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.