LINUX.ORG.RU

[Ubuntu 10.04] Проблема зависания при загрузке


0

0

Доброго времени суток, участники форума.

Хочу поделиться проблемой, с которой боролся около суток (и, судя по тем форумам на которые я попадал, я не один такой).

Решил я поставить Убунту 10.04 на свой ноутбук (Samsung R18+: celeron M 530, 2 GB ram). Изначально хотел поставить 64-х битовую версию (до этого успешно работала 9.10 64 бита). Однако, наткнулся на то, что при попытке загрузки или установки с лайвсд после выбора соответствующего пункта меню получал «зависший» черный экран (не троллинга ради, и это система, которая должна просто РАБОТАТЬ!). Затем решил обновиться через менеджер обновлений и после успешного обновления всех пакетов через вэб после плановой перезагрузки, внезапно я снова наблюдал «зависший» черный экран.

Но я без боя не сдаюсь: вернул на место старую 9.10; скачал 32-х битовую версию 10.04; и далее продолжил устанавливать дистрибутив.

32-х битовая версия при попытке загрузки с лайвсд приводила к аналогичному 64-х битовой результату - зависший черный экран.

Продолжив поиски решений тут я нашел решение, суть которого в использовании режима nomodeset. Это помогло добраться до процесса непосредственной установки. Однако, после перезагрузки пункт 2 первого решения не сработал и пришлось самому вручную, загрузившись с лайвсд, редактировать конфигурацию груба.

Собственно, этот пост пишу из установленной 10.04. Однако при загрузке системы вместо переливающейся заставки вижу нелицеприятные текстовые сообщения (хотя прекрасно понимаю, что это следствие удаления параметра splash).

Хочу спросить у более опытных товарищей правильно ли я понимаю, что сочетание параметров nomodeset и splash избавит меня от созерцания текстовых сообщений этапа загрузки и не приведет к слому загрузки системы?

Также буду рад прочесть дельные советы.

★★★

plymouth может работать и без KMS. echo GRUB_GFXPAYLOAD_LINUX=1024x768 >> /etc/default/grub && update-grub если не хотите любоваться на лого убунты в 16 цветах 640x480.

Deleted ()
Ответ на: комментарий от Deleted

я так понял вся проблема в том, что у меня встроенная видео карта ati x1250.

Правильно я понимаю, что разрешение экрана я могу поставить какое угодно (например, 1280x800):

GRUB_GFXPAYLOAD_LINUX=1280x800 >> /etc/default/grub && update-grub

на данный момент в /etc/default/grub я заменил

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
на
GRUB_CMDLINE_LINUX_DEFAULT="nomodeset"

Нужно ли мне вернуть исходный вариант?

Genuine ★★★ ()
Ответ на: комментарий от Deleted

спасибо.

в некотором смысле помогло: теперь при включении секунд 5 или 6 я наблюдаю мигающий курсор, затем в течении не более пары секунд индикатор загрузки. Но, главное, от текстовых сообщений это меня избавило. Еще раз, спасибо.

Genuine ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.